Bug 125384 - esd causes audio_alsa: no cards found message in FC2
esd causes audio_alsa: no cards found message in FC2
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gnome-session (Show other bugs)
2
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-05 15:16 EDT by Richard Miles
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-11 17:35:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Miles 2004-06-05 15:16:56 EDT
Description of problem:
When trying to start gnome the system stops. The console shows
audio_alsa: no cards found messages followed by Esound failed to
start. This only happens from a user login not when logging in as
root. The start up messages show that the sound is recognized for
snd_ens1371 card. Further I can hear sound if I type play to play a
.wav file.

Version-Release number of selected component (if applicable):
esound-0.2.34-2

How reproducible:
Try to start X windows with startx command

Steps to Reproduce:
1. Enter startx gnome stops
2. Check console messages
3. Notice audio_alsa: no cards found messages followed by Esound
failed to start message
  
Actual results:
Gnome fails to start. Checking console messages shows above mentioned
messages. Note this does not occur if I log in as root. Sometimes
gnome will start but the system sounds do not occur. Gnome-alsamixer
produces a blank settings screen. xmms will not play .wav files but
the play command will produce sound. All sounds are heard if logging
in as root.

Expected results:
Gnome will start and system sounds are heard and xmms play sounds and
gnome alsamixer shows controls.

Additional info:
I hate to be root. But that is what I must be to usually start gnome
and hear sounds.
Comment 1 Jarkko 2004-06-21 07:28:48 EDT
I'm having the exact same problem. First I thought it was because of 
SELinux because I couldn't login graphically (I was suprised that 
upgrading enables SELinux because it is not the default when doing a 
fresh install).

It feels very weird that neither of my sound cards are detected. Both 
worked fine in FC1. There are also many "FAILED" messages on system 
startup and shutdown. This FC2 seems to be released too early. It 
does not seem to be stable at all.

I think I'll do a fresh install. Although I doubt it will help at all.
Comment 2 Jarkko 2004-06-22 05:31:17 EDT
Ok, I've now installed everything from scratch (not upgraded,
installed). Now my sound cards are detected. So the CD upgrade is not
working properly.

I'm still having some problems. If I change volume levels in alsamixer
or volume control, it does not have any effect. For example I have CD
volume up but I can't hear anything with CD player. I can hear PCM
sound but the slide position does not have any effect on it's volume.

Other FC2 problem: On the startup I see LVM saying "FAILED".
Comment 3 Jarkko 2004-06-22 06:59:29 EDT
It seems that the "no effect" problem occurs with alsa only. The other
one of my cards has an oss mixer too and that one is working normally.
Comment 4 Richard Miles 2004-06-22 20:00:29 EDT
Well I have resisted trying a fresh install because I have alot of
software installed and did not want to reinstall them. But if a fresh
install will stop the problem of not starting in Gnome-session and
allow me to hear sound then that is what I will do. Thanks for the
comments Jarkko. By the way alsa usually starts up with the volumes
muted. Only after you system-sonfig-soundcard and play a test sound
does the volumn settings stay on a reboot. I know that starting an
install from scratch will is a cop out but I am stumped trying to get
this to work for a user login.
Comment 5 Jarkko 2004-06-23 01:30:27 EDT
Fresh install works. Yes, there are quite a lot of configuring and
installing to do afterwards because you'll loose all your
configurations and third party software.

ALSA was first muted and I managed to get sound after some time. The
only problem with it is that the mixer settings seem to effect only
after reboot or something. That OSS mixer works like it should.

That LVM problem was a bug in lvm2. It is fixed in the development -
no red FAILED message anymore (although I'm still getting "setlocal
failed" from it).

It seems that the upgrading from FC1 to FC2 has not been tested
enough. I truly hope this won't happen when we switch from FC2 to FC3
in the future. Upgrading should be swift.
Comment 6 Richard Miles 2004-06-23 17:07:25 EDT
Well I bit the bullet and installed FC2 from scratch. I can now startx
and gnome-session without a problem. I now can hear system sounds. So
I guess this bug has to do with anaconda on an upgrade. I don't know
what the upgrade process did to not make it work.
Comment 7 Net Nut 2004-06-25 20:19:16 EDT
I have upgraded two machines from FC1 to FC2.
One's esd works fine.. the other (my laptop) does not.
on thing that is different for me than a previous report is esd does
not work for any user (even root) sounds will play fine as long as it
does not use esd support.

please help.. thanks...
Comment 8 Net Nut 2004-06-26 04:07:31 EDT
FYI I have forcibly uninstalled esd and esd-devel, and installed the
ones from fedora core 1 and the esd worked again.. 
Comment 9 Starchild 2004-07-09 05:04:45 EDT
>Additional Comment #8 From Net Nut  on 2004-06-26 04:07 -------
>
>FYI I have forcibly uninstalled esd and esd-devel, and installed the
>ones from fedora core 1 and the esd worked again.. 

Tried, didn't work for me. What version of esound for fc1 were you using?

I have found another workaround, btw.

If you run 'esd --help' as root you will see a list of possible
devices att the bottom.

In my case it shows:
Possible devices are:  hw:0  (Sound Blaster Live!)

(As regular user it shows:
Possible devices are:  No available cards found)

So what I do is run 'esd -d hw:0' as user berfore I start anything
that needs esd as user.

Works for me, though it would be nice to know how fix it so that esd
finds the device by itself as user.

/Krister
Comment 10 Starchild 2004-07-11 15:51:54 EDT
Ok, update to my workaround...

My workaround by doing 'esd -d hw:0' seems to have stoped working...
However, it seems to work again after I added -d hw:0 to spawn_options
in /etc/esd.conf

I currently looks like:
-------start esd.conf-------------
[esd]
auto_spawn=1
spawn_options=-terminate -nobeeps -as 2 -d hw:0
spawn_wait_ms=100
-------end esd.conf---------------


Also all my sound stuff in /dev/ seemed to have permissions
0600 root root, and is set automatically by pam. I changed the 

permissions for them in /etc/security/console.perms to 0666.
I know thet should 0660 and belong to 'audio' or 'sound' group, but
that I'll fix later. It did not seem to have any effect on the problem
however. esd --help still shows it doesnt detect anything as user.

I can't use alsa output as user either, works fine as root though.

OSS does work as user, so can at least get some sound without su:ing
to root.

alsa modules aren't loaded automatically either.
I have to do modprobe -i snd-emu10k1 manually.
I'm not sure how related this is, but I thought it worth mentioning.

/Krister
Comment 11 Starchild 2004-07-16 06:00:22 EDT
Hi! Me again!:)
I noticed that /dev/snd/* were all set 0600 on my system.
This isn't really a good thing, right?
Also, /dev/snd/* was not mentioned in my /etc/security/console.perms
either.

Well I added it, and changed the premissions to 0666.

I think things improved. Now when I run 'esd --help' I get 
"audio_alsa: Error: control open (0): Permission denied"
repeated over end over at the end, instead of just a
"Possible devices are:  No available cards found"

Now I just need figure out what permission to change and where I can
change it. *sigh*

/Krister
Comment 12 Starchild 2004-07-16 06:29:43 EDT
Ok, people, you may now commence worship! (Or not, as you choose;))

I found this little beauty:
http://www.mail-archive.com/alsa-user@lists.sourceforge.net/msg10746.html

Basically, the permissions of the /dev/snd itself was set to 0700.
You need to set its permissions to executable for everyone that you
want to have alsa sound.

It now works:)

Both esd and alsa work as expected now, regardless of wether you are
root or user.
Comment 13 Alexandre Strube 2004-08-29 17:29:17 EDT
Thanks, Starchild. Works like a charm.

Is this the problem which prevents gnome environment from loading?
Comment 14 Matthew Miller 2005-04-26 12:24:11 EDT
Fedora Core 2 is now maintained by the Fedora Legacy project for
security updates only. If this problem is a security issue, please
reopen and reassign to the Fedora Legacy product. If it is not a
security issue and hasn't been resolved in the current FC3 updates or
in the FC4 test release, reopen and change the version to match.
Comment 15 Ray Strode [halfline] 2005-05-11 17:35:28 EDT
Hi,

This bug is being closed because it has been in the NEEDINFO state for a long
time now.  Feel free to reopen the bug report if the problem still happens for
you and you can provide any information that was requested.

Note You need to log in before you can comment on or make changes to this bug.