Bug 125385 - up2date gets package version numbers out of sync
up2date gets package version numbers out of sync
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: libxml2 (Show other bugs)
1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Veillard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-05 15:34 EDT by Aaron..
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-26 18:03:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aaron.. 2004-06-05 15:34:12 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
redhat updated gets libxml2 and libxml2-devel package version numbers
out of sync causing the development tools from the cd not to install.
 the libxml2 is update but libxml2-devel package is not.

Version-Release number of selected component (if applicable):
rpm-4.2.1-0.30 kernel-2.4.22-1.2188.nptl

How reproducible:
Didn't try

Steps to Reproduce:
1.install fedora core 1 do not install any development tools
2. do all redhat updates libxml2 is in the list
3. now try to install the development tools from the cd to be able to
get them installed you will have to update libxml2-devel to the same
version as libxml2
    

Expected Results:  Development tools package manager will give error
unable to locate package libxml2

Additional info:
Comment 1 Aaron.. 2004-06-05 15:40:25 EDT
	
aaronruss
	
installing Development tools 	( post #1)

I am trying to install the Development tools on my fedora core 1
system and I get a error unlocatable package libxml2 but when using
the command rpm -q --all | grep libml2 I get the following

[root@server root]# rpm -q --all | grep libxml2
libxml2-2.6.6-3
libxml2-python-2.6.6-3
[root@server root]#

so if libxml2-2.6.6-3 is installed why will gcc not install?

Here is what I get when trying to install the Development Tools from
the Fedora Core 1 CD

Package not found unlocatable package libxml2 required by
libxml2-python-2.6.6-3

I dont get it I cant install the Development Tools because the package
cant be found but its installed.

What do I need to do to get the Package Manger to find it?

__________________
OS = Fedora Core 1
Desktop = Gnome
Computer = Dell Power Edge 1400 SC

Dark_Helmet

	( post #2)

The only thing I could think to try is rebuilding your rpm database:
rpm --rebuilddb

I don't use rpms now (if I can avoid it), but remember a long while
back that a package got "lost" and rpm would say that it was either
installed or not present (depending on which answer would cause me the
most grief). Rebuilding the database semed to clear it up, but that
was many moons ago.

darthtux

	( post #3)

It may be looking for the development package
libxml2-dev

aaronruss

	( post #4)

I tried to rebuild it and I get the same thing when installing the
development tools. I also tried to install the libxml2-dev and could
not install due to the following

[root@server RPMS]# rpm -i libxml2-devel-2.5.11-1.i386.rpm
error: Failed dependencies:
libxml2 = 2.5.11 is needed by libxml2-devel-2.5.11-1
zlib-devel is needed by libxml2-devel-2.5.11-1
[root@server RPMS]#

here is my query after rebuilding

[root@server RPMS]# rpm -q --all | grep libxml
perl-libxml-perl-0.07-28
perl-libxml-enno-1.02-29
libxml-1.8.17-9
libxml2-2.6.6-3
libxml2-python-2.6.6-3
[root@server RPMS]#

libxml2 is there but a newer version. got any other ideals?

Dark_Helmet

	( post #5)

You ought to have matching version numbers between libxml2 and
libxml2-devel or as close as you can at least. I quick search on
google turned up this:
rpmfind.net - libxml2

They don't have patch level 3, but the devel and base packages ought
to be compatible. Give it a try.

aaronruss

	( post #6)

I had to get another package first the version is different on the
zlib-devel package. I hope that don't matter to much.

[root@server aaron]# rpm -i libxml2-devel-2.6.6-3.i386.rpm
error: Failed dependencies:
zlib-devel is needed by libxml2-devel-2.6.6-3

[root@server aaron]# rpm -q --all | grep zlib-devel
zlib-devel-1.2.0.7-2
[root@server aaron]#

OK i installed the same version of libxml2-devel as the others

[root@server aaron]# rpm -q --all | grep libxml2
libxml2-devel-2.6.6-3
libxml2-2.6.6-3
libxml2-python-2.6.6-3
[root@server aaron]#

After all that I put my fedora core 1 CD in and installed the
development tools from the package manager.

It Worked! the Development tools installed all is well

I have had this problem with other packages now I see that the libxml2
and libxml2-devel packages have to be the same version. I do have some
questions about this.

1) what is libxml2 and libxml2-devel and how do thay effect each other
do other packages with same first names follow this version issue.

2) I think this all started from updating libxml2 because I think I
remember it being one of the red hat updates. So if red hat is only
updating the libxml2 package and not the libxml2-devel package and the
two need to be of the same version. How do we summit this information
that they are getting the package versions out of sync with there
update service?

__________________
OS = Fedora Core 1
Desktop = Gnome
Computer = Dell Power Edge 1400 SC
Comment 2 Jeff Johnson 2004-06-06 09:19:41 EDT
I don't see any rpm problem here. If there is still a
problem, please reassign to the appropriate package(s),
like libxml2 or distribution.
Comment 3 Jeff Johnson 2004-06-07 07:40:39 EDT
This appears to be a possible libxml2 packaging problem, reassigning ...
Comment 4 Daniel Veillard 2004-08-26 18:03:32 EDT
libxml2 and libxml2-devel need to be exactly at the same version number.
If you have 1.2.3 on your CD  and upgrade libxml2 to 1.2.4 from the
network, then the libxml2-devel-1.2.3 from your CD will not install.
You will need to fetch the -devel-1.2.4 from the network too.
It's normal, not a bug and how rpm works.

Daniel

Note You need to log in before you can comment on or make changes to this bug.