Bug 1253886 - Add Python 3 subpackage
Add Python 3 subpackage
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: mapnik (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tom Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-14 22:08 EDT by Eduardo Mayorga
Modified: 2016-03-14 13:57 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-14 11:57:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eduardo Mayorga 2015-08-14 22:08:09 EDT
mapnik supports Python 3 and I need this for one of my upcoming packages.
Comment 1 Tom Hughes 2015-08-15 02:35:46 EDT
This is complicated because we're going to need to create a new package for the python bindings when we update to mapnik 3 and so far I haven't managed to get that to work with python3.
Comment 2 Jan Kurik 2016-02-24 08:37:06 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 3 Julien Enselme 2016-03-14 11:42:09 EDT
> This is complicated because we're going to need to create a new package for the python bindings when we update to mapnik 3 and so far I haven't managed to get that to work with python3.

I believe this was done. I just rebuilt the srpm from koji for my f23 and used the python3 bindings and everything works. I have some warnings though:

/usr/lib64/python3.4/importlib/_bootstrap.py:321: RuntimeWarning: to-Python converter for std::shared_ptr<mapnik::geometry::geometry<double> > already registered; second conversion method ignored.
  return f(*args, **kwds)
/usr/lib64/python3.4/importlib/_bootstrap.py:321: RuntimeWarning: to-Python converter for std::shared_ptr<mapnik::feature_impl> already registered; second conversion method ignored.
  return f(*args, **kwds)
/usr/lib64/python3.4/importlib/_bootstrap.py:321: RuntimeWarning: to-Python converter for std::shared_ptr<mapnik::Featureset> already registered; second conversion method ignored.
  return f(*args, **kwds)
/usr/lib64/python3.4/importlib/_bootstrap.py:321: RuntimeWarning: to-Python converter for std::shared_ptr<mapnik::datasource> already registered; second conversion method ignored.
  return f(*args, **kwds)
/usr/lib64/python3.4/importlib/_bootstrap.py:321: RuntimeWarning: to-Python converter for std::shared_ptr<mapnik::image_any> already registered; second conversion method ignored.
  return f(*args, **kwds)


Are they due the packaging or upstream issues?
Comment 4 Tom Hughes 2016-03-14 11:57:37 EDT
It is done for F24 but not for F23 and will not be done for F23.

The warning you are getting is a result of a bug in boost 1.60 that meant we had to register some converters explicitly because the implicit creation wasn't happening.

That has just (last week) been fixed in boost so mapnik should be able to drop them again in due course but I believe the warnings are harmless. In any case if you choose to rebuild F24 packages for F23 then you get to keep the pieces I'm afraid - it's a not a bug in Fedora if that doesn't work.
Comment 5 Julien Enselme 2016-03-14 13:57:45 EDT
> The warning you are getting is a result of a bug in boost 1.60 that meant we had to register some converters explicitly because the implicit creation wasn't happening.

Thanks for the precision. It works fine with them.

Note You need to log in before you can comment on or make changes to this bug.