Bug 1253898 - installing eclipse-jdt should not pull in eclipse-pde, eclipse-ecf-core and eclipse-emf-core for dependencies
installing eclipse-jdt should not pull in eclipse-pde, eclipse-ecf-core and e...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Alexander Kurtakov
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-15 03:23 EDT by Christian Stadelmann
Modified: 2015-09-01 14:31 EDT (History)
7 users (show)

See Also:
Fixed In Version: 3.10.1-1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-01 14:31:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Stadelmann 2015-08-15 03:23:42 EDT
Description of problem:
According to the eclipse.org website at https://eclipse.org/downloads/packages/eclipse-ide-java-developers/marsr ("Detailed feature list") Eclipse for java developers doesn't depend on eclipse-pde to be installed.
However when installing eclipse-jdt 4.4.2 or 4.5.0 on Fedora 22 it pulls in eclipse-pde, eclipse-ecf-core and eclipse-emf-core packages. Those packages pull in a lot of other dependencies and I don't want to install 20+ additional packages I won't need.
Comment 1 Alexander Kurtakov 2015-08-16 12:23:05 EDT
ecf-core and emf-core are mandatory deps and they are bundled with every eclipse platform but pde shouldn't be part of this list. To be investigated more.
Comment 2 Roland Grunberg 2015-08-17 14:04:56 EDT
I see the following packages being installed when i attempt to install 'eclipse-jdt' : http://paste.stg.fedoraproject.org/4916/ . eclipse-pde is not brought in for Fedora 22. Are you doing 'dnf install eclipse' ? It looks like 'eclipse' is actually provided by 'eclipse-pde' [1] . My guess is we did this in the past because the "Classic" Eclipse used to ship with PDE, and since PDE depended on JDT, which brought in everything else, it made sense.

In case anyone is interested in a bit of history, the first time the 'eclipse' provides was introduced, was in http://pkgs.fedoraproject.org/cgit/eclipse.git/commit/?id=619a6b2f417f5c5a771fa0fcee090c82d4705522 . The sdk package eventually got moved into pde, and so pde inherited the provide. I think since then jdt has 

Would it be safe to assume that most users don't want PDE, and so we should really make the JDT provide 'eclipse'.

[1] http://pkgs.fedoraproject.org/cgit/eclipse.git/tree/eclipse.spec?id=745b418992e92c08c2bd1910c9fa614a715a42d7#n293
Comment 3 Mat Booth 2015-08-21 06:37:53 EDT
Consensus seems to be move the provide to JDT, so I did that when making a different update to the package.
Comment 4 Fedora Update System 2015-08-26 19:24:59 EDT
eclipse-filesystem-1.0-5.fc23 eclipse-license-1.0.1-8.fc23 eclipse-ecf-3.10.1-1.fc23 eclipse-4.5.0-14.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-14367
Comment 5 Fedora Update System 2015-08-31 14:53:16 EDT
eclipse-4.5.0-14.fc23, eclipse-ecf-3.10.1-1.fc23, eclipse-filesystem-1.0-5.fc23, eclipse-license-1.0.1-8.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update eclipse-filesystem eclipse eclipse-license eclipse-ecf'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-14367
Comment 6 Fedora Update System 2015-09-01 14:31:08 EDT
eclipse-4.5.0-14.fc23, eclipse-ecf-3.10.1-1.fc23, eclipse-filesystem-1.0-5.fc23, eclipse-license-1.0.1-8.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.