Bug 1253900 - Missing routes on API end points
Missing routes on API end points
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: API (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity medium (vote)
: Beta
: --
Assigned To: Brad Buckingham
Roman Plevka
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-15 05:31 EDT by Johan Swensson
Modified: 2016-07-27 04:54 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 04:54:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 12315 None None None 2016-04-22 12:33 EDT

  None (edit)
Description Johan Swensson 2015-08-15 05:31:28 EDT
Description of problem:
These api end points are missing routes.
/katello/api/guestids
/katello/api/content_overrides
/katello/api/available_releases

These endpoints are presented at /katello/api/

Version-Release number of selected component (if applicable):
6.1.1

How reproducible:
Easy

Steps to Reproduce:
1. curl -s -k -X GET -u $SATUSER:$SATPASS  -H "Accept:application/json"  https://$SATHOST/katello/api/guestids
2. curl -s -k -X GET -u $SATUSER:$SATPASS  -H "Accept:application/json"  https://$SATHOST/katello/api/content_overrides
3.  curl -s -k -X GET -u $SATUSER:$SATPASS  -H "Accept:application/json"  https://$SATHOST/katello/api/available_releases


Actual results:
"
The page you were looking for doesn't exist.

You may have mistyped the address or the page may have moved.
"

Expected results:


Additional info:
2015-08-15 11:25:39 [F] 
ActionController::RoutingError (No route matches [GET] "/katello/api/guestids"):
  /usr/share/gems/gems/passenger-4.0.18/lib/phusion_passenger/rack/thread_handler_extension.rb:77:in `process_request'
  /usr/share/gems/gems/passenger-4.0.18/lib/phusion_passenger/request_handler/thread_handler.rb:140:in `accept_and_process_next_request'
  /usr/share/gems/gems/passenger-4.0.18/lib/phusion_passenger/request_handler/thread_handler.rb:108:in `main_loop'
  /usr/share/gems/gems/passenger-4.0.18/lib/phusion_passenger/request_handler.rb:441:in `block (3 levels) in start_threads'


2015-08-15 11:26:19 [F] 
ActionController::RoutingError (No route matches [GET] "/katello/api/content_overrides"):
  /usr/share/gems/gems/passenger-4.0.18/lib/phusion_passenger/rack/thread_handler_extension.rb:77:in `process_request'
  /usr/share/gems/gems/passenger-4.0.18/lib/phusion_passenger/request_handler/thread_handler.rb:140:in `accept_and_process_next_request'
  /usr/share/gems/gems/passenger-4.0.18/lib/phusion_passenger/request_handler/thread_handler.rb:108:in `main_loop'
  /usr/share/gems/gems/passenger-4.0.18/lib/phusion_passenger/request_handler.rb:441:in `block (3 levels) in start_threads'


2015-08-15 11:27:14 [F] 
ActionController::RoutingError (No route matches [GET] "/katello/api/available_releases"):
  /usr/share/gems/gems/passenger-4.0.18/lib/phusion_passenger/rack/thread_handler_extension.rb:77:in `process_request'
  /usr/share/gems/gems/passenger-4.0.18/lib/phusion_passenger/request_handler/thread_handler.rb:140:in `accept_and_process_next_request'
  /usr/share/gems/gems/passenger-4.0.18/lib/phusion_passenger/request_handler/thread_handler.rb:108:in `main_loop'
  /usr/share/gems/gems/passenger-4.0.18/lib/phusion_passenger/request_handler.rb:441:in `block (3 levels) in start_threads'
Comment 2 Brad Buckingham 2015-10-26 14:50:15 EDT
Created redmine issue http://projects.theforeman.org/issues/12315 from this bug
Comment 3 Brad Buckingham 2015-10-27 11:05:43 EDT
upstream katello PR: https://github.com/Katello/katello/pull/5553

The PR will return a separate resource list for RHSM vs Katello apis.
Comment 4 Bryan Kearney 2015-11-03 08:02:17 EST
Moving to POST since upstream bug http://projects.theforeman.org/issues/12315 has been closed
-------------
Brad Buckingham
Applied in changeset commit:katello|a54f1f89dfc742c518935a1b926ba89ed0ad0847.
Comment 7 Roman Plevka 2016-04-05 05:10:21 EDT
VERIFIED
on sat6.2.0 snap6.1

<pre>
curl -k -X GET -u admin:changeme  -H "Accept:application/json"  "https://${SATSERVER}/rhsm"
    ...},
    {
        "href": "/rhsm/consumers/:id/guestids",
        "rel": "guestids"
    },
    {
        "href": "/rhsm/consumers/:id/content_overrides",
        "rel": "content_overrides"
    },
    {
        "href": "/rhsm/consumers/:id/available_releases",
        "rel": "available_releases"
    },
    {...
</pre>
The output is truncated to show only the relevant part
Comment 9 errata-xmlrpc 2016-07-27 04:54:38 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500

Note You need to log in before you can comment on or make changes to this bug.