Bug 1253917 - False private-shared-object-provides warning during fedora-review
False private-shared-object-provides warning during fedora-review
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rpmlint (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-15 12:09 EDT by Dave Johansen
Modified: 2016-02-01 01:33 EST (History)
9 users (show)

See Also:
Fixed In Version: rpmlint-1.8-4.fc23 rpmlint-1.8-4.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-04 14:19:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Johansen 2015-08-15 12:09:03 EDT
Description of problem:
rpmlint is outputting a private-shared-object-provides during fedora-review, but I believe that this is a false warning.
See https://bugzilla.redhat.com/show_bug.cgi?id=1216279#c7 and https://lists.fedoraproject.org/pipermail/packaging/2015-July/010855.html

Version-Release number of selected component (if applicable):
1.7

How reproducible:
Always

Steps to Reproduce:
1. fedora-review -m fedora-rawhide-i386 -b 1216279

Actual results:
Warning is output.

Expected results:
Warning should not be output.
Comment 1 Ville Skyttä 2015-08-16 03:50:37 EDT
As I wrote in https://lists.fedoraproject.org/pipermail/packaging/2015-August/010904.html:

| I think enough investigation is finding out whether it happens with plain
| rpmlint or only with fedora-review and then choose the component to report
| against as appropriate.

This report is against rpmlint but the reproducer is written using fedora-review. And the pointer to the review this occurred with is to a x86_64 package review but the reproducer uses an i686 root.

I downloaded https://daveisfera.fedorapeople.org/cppformat_1.1.0/cppformat-1.1.0-1.fc22.src.rpm and built it locally using mock for rawhide x86_64, and running rpmlint from rpmlint-1.7-1.fc22.noarch on x86_64 F22 does not output that 

$ /usr/bin/rpmlint ./cppformat-*x86_64.rpm
cppformat.x86_64: W: spelling-error %description -l en_US printf -> print, prints, print f
cppformat.x86_64: W: no-documentation
cppformat-devel.x86_64: W: only-non-binary-in-usr-lib
cppformat-devel.x86_64: W: no-documentation
3 packages and 0 specfiles checked; 0 errors, 4 warnings.

Nor does it when the cppformat package is installed:
$ /usr/bin/rpmlint cppformat
cppformat.x86_64: W: spelling-error %description -l en_US printf -> print, prints, print f
cppformat.x86_64: W: no-documentation
1 packages and 0 specfiles checked; 0 errors, 2 warnings.

Please provide a reproducer using plain rpmlint, and more details about the environment. If it involves binary rpms, also post the rpms for examination somewhere.
Comment 2 Dave Johansen 2015-08-18 17:27:47 EDT
I am not familiar enough with rpmlint and fedora-review to understand why it's only happening when done in fedora-review, so I moved it to fedora-review in hopes that someone one on that end of things can figure what the source of the problem is.
Comment 3 Alec Leamas 2015-11-26 12:32:20 EST
Hm... Testing rpmlint in the buildroot after installing the new cppformat package:

$ mock -r fedora-rawhide-x86_64 --shell
<mock-chroot>sh-4.3# rpmlint --version
rpmlint version 1.8 Copyright (C) 1999-2007 Frederic Lepied, Mandriva
<mock-chroot>sh-4.3# rpm -q cppformat
cppformat-1.1.0-1.fc24.x86_64
<mock-chroot>sh-4.3# rpmlint cppformat
sh: /usr/bin/python: No such file or directory
cppformat.x86_64: W: private-shared-object-provides /usr/lib64/libformat.so.1.1.0 libformat.so.1()(64bit)
cppformat.x86_64: W: no-documentation
1 packages and 0 specfiles checked; 0 errors, 2 warnings.
<mock-chroot>sh-4.3#
/usr/lib64/libformat.so.1.1.0 

I. e., fedora-review does nothing but reflects the output from mock. This is seemingly not a fedora-review bug.

What I cannot understand is why rpmlint states that /usr/lib64/libformat.so... is in a private path. After all, /usr/lib64 is well-known ld.so path, right?

Oddities:

mock-chroot>sh-4.3# ls /usr/bin/python*
/usr/bin/python3  /usr/bin/python3.5  /usr/bin/python3.5m

<mock-chroot>sh-4.3# ls /etc/ld.so.conf.d
<mock-chroot>sh-4.3# 

Sorry, but unless this bug is moved to another component like rpmlint I will close it as not-a-bug.
Comment 4 Alec Leamas 2015-11-26 13:30:16 EST
Admittedly, I was too lazy. Complete reproducer:

$ wget  https://daveisfera.fedorapeople.org/cppformat_1.1.0/cppformat-1.1.0-1.fc22.src.rpm
$ rpmbuild --rebuild cppformat-1.1.0-1.fc22.src.rpm
$ mock -r fedora-rawhide-x86_64 --init
$ mock -r  fedora-rawhide-x86_64 --install rpmlint
$ mock -r  fedora-rawhide-x86_64 --install /home/al/rpmbuild/RPMS/x86_64/cppformat-1.1.0-1.fc22.x86_64.rpm
$ mock -r  fedora-rawhide-x86_64 --shell
<mock-chroot>sh-4.3# rpmlint cppformat
sh: /usr/bin/python: No such file or directory
cppformat.x86_64: W: private-shared-object-provides /usr/lib64/libformat.so.1.1.0 libformat.so.1()(64bit)
cppformat.x86_64: W: no-documentation
1 packages and 0 specfiles checked; 0 errors, 2 warnings.
<mock-chroot>sh-4.3# logout
Comment 5 Ville Skyttä 2015-11-27 03:09:06 EST
(In reply to Alec Leamas from comment #4)
> Admittedly, I was too lazy. Complete reproducer:

Thanks. See bug 1243292 comment 10.
Comment 6 Alec Leamas 2015-11-27 05:13:54 EST
OK, the "sh: /usr/bin/python: No such file or directory" message seems to be taken care of in bug #1243292.

Now, here is still the warning "W: private-shared-object-provides /usr/lib64/libformat.so...". This basically says that the provided library libformat.so doesn't live in a path known by ld.so, right? If so, isn't this nonsense?
Comment 7 Ville Skyttä 2015-11-27 05:49:18 EST
Yep, now that I could reproduce it, that's fixed in rpmlint upstream: https://github.com/rpm-software-management/rpmlint/commit/4e8657f47fb15b7a871b88054d15ea1141dd55b3
Comment 8 Fedora Update System 2015-11-30 14:51:49 EST
rpmlint-1.8-4.fc21 has been submitted as an update to Fedora 21. https://bodhi.fedoraproject.org/updates/FEDORA-2015-b4da76610b
Comment 9 Fedora Update System 2015-11-30 14:51:50 EST
rpmlint-1.8-4.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-1153251876
Comment 10 Fedora Update System 2015-11-30 14:52:01 EST
rpmlint-1.8-4.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-037f1f4db5
Comment 11 Fedora Update System 2015-12-01 17:30:57 EST
rpmlint-1.8-4.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update rpmlint'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-1153251876
Comment 12 Fedora Update System 2015-12-03 11:03:27 EST
rpmlint-1.8-4.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update rpmlint'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-037f1f4db5
Comment 13 Fedora Update System 2015-12-04 14:19:44 EST
rpmlint-1.8-4.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2016-02-01 01:33:38 EST
rpmlint-1.8-4.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.