Bug 1253922 - docker-compose requires python-dockerpty > 0.3
docker-compose requires python-dockerpty > 0.3
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: docker-compose (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michael Hampton
Fedora Extras Quality Assurance
:
Depends On: 1253859
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-15 12:45 EDT by Nikos Roussos
Modified: 2015-11-01 16:52 EST (History)
3 users (show)

See Also:
Fixed In Version: docker-compose-1.2.0-4.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-01 16:52:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nikos Roussos 2015-08-15 12:45:38 EDT
Some deatures of docker-compose (eg. run) don't work with older python-dockerpty versions. This should be stated on the Required field on the spec file.
Comment 1 Sascha Zantis 2015-09-10 04:54:34 EDT
Hi, any updates on this? I ran into some docker-compose problems this morning because of the old version, and python-dockerpty.noarch 0.3.3-3.fc22 has been pushed to updates-testing, I installed it right now and I would love to see docker-compose 1.4.0 in the updates-testing repo :)

Regards,
Sascha
Comment 2 Michael Hampton 2015-09-10 06:12:32 EDT
docker-compose 1.4.0 has quite a number of backward incompatible changes since 1.2.x so it will probably not be released for F22. You can find it in F23.

As for python-dockerpty, remember to leave karma on it.
Comment 3 Sascha Zantis 2015-09-10 08:08:53 EDT
Well, that's unfortunate. Could you shortly explain some of the issues of docker-compose 1.4.0? I just installed it via pip and it works. I had to relabel something (Didn't really get what the problem was), but now I am able to use docker run. However, how can I test the functionality of python-dockerpty when I stop using docker-compose 1.2.0? Is there any reason for it to be updated in F22 if not docker-compose which runs fine with the older version, too…
I cannot update to F23 atm, I guess, but I really appreciate your work with maintaining this package what seems not to be the easiest job as I read in some other bugreports. I also tried to build the rpm from source with your old specfile from 1.2.0 which did not work. I will try it again with the 1.4.0 specfile from F23. Working with pip packages feels kind of wrong.
Comment 4 Fedora Update System 2015-10-05 10:27:05 EDT
docker-compose-1.2.0-4.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-cccaff55b0
Comment 5 Fedora Update System 2015-10-05 21:08:00 EDT
docker-compose-1.2.0-4.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update docker-compose'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-cccaff55b0
Comment 6 Fedora Update System 2015-11-01 16:52:46 EST
docker-compose-1.2.0-4.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.