Bug 1253929 - DNF needs skip-broken option
DNF needs skip-broken option
Status: CLOSED DUPLICATE of bug 1197456
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-15 14:35 EDT by Ben Greear
Modified: 2015-08-17 03:23 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-17 03:23:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Greear 2015-08-15 14:35:42 EDT
Description of problem:

I have a large list of rpm packages that I need to install on various
Fedora (and other RPM based OSs).  Some do require packages that others do not even support.  So, I could use yum instal [big-list-of-packages] --skip-broken
and it would just ignore the packages that were not available.

I cannot find any way to do this with dnf.  This means that I will have
to create a custom list for every possible OS that uses dnf.

Please add an option to allow dnf to ignore packages it cannot find.


Version-Release number of selected component (if applicable):


How reproducible:

Always


Steps to Reproduce:

dnf install pciutils-devel libidn-devel openldap-devel autoconf    automake libtool flex bison db4-devel openssl-devel libssh2-devel libpcap-devel tcp_wrappers-devel libevent-devel    libblkid-devel libgssglue-devel libtirpc-devel libnfsidmap-devel libnl-devel ncurses-devel pcsc-lite-devel gnutls-devel libgssglue-devel lksctp-tools lksctp-tools-devel maven maven2 gcc-c++ nfs-utils make libcap-devel autogen libnet-devel device-mapper-devel sqlite-devel    m2crypto libgcrypt-devel libnl-devel libxml2-devel webkitgtk3-devel libnl3-devel    pcre-devel readline-devel glibc-static glibc-utils pciutils-devel-static

Actual results:

Fails because libgssglue-devel is not available in Fedora 22.  It is required
for my application on old Fedora/Centos/Redhat OS versions though.


Expected results:

dnf should install what it can, warn about those it cannot.


Additional info:
Comment 1 Michal Luscon 2015-08-17 03:23:15 EDT

*** This bug has been marked as a duplicate of bug 1197456 ***

Note You need to log in before you can comment on or make changes to this bug.