Bug 1253931 - Please include a static package
Please include a static package
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: libssh2 (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Paul Howarth
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-15 15:13 EDT by Mark Harfouche
Modified: 2016-03-24 05:24 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-24 05:24:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for creating a static package (1.36 KB, patch)
2015-08-15 15:13 EDT, Mark Harfouche
no flags Details | Diff

  None (edit)
Description Mark Harfouche 2015-08-15 15:13:27 EDT
Created attachment 1063303 [details]
patch for creating a static package

Static libraries are useful in certain cases.

I've attached a patch for creating a static package.

In the meantime, if anybody wants, here is a copr repo with libssh2-static

https://copr.fedoraproject.org/coprs/hmaarrfk/fedora-static/
Comment 1 Paul Howarth 2015-08-16 05:08:29 EDT
The packaging guidelines discourage the use of static libraries except under exceptional circumstances:

https://fedoraproject.org/wiki/Packaging:Guidelines#Packaging_Static_Libraries

I don't think being "useful in certain cases" qualifies as "exceptional" really. Do you have a more specific use-case that could justify it?
Comment 2 Mark Harfouche 2015-08-17 13:18:02 EDT
I'm currently working on a project where a statically linked version of qemu would be very helpful.

The reason for this is that I require to chroot and run a qemu executable.
If qemu is not statically linked, I will need to copy in a large (unknown) amount of libraries into the new chroot.

Thanks for your help.


Side note:
I understand the desire to not have static libraries in the -devel packages, but having a seprate -static package is not a big deal. Developers can decide if statically linking is useful for their applications.

As a Fedora user, I find the lack of availability of -static libraries to be a barrier when moving from a Debian based distro.

Is there somewhere I can more formally make this point?
Comment 3 Mark Harfouche 2015-08-17 13:22:57 EDT
An other note, I'm not sure of the necessity of this specific statically linked library for what I need from qemu-arm-static.

You can target this bug against F22. In the case that I don't get back to you with the necessity of this -static package, this bug will be squashed.
Comment 4 Jan Kurik 2016-02-24 08:37:12 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 5 Kamil Dudka 2016-03-24 05:24:55 EDT
I am closing this bug until we have a good enough reason to reopen it.

Note You need to log in before you can comment on or make changes to this bug.