Bug 1253933 - Please include a static package
Please include a static package
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: brltty (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Gwyn Ciesla
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-15 15:28 EDT by Mark Harfouche
Modified: 2017-03-15 10:08 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-03-15 10:08:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to add a static package (1.47 KB, patch)
2015-08-15 15:28 EDT, Mark Harfouche
no flags Details | Diff

  None (edit)
Description Mark Harfouche 2015-08-15 15:28:23 EDT
Created attachment 1063305 [details]
patch to add a static package

Static libraries are useful in certain cases.

I've attached a patch for creating a static package.

In the meantime, if anybody wants, here is a copr repo with libssh2-static

https://copr.fedoraproject.org/coprs/hmaarrfk/fedora-static/
Comment 1 Jaroslav Škarvada 2015-08-17 06:20:43 EDT
Please could you provide use case description for brltty static libraries? Please note we don't want static libraries in Fedora unless exceptional circumstances exists, i.e. from packaging guidelines [1]:

"Packages including libraries should exclude static libs as far as possible (eg by configuring with --disable-static). Static libraries should only be included in exceptional circumstances. Applications linking against libraries should as far as possible link against shared libraries not static versions.

...

In general, packagers are strongly encouraged not to ship static libs unless a compelling reason exists."

[1] https://fedoraproject.org/wiki/Packaging:Guidelines#Packaging_Static_Libraries
Comment 2 Mark Harfouche 2015-08-17 13:15:06 EDT
I'm currently working on a project where a statically linked version of qemu would be very helpful.

The reason for this is that I require to chroot and run a qemu executable.
If qemu is not statically linked, I will need to copy in a large (unknown) amount of libraries into the new chroot.

Thanks for your help.


Side note:
I understand the desire to not have static libraries in the -devel packages, but having a seprate -static package is not a big deal. Developers can decide if statically linking is useful for their applications.

As a Fedora user, I find the lack of availability of -static libraries to be a barrier when moving from a Debian based distro.

Is there somewhere I can more formally make this point?
Comment 3 Mark Harfouche 2015-08-17 13:22:54 EDT
An other note, I'm not sure of the necessity of this specific statically linked library for what I need from qemu-arm-static.

You can target this bug against F22. In the case that I don't get back to you with the necessity of this -static package, this bug will be squashed.
Comment 4 Jaroslav Škarvada 2015-08-18 10:24:42 EDT
IMHO the decision is made by maintainer/package owner, there is no process for it (AFAIK). I am co-maintainer, so letting the decision on package owner.
Comment 5 Mark Harfouche 2015-08-18 12:34:44 EDT
Thanks Jaroslav.

I understand that adding a static package might unnecessarily clutter the spec file and make it harder to maintain.
Comment 6 Jan Kurik 2016-02-24 08:37:15 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase

Note You need to log in before you can comment on or make changes to this bug.