Bug 1253963 - Kernel version 4.1.4.200.fc22 and 4.1.5-200.fc22.x86_64 break Eclipse (and maybe other Java?) [NEEDINFO]
Kernel version 4.1.4.200.fc22 and 4.1.5-200.fc22.x86_64 break Eclipse (and ma...
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
22
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-16 00:55 EDT by Phillip Rhodes
Modified: 2015-11-23 12:20 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-23 12:20:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
jforbes: needinfo?


Attachments (Terms of Use)

  None (edit)
Description Phillip Rhodes 2015-08-16 00:55:16 EDT
Description of problem:

On Fedora 22, when using the latest kernel, 4.1.4.200.fc22
, Eclipse is essentially broken.  On my laptop I waited over 90 seconds for Eclipse to simply display the workplace chooser, with no results. On the previous kernel - 4.0.4.301.fc22, the Eclipse workplace chooser dialog appears in around 20-30 seconds.  On the one occasion when I waited long enough to get the chooser, made a choose, and waited, it took several minutes for the Eclipse main window to finish drawing itself.  And when it did, it was completely unresponsive and unusable.

Version-Release number of selected component (if applicable):
Fedora 22 with kernel 4.1.4.200.fc22

How reproducible:

Totally reproducible on my machine. I can boot into the 4.1.4 kernel and see the bad behavior, then reboot back into 4.0.4 and everything behaves normally.

Steps to Reproduce:
1. Install Fedora 22 from installation media.
2. Install Java. I tried this with all of OpenJDK 1.8, Oracle JDK 1.8 and Oracle JDK 1.7, and got the same behavior with each.
3. Install Eclipse. I tried with "vanilla" eclipse 3.8.2, Eclipse Luna and Eclipse Mars (from eclipse.org, not form the Fedora repo)
4. Launch Eclipse and notice how long it takes Eclipse to start and become usable.
5. run dnf upgrade
6. reboot and pick the newer kernel version
7. Try running Eclipse again.  

Actual results:

My observation was that after rebooting into the 4.1.4 kernel, Eclipse became unusable. 

Expected results:

I expect Eclipse to start and run normally on Fedora after updating the kernel.

Additional info:

Most of my testing was done using KDE Plasma, but when I tried it under Gnome Classic, I saw the same behavior.
Comment 1 Phillip Rhodes 2015-08-21 21:24:10 EDT
FYI, the last batch of updates brought in kernel version 4.1.5-200.fc22.x86_64, and I'm seeing the same behavior with this kernel.  But it remains that case that if I boot back into 4.0.4, Eclipse runs normally.
Comment 2 Justin M. Forbes 2015-10-20 15:35:55 EDT
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 22 kernel bugs.

Fedora 22 has now been rebased to 4.2.3-200.fc22.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 23, and are still experiencing this issue, please change the version to Fedora 23.

If you experience different issues, please open a new bug report for those.
Comment 3 Fedora Kernel Team 2015-11-23 12:20:53 EST
*********** MASS BUG UPDATE **************
This bug is being closed with INSUFFICIENT_DATA as there has not been a response in over 4 weeks. If you are still experiencing this issue, please reopen and attach the relevant data from the latest kernel you are running and any data that might have been requested previously.

Note You need to log in before you can comment on or make changes to this bug.