Bug 1253974 - [vdsm] Live merge fails after a disk containing a snapshot has been extended
[vdsm] Live merge fails after a disk containing a snapshot has been extended
Status: CLOSED NEXTRELEASE
Product: vdsm
Classification: oVirt
Component: General (Show other bugs)
4.17.0
x86_64 Unspecified
unspecified Severity high (vote)
: ovirt-3.6.0-rc
: 4.17.23
Assigned To: Adam Litke
Elad
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-16 05:13 EDT by Elad
Modified: 2016-03-10 10:13 EST (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-29 05:26:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
ylavi: ovirt‑3.6.0?
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)

  None (edit)
Description Elad 2015-08-16 05:13:47 EDT
Description of problem:
The same scenario as in https://bugzilla.redhat.com/show_bug.cgi?id=1236758. 
Tried to do live deletion of a snapshot after the VM disk was extended. The operation ends with a failure in VDSM:

acff4189-cfc2-404d-9c03-ddfb33e36104::ERROR::2015-08-16 10:45:58,925::task::866::Storage.TaskManager.Task::(_setError) Task=`acff4189-cfc2-404d-9c03-ddfb33e36104`::Unexpected error
Traceback (most recent call last):
  File "/usr/share/vdsm/storage/task.py", line 873, in _run
    return fn(*args, **kargs)
  File "/usr/share/vdsm/storage/task.py", line 332, in run
    return self.cmd(*self.argslist, **self.argsdict)
  File "/usr/share/vdsm/storage/securable.py", line 77, in wrapper
    return method(self, *args, **kwargs)
  File "/usr/share/vdsm/storage/sp.py", line 1304, in extendVolumeSize
    .produceVolume(imgUUID, volUUID).extendSize(int(newSize))
  File "/usr/share/vdsm/storage/volume.py", line 552, in extendSize
    raise se.VolumeNonWritable(self.volUUID)
VolumeNonWritable: Volume cannot be access to writes: ["u'46d93a59-0ec1-4c7c-9f25-816be8d0760b'"]


Version-Release number of selected component (if applicable):
ovirt-3.6.0-5
vdsm-4.17.0-1239.git6575e3f.el7.noarch
libvirt-daemon-1.2.8-16.el7_1.3.x86_64
qemu-kvm-ev-2.1.2-23.el7_1.6.1.x86_64
sanlock-3.2.2-2.el7.x86_64
selinux-policy-3.13.1-23.el7_1.13.noarch
python-2.7.5-18.el7_1.1.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Create a VM with 1gb preallocated disk (probably thin as well, didn't test that) in a block-based domain.
2. Create a snapshot.
3. Extend the disk to 2gb.
4. Start the VM.
5. Delete the snapshot.


Actual results:
Live snapshot deletion fails on VDSM with the mentioned exception

Expected results:
Live merge should succeed for a snapshot that was previously extended.

Additional info:
sosreport from host: http://file.tlv.redhat.com/ebenahar/sosreport-green-vdsc.qa.lab.tlv.redhat.com-20150816120535.tar.xz
sosreport from engine: http://file.tlv.redhat.com/ebenahar/sosreport-RHEL6.7Server-20150816120920.tar.xz
Comment 1 Greg Padgett 2015-08-17 14:13:06 EDT
I believe this should be closed (duplicate of 1232481?), see my latest comment to bug 1236758 for details.
Comment 2 Red Hat Bugzilla Rules Engine 2015-10-19 06:49:42 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 3 Sandro Bonazzola 2015-10-26 08:29:26 EDT
this is an automated message. oVirt 3.6.0 RC3 has been released and GA is targeted to next week, Nov 4th 2015.
Please review this bug and if not a blocker, please postpone to a later release.
All bugs not postponed on GA release will be automatically re-targeted to

- 3.6.1 if severity >= high
- 4.0 if severity < high
Comment 4 Adam Litke 2015-11-23 13:42:28 EST
closed bug.  clearing NEEDINFO.

Note You need to log in before you can comment on or make changes to this bug.