Bug 1253977 - conflict between hwloc-libs-1.11.0-1.fc22.i686 and hwloc-libs-1.11.0-1.fc22.x86_64
conflict between hwloc-libs-1.11.0-1.fc22.i686 and hwloc-libs-1.11.0-1.fc22.x...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: hwloc (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jiri Hladky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-16 06:24 EDT by Konstantin Belousov
Modified: 2015-09-21 09:18 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.11.0-4.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-21 06:50:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Konstantin Belousov 2015-08-16 06:24:43 EDT
Trying to do dnf upgrade today, I got:

Running transaction check
Transaction check succeeded.
Running transaction test
Error: Transaction check error:
  file /usr/share/doc/hwloc/examples/Makefile conflicts between attempted installs of hwloc-libs-1.11.0-1.fc22.i686 and hwloc-libs-1.11.0-1.fc22.x86_64

I have hwloc-libs installed as the dependency for openmpi, for which I need both 32 and 64 bit versions for building corresponding binaries.
Comment 1 Jiri Hladky 2015-08-18 04:35:05 EDT
Hi,

thanks for reporting this. I will move the file to hwloc-devel
Comment 2 Jiri Hladky 2015-08-18 05:53:38 EDT
I have kept only libraries in hwloc-libs package.

/usr/lib64/libhwloc.so.5
/usr/lib64/libhwloc.so.5.6.6

This should allow you to install i686 and x86-64 libraries alongside.
Comment 3 Fedora Update System 2015-08-18 06:45:35 EDT
hwloc-1.11.0-2.fc23 has been submitted as an update for Fedora 23.
https://admin.fedoraproject.org/updates/hwloc-1.11.0-2.fc23
Comment 4 Fedora Update System 2015-08-18 06:46:34 EDT
hwloc-1.11.0-2.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/hwloc-1.11.0-2.fc22
Comment 5 Jiri Hladky 2015-08-18 06:48:43 EDT
Please test it, the new package is here:
https://admin.fedoraproject.org/updates/hwloc-1.11.0-2.fc22
Comment 6 Konstantin Belousov 2015-08-18 07:00:54 EDT
Does the change mean that the problem is moved from the lib rpms to the -devel one ?  I.e. if I want to build e.g. both 32 and 64 bit local version of openmpi, I am still in trouble, since I cannot have hwloc-devel for both ABIs simultaneously ?
Comment 7 Jiri Hladky 2015-08-18 07:15:56 EDT
I have just compared 

hwloc-devel-1.11.0-2.fc22.i686.rpm
and
hwloc-devel-1.11.0-2.fc22.x86_64.rpm

packages. There is no conflict except for 

/usr/share/doc/hwloc/examples/Makefile

So yes, problem has been merely moved to another package. 

Thinking about it deeper, it would be probably better to rename Makefile to Makefile_${arch} to solve this.

As the workaround, you can force Makefile override - it's example file, so there is no harm doing so. 

I will build new package later today.
Comment 8 Fedora Update System 2015-08-18 09:36:41 EDT
hwloc-1.11.0-3.fc23 has been submitted as an update for Fedora 23.
https://admin.fedoraproject.org/updates/hwloc-1.11.0-3.fc23
Comment 9 Fedora Update System 2015-08-18 09:38:31 EDT
hwloc-1.11.0-3.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/hwloc-1.11.0-3.fc22
Comment 10 Jiri Hladky 2015-08-18 09:46:04 EDT
Could you please test if 
https://admin.fedoraproject.org/updates/hwloc-1.11.0-3.fc22
solves the problem?
Comment 11 Konstantin Belousov 2015-08-19 05:10:32 EDT
What do you want me to test ?

I do not see much value in me confirming that i686 and x86_64 packages can be installed simultaneously, if you already tested this yourself.  And I do not see what else could be considered as the testing for the issue.

That said, I am not that knowledgable about Linux/Fedora.  Would dnf upgrade continue to work if I manually remove hwloc-libs and openmpi rpms and then install newer rpms from koji ?  Or is there some special procedure I need to follow to keep the machine update procedure to continue working after the testing ?
Comment 12 Jiri Hladky 2015-08-19 06:30:37 EDT
Hi,

please simply download the rpms and do 

dnf install <all rpm files>

That's all. After two weeks or so rpms will be moved to Fedora repositories. dnf upgrade will work as usual. And there is no need to remove openmpi rpms.

Thanks
Jirka
Comment 13 Konstantin Belousov 2015-08-19 06:57:51 EDT
(In reply to Jiri Hladky from comment #12)

Did that.  Looks fine, thank you for the instructions.

[kostik@sandy tmp]$ rpm -qa | grep -E 'openmpi|hwloc'
hwloc-devel-1.11.0-3.fc22.x86_64
hwloc-libs-1.11.0-3.fc22.i686
hwloc-1.11.0-3.fc22.i686
hwloc-1.11.0-3.fc22.x86_64
openmpi-devel-1.8.7-1.fc22.i686
openmpi-1.8.7-1.fc22.i686
openmpi-devel-1.8.7-1.fc22.x86_64
hwloc-devel-1.11.0-3.fc22.i686
openmpi-1.8.7-1.fc22.x86_64
hwloc-libs-1.11.0-3.fc22.x86_64
Comment 14 Jiri Hladky 2015-08-19 07:03:12 EDT
Great! Thanks for the confirmation.

Jirka
Comment 15 Fedora Update System 2015-09-04 19:20:31 EDT
hwloc-1.11.0-4.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update hwloc'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-15068
Comment 16 Fedora Update System 2015-09-04 19:22:33 EDT
hwloc-1.11.0-4.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update hwloc'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-15067
Comment 17 Fedora Update System 2015-09-21 06:50:44 EDT
hwloc-1.11.0-4.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 18 Fedora Update System 2015-09-21 09:18:00 EDT
hwloc-1.11.0-4.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.