Bug 1254001 - [vdsm] PrepareImage manual execution using vdsClient, without a mandatory argument fails with 'Unexpected exception'
[vdsm] PrepareImage manual execution using vdsClient, without a mandatory arg...
Status: CLOSED WONTFIX
Product: vdsm
Classification: oVirt
Component: General (Show other bugs)
---
x86_64 Unspecified
low Severity low (vote)
: ovirt-4.0.0-alpha
: ---
Assigned To: Idan Shaby
Aharon Canan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-16 08:22 EDT by Elad
Modified: 2016-03-28 11:00 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-28 11:00:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
ylavi: ovirt‑4.0.0?
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)
vdsm.log (139.97 KB, application/x-gzip)
2015-08-16 08:22 EDT, Elad
no flags Details

  None (edit)
Description Elad 2015-08-16 08:22:13 EDT
Created attachment 1063518 [details]
vdsm.log

Description of problem:
Tried to perform prepareImage using vdsClient, without volume UUID which is now mandatory as fixed by https://gerrit.ovirt.org/#/c/38440/
The operation failed with an ugly error message -  'Unexpected exception'.


Version-Release number of selected component (if applicable):
ovirt-3.6.0-5
vdsm-4.17.0-1239.git6575e3f.el7.noarch
vdsm-cli-4.17.0-1239.git6575e3f.el7.noarch

How reproducible:
Always

Steps to Reproduce:
1. Have a VM with a disk located on a block domain. Don't start the VM
2. Perform prepareImage using vdsClient, don't give it volume UUID:

vdsClient -s 0 prepareImage `vdsClient -s 0 getConnectedStoragePoolsList` 1e3f4f8d-26bb-4612-8610-bf670f1b274e a862bd11-c492-4925-9c87-8fefd36fd018


Actual results:

[root@green-vdsc ~]# vdsClient -s 0 prepareImage `vdsClient -s 0 getConnectedStoragePoolsList` 1e3f4f8d-26bb-4612-8610-bf670f1b274e a862bd11-c492-4925-9c87-8fefd36fd018
Unexpected exception


vdsm.log:

Thread-8321::ERROR::2015-08-16 15:13:31,404::bindingxmlrpc::330::vds::(wrapper) Unexpected exception
Traceback (most recent call last):
  File "/usr/share/vdsm/rpc/bindingxmlrpc.py", line 328, in wrapper
    return f(*args, **kwargs)
TypeError: imagePrepare() takes exactly 5 arguments (4 given)
Thread-8321::INFO::2015-08-16 15:13:31,406::xmlrpc::92::vds.XMLRPCServer::(_process_requests) Request handler for 127.0.0.1:50031 stopped


Expected results:
The error should be informative.

Additional info:
vdsm.log
Comment 1 Red Hat Bugzilla Rules Engine 2015-10-19 07:00:48 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 2 Sandro Bonazzola 2015-10-26 08:44:00 EDT
this is an automated message. oVirt 3.6.0 RC3 has been released and GA is targeted to next week, Nov 4th 2015.
Please review this bug and if not a blocker, please postpone to a later release.
All bugs not postponed on GA release will be automatically re-targeted to

- 3.6.1 if severity >= high
- 4.0 if severity < high
Comment 3 Allon Mureinik 2016-03-28 11:00:10 EDT
We aren't going to devote resources to vdsClient, closing.

Note You need to log in before you can comment on or make changes to this bug.