Bug 1254046 - fence_ipmilan no longer understands (deprecated) -i option
fence_ipmilan no longer understands (deprecated) -i option
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: fence-agents (Show other bugs)
6.7
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Marek Grac
cluster-qe@redhat.com
: EasyFix, Regression, ZStream
Depends On:
Blocks: 1257812
  Show dependency treegraph
 
Reported: 2015-08-16 22:29 EDT by Dan Callaghan
Modified: 2016-05-10 17:33 EDT (History)
5 users (show)

See Also:
Fixed In Version: fence-agents-4.0.15-9.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1257812 (view as bug list)
Environment:
Last Closed: 2016-05-10 17:33:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch (1.55 KB, application/mbox)
2015-08-17 03:31 EDT, Marek Grac
no flags Details

  None (edit)
Description Dan Callaghan 2015-08-16 22:29:36 EDT
Description of problem:
fence_ipmilan (from fence-agents-3.1.5-48.el6) accepted -i as a deprecated option for specifying the IPMI address. With the latest update -i is no longer a valid option.

This regression broke Beaker's power scripts.

Version-Release number of selected component (if applicable):
fence-agents-4.0.15-8.el6.x86_64

How reproducible:
easily

Steps to Reproduce:
1.fence_ipmilan -i 

Actual results:
ERROR:root:Parse error: option -i not recognized

Expected results:
fence_ipmilan: option requires an argument -- 'i'

Additional info:
I see in bug 1049805 fence-agents was rebased. There was some effort to maintain compatibility but I guess this particular -i option was missed.
Comment 3 Marek Grac 2015-08-17 03:16:16 EDT
@Dan:

yes, you are right. It was missed because it was not propagated via metadata and was hard-coded in help so our tests did not catch it.
Comment 4 Marek Grac 2015-08-17 03:31:54 EDT
Created attachment 1063663 [details]
Proposed patch
Comment 10 errata-xmlrpc 2016-05-10 17:33:04 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0838.html

Note You need to log in before you can comment on or make changes to this bug.