Bug 1254064 - encrypted swap should have optional password
encrypted swap should have optional password
Status: CLOSED DUPLICATE of bug 505518
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
22
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-17 01:34 EDT by Ian Kelling
Modified: 2016-04-08 16:12 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-08 16:12:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Kelling 2015-08-17 01:34:04 EDT
Description of problem:
Setting up custom partitioning, lvm with only one encrypted volume (swap), it requires a password. blank does not work. Swap should be able to use a random password. For example, this line in /etc/crypttab:

swap /dev/sdaX   /dev/urandom   swap,cipher=aes-cbc-essiv:sha256,size=256
Comment 1 David Shea 2016-03-23 17:06:37 EDT
This would break resuming from hibernate.
Comment 2 Ian Kelling 2016-03-24 00:02:56 EDT
Anaconda allows having no swap or a small swap, which both break hibernate. This is a perfectly valid and useful configuration.
Comment 3 David Shea 2016-04-08 16:12:33 EDT

*** This bug has been marked as a duplicate of bug 505518 ***

Note You need to log in before you can comment on or make changes to this bug.