Bug 125411 - kernel-2.6.6-1.422 hangs on boot (FIREWIRE)
kernel-2.6.6-1.422 hangs on boot (FIREWIRE)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-06 11:50 EDT by Micheal Clark
Modified: 2015-01-04 17:06 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-30 22:45:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of lspci -vv (13.77 KB, text/plain)
2004-06-06 11:52 EDT, Micheal Clark
no flags Details
Ouput of lsusb -v (11.20 KB, text/plain)
2004-06-06 11:54 EDT, Micheal Clark
no flags Details
lspci -vv (4.32 KB, text/plain)
2004-06-21 18:37 EDT, euphgeek
no flags Details
lsusb -v (4.08 KB, text/plain)
2004-06-21 18:38 EDT, euphgeek
no flags Details

  None (edit)
Description Micheal Clark 2004-06-06 11:50:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
When booting this kernel, system hangs on Probing for new hardware.

Motherboard: Asus p4c800-e deluxe
Sound Card: Sound Blaster Audigy 2
Video Card : ATI Radeon 9000


Version-Release number of selected component (if applicable):
kernel-2.6.6-1.422

How reproducible:
Always

Steps to Reproduce:
1. Boot the kernel from GRUB
2.
3.
    

Actual Results:  System hangs at Probing for new Hardware

Expected Results:  System should boot normally

Additional info:
Comment 1 Micheal Clark 2004-06-06 11:52:37 EDT
Created attachment 100905 [details]
Output of lspci -vv
Comment 2 Micheal Clark 2004-06-06 11:54:34 EDT
Created attachment 100906 [details]
Ouput of lsusb -v
Comment 3 euphgeek 2004-06-21 18:36:09 EDT
This problem also occurs in kernel-2.6.6-1.435.  I have a Microsoft
Intellimouse Optical usb, and the computer either freezes at that
point, or starts with no mouse (can't move the mouse cursor).  I will
also attach the output of lspci -vv and lsusb -v
Comment 4 euphgeek 2004-06-21 18:37:27 EDT
Created attachment 101315 [details]
lspci -vv
Comment 5 euphgeek 2004-06-21 18:38:10 EDT
Created attachment 101316 [details]
lsusb -v
Comment 6 Micheal Clark 2004-06-21 20:05:27 EDT
Thanks for commenting on this bug, euphgeek. If enough folks are
having this problem the sooner it could be fixed. 

Im having the same problem with checkin 435 as well though a strace on
kudzu revealed it was hanging on the firewire detection. I disabled
firewire in the BIOS and it booted normally.  It looks like firewire
isn't 100% in 2.6 yet.  I just recompiled the updated kernel and
removed support for firewire as a workaround. I will have to do that
unfortunately until this is fixed.

Thanks again
Comment 7 euphgeek 2004-06-21 20:39:43 EDT
No problem.  I was about to file my own bug report when I saw yours. 
It seems like this may only affect 2.6.6, because my system boots fine
with 2.6.5.
Comment 8 Dave Jones 2004-06-30 08:49:37 EDT
booting with 'nofirewire' argument should also work around this, to
save you needing to rebuild a kernel.
Comment 9 Micheal Clark 2004-06-30 21:28:19 EDT
Thanks Dave for your suggestion, strangely enough adding the
nofirewire arg to the boot line in grub does not seem to keep kudzu
from freaking out, at least with 2.6.6-435.2.1. Was thinking about
chkconfiging kudzu out of runlevels 5 and 3 but I'm not sure about the
ramifications of that.

Either way thanks for the help and if there is any info I can provide,
just let me know.
Comment 10 Dave Jones 2004-07-04 09:42:00 EDT
yes, it seems kudzu makes the modules get probed regardless of the
nofirewire setting, so removing the ieee1394 directory from
/lib/modules/ is the only way to be sure they dont get loaded.

Newer kernels in rawhide have firewire disabled in the SMP kernels.
Hopefully at some point in time, we can reenable it across the board,
but upstream needs to fix this and a few other issues first.
Comment 11 Dave Jones 2004-11-27 15:21:00 EST
mass update for old bugs:

Is this still a problem with the 2.6.9 based update kernel ?
Comment 12 Micheal Clark 2004-11-30 22:28:08 EST
You are on the ball Dave.

No problems as of 2.6.9 Feel free to mark as resolved.
Comment 13 euphgeek 2004-12-01 09:40:09 EST
The kernel (2.6.9-1.6_FC2) is still hanging for me, even when I boot with the
"nofirewire" argument.

Note You need to log in before you can comment on or make changes to this bug.