Bug 1254111 - (CVE-2015-5475, CVE-2015-6506) CVE-2015-5475 CVE-2015-6506 rt: multiple XSS flaws
CVE-2015-5475 CVE-2015-6506 rt: multiple XSS flaws
Status: NEW
Product: Security Response
Classification: Other
Component: vulnerability (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Red Hat Product Security
impact=moderate,public=20150814,repor...
: Security
Depends On: 1254112
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-17 03:52 EDT by Martin Prpič
Modified: 2015-08-27 19:48 EDT (History)
3 users (show)

See Also:
Fixed In Version: rt 4.2.12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Prpič 2015-08-17 03:52:04 EDT
Common Vulnerabilities and Exposures assigned an identifier CVE-2015-5475 to
the following vulnerability:

Name: CVE-2015-5475
URL: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-5475
Assigned: 20150710
Reference: http://www.debian.org/security/2015/dsa-3335

Multiple cross-site scripting (XSS) vulnerabilities in Request Tracker
(RT) 4.x before 4.2.12 allow remote attackers to inject arbitrary web
script or HTML via vectors related to the (1) user and (2) group
rights management pages.
Comment 1 Martin Prpič 2015-08-17 03:52:40 EDT
Created rt tracking bugs for this issue:

Affects: fedora-all [bug 1254112]
Comment 2 Martin Prpič 2015-08-18 04:58:40 EDT
External References:

http://blog.bestpractical.com/2015/08/security-vulnerabilities-in-rt.html
Comment 3 Martin Prpič 2015-08-18 05:00:01 EDT
A second flaw has also been assigned a CVE:

RT 4.2.0 and above are vulnerable to a cross-site scripting (XSS) attack via the cryptography interface.  This vulnerability could allow an attacker with a carefully-crafted key to inject JavaScript into RT's user interface. Installations which use neither GnuPG nor S/MIME are unaffected.

This has been assigned CVE-2015-6506:

http://seclists.org/oss-sec/2015/q3/384
Comment 4 Fedora Update System 2015-08-25 12:06:24 EDT
rt-4.2.12-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 5 Fedora Update System 2015-08-27 14:26:14 EDT
rt-4.2.12-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2015-08-27 19:48:45 EDT
rt-4.2.12-1.fc21 has been pushed to the Fedora 21 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.