Bug 1254115 - the window doesn't show the details of PCI host devices or USB host devices when adding a PCI host device or USB host device
the window doesn't show the details of PCI host devices or USB host devices w...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-manager (Show other bugs)
7.2
x86_64 Linux
high Severity high
: rc
: 7.2
Assigned To: Pavel Hrdina
Virtualization Bugs
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-17 03:57 EDT by XiaoQing
Modified: 2015-11-19 00:31 EST (History)
4 users (show)

See Also:
Fixed In Version: virt-manager-1.2.1-6.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 00:31:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description XiaoQing 2015-08-17 03:57:36 EDT
Description of problem:
the window doesn't show the details of PCI host devices or USB host devices when adding a PCI host device or USB host device.

Version-Release number of selected component (if applicable):
virt-manager-1.2.1-5.el7.noarch

How reproducible:
100%

Steps to Reproduce:

1.Launch virt-manager, select a shut-down guest and open the hardware details window.

2.Click "Add Hardware" and choose the PCI host device or USB host device.

3.Click any other device then click PCI or USB host device.


Actual results:
after step2, "Add new virtual hardware" window pops up and the details of PCI or USB host device doesn't refresh  after clicking "PCI Host Device " or "USB Host Device".
When clicking any other device , the window refresh the detail except PCI or USB host device.

Expected results:
the details of devices refresh normally.

Additional info:
This bug couldn't produce in virt-manager-1.2.1-5.el7.noarch
Comment 4 Pavel Hrdina 2015-08-18 11:58:37 EDT
Upstream commit:

commit 7d08d3d981f3eb39e5229767028e8b0064272095
Author: Cole Robinson <crobinso@redhat.com>
Date:   Mon Aug 10 14:18:43 2015 -0400

    addhw: Drop unused columns from host-device list
Comment 8 XiaoQing 2015-08-20 03:04:43 EDT
I can reproduce the bug with the build:
virt-install-1.2.1-5.el7.noarch


Try to verify this bug with package:
virt-install-1.2.1-6.el7.noarch

steps:
1.Launch virt-manager, select a shut-down guest and open the hardware details window.

2.Click "Add Hardware" and choose the PCI host device or USB host device.

3.Click any other device then click PCI or USB host device.

Result:
after step2, "Add new virtual hardware" window pops up and the details of PCI or USB host device  refresh  after clicking "PCI Host Device " or "USB Host Device".
When clicking any other device , the window refresh the detail including PCI or USB host device.

According to above result,move this bug from ON_QA to VERIFIED.
Comment 10 errata-xmlrpc 2015-11-19 00:31:56 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2206.html

Note You need to log in before you can comment on or make changes to this bug.