Bug 1254127 - Spurious failure blocking NetBSD regression runs
Summary: Spurious failure blocking NetBSD regression runs
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: tests
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Avra Sengupta
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1254128
TreeView+ depends on / blocked
 
Reported: 2015-08-17 08:41 UTC by Avra Sengupta
Modified: 2016-06-16 13:32 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1254128 (view as bug list)
Environment:
Last Closed: 2016-06-16 13:32:25 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Avra Sengupta 2015-08-17 08:41:49 UTC
Description of problem:
Spurious failure of ./tests/basic/mount-nfs-auth.t and ./tests/geo-rep/georep-basic-dr-rsync.t are blocking NetBSD regression runs.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Anand Avati 2015-08-17 08:47:21 UTC
REVIEW: http://review.gluster.org/11934 (tests: Moving ./tests/basic/mount-nfs-auth.t and  ./tests/geo-rep/georep-basic-dr-rsync.t to bad test) posted (#1) for review on master by Avra Sengupta (asengupt@redhat.com)

Comment 2 Anand Avati 2015-08-18 05:34:15 UTC
REVIEW: http://review.gluster.org/11934 (tests: Moving ./tests/basic/mount-nfs-auth.t and  ./tests/geo-rep/georep-basic-dr-rsync.t to bad test) posted (#2) for review on master by Avra Sengupta (asengupt@redhat.com)

Comment 3 Anand Avati 2015-08-24 11:01:29 UTC
REVIEW: http://review.gluster.org/12005 (tests: add arbiter-statfs.t to bad tests) posted (#1) for review on master by Atin Mukherjee (amukherj@redhat.com)

Comment 4 Anand Avati 2015-08-24 11:24:10 UTC
REVIEW: http://review.gluster.org/12005 (tests: add arbiter-statfs.t/tier.t to bad tests) posted (#2) for review on master by Atin Mukherjee (amukherj@redhat.com)

Comment 5 Anand Avati 2015-08-25 05:28:04 UTC
REVIEW: http://review.gluster.org/12005 (tests: add arbiter-statfs.t/tier.t to bad tests) posted (#3) for review on master by Atin Mukherjee (amukherj@redhat.com)

Comment 6 Anand Avati 2015-08-25 09:44:06 UTC
COMMIT: http://review.gluster.org/12005 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit 255b4ba477f5163b59efee1c9f62845eb86067a2
Author: Atin Mukherjee <amukherj@redhat.com>
Date:   Mon Aug 24 16:20:06 2015 +0530

    tests: add arbiter-statfs.t/tier.t to bad tests
    
    Recent regression links for proof:
    http://build.gluster.org/job/rackspace-netbsd7-regression-triggered/9611/consoleFull
    https://build.gluster.org/job/rackspace-netbsd7-regression-triggered/9616/consoleFull
    https://build.gluster.org/job/rackspace-regression-2GB-triggered/13613/consoleFull
    
    Filed https://bugzilla.redhat.com/show_bug.cgi?id=1256588 for tracking
    arbiter-statfs.t spurious failure and
    https://bugzilla.redhat.com/show_bug.cgi?id=1231268 is going to track tier.t's
    issue.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1231268
    Change-Id: I61dc8f3d3366b2c784e3ce82bd88900f2651cbef
    BUG: 1254127
    Signed-off-by: Atin Mukherjee <amukherj@redhat.com>
    Reviewed-on: http://review.gluster.org/12005
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
    Tested-by: Vijay Bellur <vbellur@redhat.com>

Comment 7 Nagaprasad Sathyanarayana 2015-10-25 14:52:49 UTC
Fix for this BZ is already present in a GlusterFS release. You can find clone of this BZ, fixed in a GlusterFS release and closed. Hence closing this mainline BZ as well.

Comment 8 Niels de Vos 2016-06-16 13:32:25 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.