This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 125413 - [httx] xft httx terminates when used from Emacs
[httx] xft httx terminates when used from Emacs
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: im-sdk (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
: i18n
Depends On:
Blocks: IIIMF 137149
  Show dependency treegraph
 
Reported: 2004-06-06 12:32 EDT by Jens Petersen
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: emacs-21.3-19.EL
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-06 00:09:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2004-06-06 12:32:59 EDT
Description of problem:
When Emacs is run httx stops working and the httx status
window disappears.

How reproducible:
every time

Steps to Reproduce:
0. In an X session
1. run XEmacs say
2. run Emacs
  
Actual results:
1. XEmacs appears with httx status window
2. XEmacs httx status window disappears

Expected results:
2. httx to continue to go on working.
Comment 1 Jens Petersen 2004-11-08 01:57:19 EST
$ httx
htt : Warning - Duplicate htt_server 32
X Error of failed request:  BadDrawable (invalid Pixmap or Window parameter)
  Major opcode of failed request:  155 (RENDER)
  Minor opcode of failed request:  4 (RenderCreatePicture)
  Resource id in failed request:  0x0
  Serial number of failed request:  383
  Current serial number in output stream:  394
htt : Warning - htt_server has been terminated without knowledge of htt ,
restart htt again
$ 
Comment 2 Jens Petersen 2004-11-08 02:54:43 EST
The above error appears when iiimf is turned on in Emacs with Ctrl-Space.

Here is a backtrace at CommonIM_Error_Handler:

$ gdb htt_xbe
GNU gdb Red Hat Linux (6.1post-1.20040607.44rh)
:
(gdb) b CommonIM_Error_Handler
:
Breakpoint 1 (CommonIM_Error_Handler) pending.
(gdb) r
Starting program: /usr/bin/htt_xbe
[Thread debugging using libthread_db enabled]
[New Thread -151045280 (LWP 7895)]
Breakpoint 2 at 0xf6cf2faf: file commonIM.c, line 77.
Pending breakpoint "CommonIM_Error_Handler" resolved
[New Thread -154784848 (LWP 7900)]
bt
[Switching to Thread -154784848 (LWP 7900)]

Breakpoint 2, CommonIM_Error_Handler (dpy=0x9e1b460, event=0xf6c619e0)
    at commonIM.c:77
77          if (appl_error_handler &&
Current language:  auto; currently c
(gdb) bt
#0  CommonIM_Error_Handler (dpy=0x9e1b460, event=0xf6c619e0) at commonIM.c:77
#1  0x02a43e40 in _XError () from /usr/X11R6/lib/libX11.so.6
#2  0x02a44557 in _XReply () from /usr/X11R6/lib/libX11.so.6
#3  0x02a301a8 in XInternAtom () from /usr/X11R6/lib/libX11.so.6
#4  0xf6c9e5c8 in xaux_so_Create (aux=0x9e39588) at xaux_so_common.c:953
#5  0xf6d027cb in aux_get (ic=0x9e2d560, ev=0x9e1b460, aux_name=0x9e3b2f0)
    at iiimpAux.c:1255
#6  0xf6d02937 in IIimpAuxStart (ic=0xf6c619e0, ev=0x9fe3cd0) at iiimpAux.c:615
#7  0xf6cfdf99 in IMProcessIncomingEvent (ic=0x9e2d560) at iiimcfFun.c:495
#8  0xf6cfec86 in IMTriggerNotify (ic=0x9e2d560, conv_mode=4140177888)
    at iiimcfFun.c:539
#9  0xf6cfed6a in IMForwardEvent (ic=0x9e2d560, ev=0xf6c622e0)
    at iiimcfFun.c:573
#10 0xf6cfa846 in IIIMP_Local_KeyFilter (d=0xf6c619e0, w=4140177888,
"<raw>")
    at iiimpIC.c:260
#11 0x02a5eddd in XFilterEvent () from /usr/X11R6/lib/libX11.so.6
#12 0x0805b7e1 in XInputContext::filter_event (this=0x9e2bee0,
    event=0xf6c622e0) at r6im/XInputContext.cpp:339
#13 0x08059688 in FilterEvent (icid=-154789408, event=0xf6c619e0)
    at r6im/R6IMProtocol.cpp:653
#14 0x080643bc in ForwardEventMessageProc (ims=0xf6c619e0,
    call_data=0xf6c622d0, p=0xf6c620f0 "<raw>") at r6im/i18nPtHdr.c:983
#15 0x08065c43 in _Xi18nMessageHandler (ims=0x9e1b9a0, connect_id=2,
    p=0x9fe4634 "\002", delete=0xf6c619e0) at r6im/i18nPtHdr.c:1563
#16 0x0805f84a in WaitXIMProtocol (dpy=0x9e1b460, win=14680068, ev=0x9e1b460,
    client_data=0x9e1b9a0 "<raw>") at r6im/i18nX.c:402
#17 0x02a5eddd in XFilterEvent () from /usr/X11R6/lib/libX11.so.6
#18 0x08058264 in R6IMProtocol::xevent_loop (client_data=0x9e0b250)
    at r6im/R6IMProtocol.cpp:256
#19 0x00aed1d5 in start_thread () from /lib/tls/libpthread.so.0
#20 0x0088b2da in clone () from /lib/tls/libc.so.6
(gdb)
Comment 3 Jens Petersen 2004-11-11 22:24:52 EST
The above backtrace is for ja_JP with cannaLE.

Here's one for hangulLE:

#0  CommonIM_Error_Handler (dpy=0x94ca448, event=0xf6c458b0) at commonIM.c:77
#1  0x02a43e40 in _XError () from /usr/X11R6/lib/libX11.so.6
#2  0x02a44557 in _XReply () from /usr/X11R6/lib/libX11.so.6
#3  0x02a2ce17 in _XGetWindowAttributes () from /usr/X11R6/lib/libX11.so.6
#4  0x02a2cf4a in XGetWindowAttributes () from /usr/X11R6/lib/libX11.so.6
#5  0xf6caf793 in UpdateStatus (ic=0x94dc550, doCache=1) at guiIMSts.c:59
#6  0xf6cb16be in ChangeStatusArea (xic=0xf6c458b0, reason=156017736, 
    call_data=0xf6c458b0 "") at guiIMStsArea.c:161
#7  0xf6cb73f8 in CallStatusDrawCallback (ic=0x94dc550, call_data=0xf6c45df0, 
    feedback_list=0xf6c458b0) at guiIMClbk.c:184
#8  0xf6cbc47c in IMProcessIncomingEvent (ic=0x94dc550) at iiimcfFun.c:194
#9  0xf6cbce4c in IMChangeFocus (ic=0x94dc550, flag=1) at iiimcfFun.c:611
#10 0xf6cb8b6a in IIIMP_SetFocus (xic=0x94dc550) at iiimpIC.c:376
#11 0xf6cbcdca in IMForwardEvent (ic=0x94dc550, ev=0xf6c462e0)
    at iiimcfFun.c:574
#12 0xf6cb8846 in IIIMP_Local_KeyFilter (d=0xf6c458b0, w=4140062896, 
    ev=0xf6c462e0, client_data=0x94dc550 " N?") at iiimpIC.c:260
#13 0x02a5eddd in XFilterEvent () from /usr/X11R6/lib/libX11.so.6
#14 0x0805b7e1 in XInputContext::filter_event (this=0x94daed0, 
    event=0xf6c462e0) at r6im/XInputContext.cpp:339
#15 0x08059688 in FilterEvent (icid=-154904400, event=0xf6c458b0)
    at r6im/R6IMProtocol.cpp:653
#16 0x080643bc in ForwardEventMessageProc (ims=0xf6c458b0, 
    call_data=0xf6c462d0, p=0xf6c460f0 "\002A\017\030?\005\005?")
    at r6im/i18nPtHdr.c:983
#17 0x08065c43 in _Xi18nMessageHandler (ims=0x94ca988, connect_id=2, 
    p=0x94f689c "\002", delete=0xf6c458b0) at r6im/i18nPtHdr.c:1563
#18 0x0805f84a in WaitXIMProtocol (dpy=0x94ca448, win=12582916, ev=0x94ca448, 
    client_data=0x94ca988 "\200윰06\bHČ\t") at r6im/i18nX.c:402
#19 0x02a5eddd in XFilterEvent () from /usr/X11R6/lib/libX11.so.6
#20 0x08058264 in R6IMProtocol::xevent_loop (client_data=0x94ba250)
    at r6im/R6IMProtocol.cpp:256
#21 0x00aed1d5 in start_thread () from /lib/tls/libpthread.so.0
#22 0x0088b2da in clone () from /lib/tls/libc.so.6
Comment 4 Jens Petersen 2004-11-29 09:22:21 EST
Tagoh pointed out that our xft patch seems to be causing the X error:
when the patch is disabled then httx works fine with Emacs.

Alternatively changing the XIM style to use XIMStatusNothing
(which puts the status under the window rather than in it) works too. :)
Comment 5 Jens Petersen 2004-11-30 01:43:42 EST
The latter change has been made in 21.3-19.
Comment 7 Lawrence Lim 2004-12-06 00:09:16 EST
Confirm fixed. Tested with emacs-21.3-19.EL and xemacs-21.4.15-10.EL.


Thanks.
Comment 8 Jens Petersen 2005-04-25 23:22:05 EDT
The issue with httx (now iiimx) has fixed in rawhide iiimf.
See bug 147457.

Note You need to log in before you can comment on or make changes to this bug.