Bug 1254165 - bash hangs when receive some signal. there is a bug in trap signal handling
bash hangs when receive some signal. there is a bug in trap signal handling
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: bash (Show other bugs)
6.3
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Ondrej Oprala
Jan Kepler
: Patch, ZStream
Depends On: 868846
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-17 06:17 EDT by Jan Kurik
Modified: 2015-09-22 10:02 EDT (History)
13 users (show)

See Also:
Fixed In Version: bash-4.1.2-33.el6_7.1
Doc Type: Bug Fix
Doc Text:
Due to the signal handler function calling certain signal-unsafe functions such as malloc(), the Bash shell in some cases became unresponsive after it received a signal. This update ensures that the signal handler no longer calls signal-unsafe functions, which prevents the described bug from occurring.
Story Points: ---
Clone Of: 868846
Environment:
Last Closed: 2015-09-22 10:02:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kurik 2015-08-17 06:17:28 EDT
This bug has been copied from bug #868846 and has been proposed
to be backported to 6.7 z-stream (EUS).
Comment 6 errata-xmlrpc 2015-09-22 10:02:50 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1811.html

Note You need to log in before you can comment on or make changes to this bug.