Bug 1254166 - xorg-x11-server freezes using R function X11() after updating to centos 6.7
xorg-x11-server freezes using R function X11() after updating to centos 6.7
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-server (Show other bugs)
6.7
x86_64 Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: Adam Jackson
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-17 06:28 EDT by Pablo HC
Modified: 2016-05-10 15:54 EDT (History)
4 users (show)

See Also:
Fixed In Version: xorg-x11-server-1.17.4-8.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-10 15:54:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pablo HC 2015-08-17 06:28:32 EDT
Description of problem:
After upgrading to centos 6.7, the function X11() in R (cran) freezes.
X11 draws a window, but nothing inside, the window cannot even be moved, and the only way to recover is killing R.

Version-Release number of selected component (if applicable):
centos 6.7
xorg-x11-server-Xort-1.15.0-36.elg.x86_64 ??

How reproducible:

I have tried with centos official R binary, but also with my own compiled R version, so an R problem should be discarded.

Steps to Reproduce:
1. Upgrade to centos 6.7 from 6.6
2. Execute R binary (from official repo or installed by source)
3. In the R console, type X11()

Actual results:
Window pop-up, but R freezes.

Expected results:


Additional info:
Comment 2 Alex Hartsell 2015-10-23 12:25:32 EDT
I have found that R is opening the window and waiting for an ExposureEvent, which it never receives causing the window to wait indefinitely and not paint. I believe this is related to the recent 0001-composite-Implement-backing-store-Always.patch in xorg-x11-server.

As a workaround, things work as expected if compositing is disabled in X. It seems only disabling the backing store is not enough.
Comment 5 Rudy 2016-04-12 15:58:46 EDT
(In reply to Alex Hartsell from comment #2)
> I have found that R is opening the window and waiting for an ExposureEvent,
> which it never receives causing the window to wait indefinitely and not
> paint. I believe this is related to the recent
> 0001-composite-Implement-backing-store-Always.patch in xorg-x11-server.
> 
> As a workaround, things work as expected if compositing is disabled in X. It
> seems only disabling the backing store is not enough.

Can confirm this bug happening, disabling composite fixed the issue! Thanks Alex!
Comment 8 errata-xmlrpc 2016-05-10 15:54:38 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0761.html

Note You need to log in before you can comment on or make changes to this bug.