Bug 1254177 - Right click on external HDD icon on Desktop causes nautilus to crash
Right click on external HDD icon on Desktop causes nautilus to crash
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: nautilus (Show other bugs)
7.1
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Alexander Larsson
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-17 07:05 EDT by Siteshwar Vashisht
Modified: 2015-11-19 03:35 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 03:35:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Siteshwar Vashisht 2015-08-17 07:05:31 EDT
Description of problem:
Right click on external HDD icon on Desktop causes nautilus to crash.

Version-Release number of selected component (if applicable):
nautilus-3.8.2-10.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Login to GNOME classic.
2. Attach external HDD with the system. HDD icon will appear on the Desktop.
3. Right click on the HDD icon on Desktop.

Actual results:
Nautilus crashes.

Expected results:
Context menu for the icon should be shown.

Additional info:
(gdb) bt
#0  0x00007f57171e95d7 in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
#1  0x00007f57171eacc8 in __GI_abort () at abort.c:90
#2  0x00007f57182ab8c5 in g_assertion_message (domain=domain@entry=0x0, file=file@entry=0x4f1b2a "nautilus-canvas-view.c", line=line@entry=1848, 
    func=func@entry=0x4f25c0 <__PRETTY_FUNCTION__.52178> "nautilus_canvas_view_update_click_mode", message=message@entry=0x168a7c0 "assertion failed: (canvas_container != NULL)") at gtestutils.c:2291
#3  0x00007f57182ab95a in g_assertion_message_expr (domain=domain@entry=0x0, file=file@entry=0x4f1b2a "nautilus-canvas-view.c", line=line@entry=1848, 
    func=func@entry=0x4f25c0 <__PRETTY_FUNCTION__.52178> "nautilus_canvas_view_update_click_mode", expr=expr@entry=0x4f1be7 "canvas_container != NULL") at gtestutils.c:2306
#4  0x00000000004306bc in nautilus_canvas_view_update_click_mode (canvas_view=<optimized out>) at nautilus-canvas-view.c:1848
#5  0x00007f5718582ce9 in g_cclosure_marshal_VOID__STRINGv (closure=0x1731b80, return_value=<optimized out>, instance=<optimized out>, args=<optimized out>, marshal_data=<optimized out>, n_params=<optimized out>, param_types=0x13b8e90)
    at gmarshal.c:1004
#6  0x00007f5718580207 in _g_closure_invoke_va (closure=closure@entry=0x1731b80, return_value=return_value@entry=0x0, instance=instance@entry=0x147c610, args=args@entry=0x7ffff7b3fb20, n_params=1, param_types=0x13b8e90)
    at gclosure.c:831
#7  0x00007f5718599487 in g_signal_emit_valist (instance=0x147c610, signal_id=<optimized out>, detail=2484, var_args=var_args@entry=0x7ffff7b3fb20) at gsignal.c:3215
#8  0x00007f571859a0ef in g_signal_emit (instance=instance@entry=0x147c610, signal_id=<optimized out>, detail=<optimized out>) at gsignal.c:3363
#9  0x00007f5718879c7c in g_settings_real_change_event (settings=0x147c610, keys=<optimized out>, n_keys=19) at gsettings.c:277
#10 0x00007f571279edac in ffi_call_unix64 () at ../src/x86/unix64.S:76
#11 0x00007f571279e6d5 in ffi_call (cif=cif@entry=0x7ffff7b3fea0, fn=<optimized out>, rvalue=0x7ffff7b3fdd0, avalue=avalue@entry=0x7ffff7b3fd70) at ../src/x86/ffi64.c:522
#12 0x00007f5718580c75 in g_cclosure_marshal_generic_va (closure=0x13b8f40, return_value=0x7ffff7b3ffe0, instance=0x147c610, args_list=<optimized out>, marshal_data=0x7f5718879c10 <g_settings_real_change_event>, n_params=2, 
    param_types=0x13b8f70) at gclosure.c:1541
#13 0x00007f5718580207 in _g_closure_invoke_va (closure=closure@entry=0x13b8f40, return_value=return_value@entry=0x7ffff7b3ffe0, instance=instance@entry=0x147c610, args=args@entry=0x7ffff7b400e0, n_params=2, param_types=0x13b8f70)
    at gclosure.c:831
#14 0x00007f5718599487 in g_signal_emit_valist (instance=0x147c610, signal_id=<optimized out>, detail=0, var_args=var_args@entry=0x7ffff7b400e0) at gsignal.c:3215
#15 0x00007f571859a0ef in g_signal_emit (instance=instance@entry=0x147c610, signal_id=<optimized out>, detail=detail@entry=0) at gsignal.c:3363
#16 0x00007f571887a408 in settings_backend_path_changed (target=0x147c610, backend=<optimized out>, path=<optimized out>, origin_tag=<optimized out>) at gsettings.c:352
#17 0x00007f571887526a in g_settings_backend_invoke_closure (user_data=0x14ecf40) at gsettingsbackend.c:267
#18 0x00007f57182869ba in g_main_dispatch (context=0x12f93b0) at gmain.c:3061
#19 g_main_context_dispatch (context=context@entry=0x12f93b0) at gmain.c:3660
#20 0x00007f5718286d08 in g_main_context_iterate (context=context@entry=0x12f93b0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3731
#21 0x00007f5718286dbc in g_main_context_iteration (context=0x12f93b0, context@entry=0x0, may_block=may_block@entry=1) at gmain.c:3792
#22 0x00007f57188650c4 in g_application_run (application=0x12d4210, argc=argc@entry=2, argv=argv@entry=0x7ffff7b40458) at gapplication.c:2114
#23 0x000000000042a3db in main (argc=2, argv=0x7ffff7b40458) at nautilus-main.c:104
(gdb) frame 3
#3  0x00007f57182ab95a in g_assertion_message_expr (domain=domain@entry=0x0, file=file@entry=0x4f1b2a "nautilus-canvas-view.c", line=line@entry=1848, 
    func=func@entry=0x4f25c0 <__PRETTY_FUNCTION__.52178> "nautilus_canvas_view_update_click_mode", expr=expr@entry=0x4f1be7 "canvas_container != NULL") at gtestutils.c:2306
2306      g_assertion_message (domain, file, line, func, s);
Comment 1 Vladimir Benes 2015-08-17 07:35:49 EDT
This should be fixed in 3.14, could you please retest on rhel-7.2 alpha if it's your case too?
Comment 3 Martin Simon 2015-09-01 07:43:45 EDT
I'm not able to reproduce this bug with nautilus-3.14.3-3.el7.x86_64. I can get the context menu and even preferences/browsing without any crash, so I assume this is fixed by the 3.14 rebase.
Comment 5 errata-xmlrpc 2015-11-19 03:35:51 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2236.html

Note You need to log in before you can comment on or make changes to this bug.