Bug 1254192 - [RFE] Take a set of default credentials for RHEV Provider Hosts
[RFE] Take a set of default credentials for RHEV Provider Hosts
Status: CLOSED WONTFIX
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers (Show other bugs)
unspecified
Unspecified Unspecified
medium Severity unspecified
: GA
: cfme-future
Assigned To: John Hardy
Dave Johnson
host
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-17 08:01 EDT by Jason Montleon
Modified: 2018-01-29 07:36 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-21 09:00:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Montleon 2015-08-17 08:01:25 EDT
Description of problem:


Version-Release number of selected component (if applicable):
5.3.4.2.20150415125246_f5d5c91

How reproducible:
Always

Steps to Reproduce:
1. Install CloudForms Management Engine
2. Configure a RHEV Provider 
3. Potentially many Hypervisors/Hosts will be automatically created.

Actual results:
Each one requires manual configuration of credentials

Requested results:
It would be nice if there were a way to configure a default set of credentials for new hosts so that they don't need to be configured manually.

Additional info:
I was attempting to use mechanize to create the Hosts for the provider with the correct credentials and then configure the Provider, letting the relationship be updated at which time everything works, but I hit https://bugzilla.redhat.com/show_bug.cgi?id=944685

After talking to the CloudForms team I was told this isn't really supported and it's a bug that I can create a non-ESXi Host.
Comment 1 Jason Montleon 2015-08-17 08:03:06 EDT
My apologies for leaving the description empty.
If it's not clear what I am seeing is that we have to manually add the credentials to a potentially large set of discovered hosts. It would be nice if we could provider a set of default credentials for discovered Hosts so they don't require any manual configuration.
Comment 3 Jason Montleon 2015-08-18 18:49:57 EDT
https://github.com/fusor/fusor/pull/311/files
Comment 5 Jason Montleon 2015-08-20 12:30:38 EDT
Sorry, I just realized my last two updates were not meant for this BZ...
Comment 6 Oved Ourfali 2016-01-13 06:31:24 EST
Greg - it sounds like a general issue, and not a rhev one.
What am I missing?
Comment 7 Greg Blomquist 2016-02-08 09:33:08 EST
@Oved, yeah, I think you're probably correct.  In fact, I don't even know how this would be done without a decent amount of general UX help to determine when/how a user would enter default host credentials.

I'm removing the rhev whiteboard.  I'll ask @johnhardy about the priority of this.
Comment 8 Greg Blomquist 2016-02-18 16:28:41 EST
John, is this something we should put on our backlog? If so, where does it sit in priority considering it may be something we'd implement for both RHEV and VMWare.  And, also considering I don't know of any customer requests for this type of feature.
Comment 9 Oved Ourfali 2016-05-10 04:17:43 EDT
Based on comment #7 this isn't RHEV specific. Removing rhev from the whiteboard.
Comment 11 Chris Pelland 2017-08-21 09:00:01 EDT
This bug has been open for more than a year and is assigned to an older release of CloudForms. 

If you would like to keep this Bugzilla open and if the issue is still present in the latest version of the product, please file a new Bugzilla which will be added and assigned to the latest release of CloudForms.

Note You need to log in before you can comment on or make changes to this bug.