Bug 1254215 - (CVE-2015-3220) CVE-2015-3220 python-tlslite: denial of service triggered by a malformed packet
CVE-2015-3220 python-tlslite: denial of service triggered by a malformed packet
Status: NEW
Product: Security Response
Classification: Other
Component: vulnerability (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Red Hat Product Security
impact=moderate,public=20150812,repor...
: Security
Depends On: 1254216 1254217
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-17 08:48 EDT by Vasyl Kaigorodov
Modified: 2015-08-17 11:36 EDT (History)
7 users (show)

See Also:
Fixed In Version: python-tlslite 0.4.9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vasyl Kaigorodov 2015-08-17 08:48:18 EDT
It was reported that python-tlslite will raise a runtime exception if it gets a message with an empty payload.
Upstream announcement: https://groups.google.com/forum/#!topic/tlslite-dev/MoWE7B0A4iU
Upstream commit: https://github.com/trevp/tlslite/commit/aca8d4f898b436ff6754e1a9ab96cae976c8a853
Comment 1 Vasyl Kaigorodov 2015-08-17 08:48:58 EDT
Created python-tlslite tracking bugs for this issue:

Affects: fedora-all [bug 1254216]
Comment 2 Vasyl Kaigorodov 2015-08-17 08:49:01 EDT
Created python-gdata tracking bugs for this issue:

Affects: fedora-all [bug 1254217]

Note You need to log in before you can comment on or make changes to this bug.