Bug 1254230 - REST API : Operation of exporting template to Export domain stucks
REST API : Operation of exporting template to Export domain stucks
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.6.0
x86_64 Linux
unspecified Severity urgent
: ovirt-3.6.0-rc
: 3.6.0
Assigned To: Moti Asayag
: Automation, AutomationBlocker, Regression
: 1256026 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-17 09:14 EDT by GenadiC
Modified: 2016-04-19 21:37 EDT (History)
15 users (show)

See Also:
Fixed In Version: 3.6.0-12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-19 21:37:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 45327 master ABANDONED core: Index entity managers by transaction Never
oVirt gerrit 45547 master MERGED engine: Revert JPA Never
oVirt gerrit 45586 ovirt-engine-3.6 MERGED engine: Revert JPA Never

  None (edit)
Description GenadiC 2015-08-17 09:14:23 EDT
Description of problem:
Though action of exporting template to Export Domain succeeds (template exists after several minutes in GUI), the Rest command is stucked

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Send xml (attached below) to the API


Actual results:
API action is stucked though action succeeds

Expected results:
API action should not stuck

Additional info:
In our case we sent the follwoing "body" to https://jenkins-vm-07.scl.lab.tlv.redhat.com/ovirt-engine/api/templates/3b8f685b-a503-4974-bdf6-a46d5a9bf7df/export


<action>    
<async>false</async>    
<grace_period>        
<expiry>10</expiry>   
 </grace_period>    
<storage_domain>        
<name>export_domain</name>    
</storage_domain>    
<exclusive>false</exclusive>
</action>
Comment 1 Juan Hernández 2015-08-18 04:27:15 EDT
It is the second time that I see this problem in the last few days, see bug 1253338. Initially I thought that bug was a specific problem when restoring a snapshot, but it looks like it is a more generic issue with caching in the DAO layer. In both cases (this bug and bug 1253338) the command executed returns a job and checking the status of that job (using the GetJobByJobId query) always returns STARTED, even if the database already contains FINISHED.
Comment 2 Allon Mureinik 2015-08-25 06:16:43 EDT
*** Bug 1256026 has been marked as a duplicate of this bug. ***
Comment 3 GenadiC 2015-10-07 09:51:26 EDT
Verified on 3.6.0-0.18.el6

Note You need to log in before you can comment on or make changes to this bug.