Bug 1254248 - [abrt] WARNING: CPU: 0 PID: 1699 at drivers/gpu/drm/i915/i915_gem.c:5269 i915_gem_track_fb+0x129/0x140 [i915]() [i915]
[abrt] WARNING: CPU: 0 PID: 1699 at drivers/gpu/drm/i915/i915_gem.c:5269 i915...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:e105817ae735991f1711e201940...
: HardwareEnablement
: 1241197 1317158 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-17 09:48 EDT by Itamar Reis Peixoto
Modified: 2016-05-09 15:57 EDT (History)
80 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-17 12:11:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dmesg (77.05 KB, text/plain)
2015-08-17 09:48 EDT, Itamar Reis Peixoto
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 91866 None None None Never

  None (edit)
Description Itamar Reis Peixoto 2015-08-17 09:48:40 EDT
Additional info:
reporter:       libreport-2.6.2
WARNING: CPU: 0 PID: 1699 at drivers/gpu/drm/i915/i915_gem.c:5269 i915_gem_track_fb+0x129/0x140 [i915]()
WARN_ON(!(old->frontbuffer_bits & frontbuffer_bits))
Modules linked in:
 xt_CHECKSUM ipt_MASQUERADE nf_nat_masquerade_ipv4 tun nf_conntrack_netbios_ns nf_conntrack_broadcast ip6t_rpfilter ip6t_REJECT nf_reject_ipv6 xt_conntrack ebtable_nat ebtable_filter ebtable_broute bridge ebtables ip6table_security ip6table_raw ip6table_mangle ip6table_nat nf_conntrack_ipv6 nf_defrag_ipv6 nf_nat_ipv6 ip6table_filter ip6_tables iptable_security iptable_raw iptable_mangle iptable_nat nf_conntrack_ipv4 nf_defrag_ipv4 nf_nat_ipv4 nf_nat nf_conntrack rc_dib0700_rc5 dib8000 dvb_usb_dib0700 dib7000m rtsx_usb_ms dib0090 memstick dib0070 dib3000mc dibx000_common dvb_usb dvb_core rc_core vfat fat arc4 brcmsmac cordic brcmutil b43 mac80211 cfg80211 ssb intel_rapl iTCO_wdt iTCO_vendor_support iosf_mbi uvcvideo x86_pkg_temp_thermal coretemp kvm_intel snd_hda_codec_hdmi videobuf2_vmalloc
 videobuf2_core kvm snd_hda_codec_conexant videobuf2_memops snd_hda_codec_generic v4l2_common videodev uas snd_hda_intel usb_storage media snd_hda_codec snd_hda_core snd_hwdep snd_seq i2c_i801 snd_seq_device snd_pcm bcma ideapad_laptop snd_timer sparse_keymap snd mei_me rfkill mei soundcore shpchp lpc_ich nfsd auth_rpcgss nfs_acl lockd grace sunrpc dm_crypt i915 crct10dif_pclmul crc32_pclmul crc32c_intel 8021q i2c_algo_bit drm_kms_helper garp stp llc ghash_clmulni_intel mrp drm serio_raw alx mdio video rtsx_usb_sdmmc mmc_core rtsx_usb
CPU: 0 PID: 1699 Comm: gnome-shell Not tainted 4.2.0-0.rc5.git0.2.fc23.x86_64 #1
Hardware name: LENOVO 20150/INVALID, BIOS 5ECN96WW(V9.01) 03/14/2013
 0000000000000000 000000001486e0ec ffff880410e13a28 ffffffff8176e150
 0000000000000000 ffff880410e13a80 ffff880410e13a68 ffffffff8109c786
 ffff8804185b0000 0000000000000001 ffff88040db9df80 ffff880419680240
Call Trace:
 [<ffffffff8176e150>] dump_stack+0x45/0x57
 [<ffffffff8109c786>] warn_slowpath_common+0x86/0xc0
 [<ffffffff8109c815>] warn_slowpath_fmt+0x55/0x70
 [<ffffffffa0160719>] i915_gem_track_fb+0x129/0x140 [i915]
 [<ffffffffa01a7507>] intel_prepare_plane_fb+0xe7/0x1a0 [i915]
 [<ffffffffa0109e89>] drm_atomic_helper_prepare_planes+0x59/0xe0 [drm_kms_helper]
 [<ffffffffa019f7be>] __intel_set_mode+0x1ae/0xb80 [i915]
 [<ffffffffa01a149f>] ? intel_modeset_compute_config+0x3af/0xb60 [i915]
 [<ffffffffa01a6e49>] intel_crtc_set_config+0x2c9/0x600 [i915]
 [<ffffffffa0069326>] drm_mode_set_config_internal+0x66/0x100 [drm]
 [<ffffffffa006d809>] drm_mode_setcrtc+0x3e9/0x500 [drm]
 [<ffffffffa005e365>] drm_ioctl+0x125/0x610 [drm]
 [<ffffffffa006d420>] ? drm_mode_setplane+0x1b0/0x1b0 [drm]
 [<ffffffff8122c4a5>] do_vfs_ioctl+0x295/0x470
 [<ffffffff8132412d>] ? selinux_file_ioctl+0x4d/0xc0
 [<ffffffff8122c6f9>] SyS_ioctl+0x79/0x90
 [<ffffffff8177476e>] entry_SYSCALL_64_fastpath+0x12/0x71

Potential duplicate: bug 1241197
Comment 1 Itamar Reis Peixoto 2015-08-17 09:48:48 EDT
Created attachment 1063862 [details]
File: dmesg
Comment 2 Andrey Motoshkov 2015-10-13 05:10:13 EDT
Description of problem:
getting to gdm login screen with 3 monitors on the system supporting maximum 2 (Dell Latitude E6330)

Version-Release number of selected component:
kernel

Additional info:
reporter:       libreport-2.6.2
cmdline:        BOOT_IMAGE=/vmlinuz-4.2.3-300.fc23.x86_64 root=/dev/mapper/fedora_dragonfly-root ro rd.lvm.lv=fedora_dragonfly/swap rd.lvm.lv=fedora_dragonfly/root rhgb quiet LANG=en_US.utf8
kernel:         4.2.3-300.fc23.x86_64
runlevel:       5 3
type:           Kerneloops

Truncated backtrace:
WARNING: CPU: 1 PID: 5318 at drivers/gpu/drm/i915/i915_gem.c:5269 i915_gem_track_fb+0x129/0x140 [i915]()
WARN_ON(!(old->frontbuffer_bits & frontbuffer_bits))
Modules linked in: rfcomm fuse cmac nf_conntrack_netbios_ns nf_conntrack_broadcast ip6t_rpfilter ip6t_REJECT nf_reject_ipv6 xt_conntrack ebtable_broute bridge stp llc ebtable_nat ebtable_filter ebtables ip6table_raw ip6table_nat nf_conntrack_ipv6 nf_defrag_ipv6 nf_nat_ipv6 ip6table_security ip6table_mangle ip6table_filter ip6_tables iptable_raw iptable_nat nf_conntrack_ipv4 nf_defrag_ipv4 nf_nat_ipv4 nf_nat nf_conntrack iptable_security iptable_mangle bnep uvcvideo videobuf2_vmalloc videobuf2_core videobuf2_memops v4l2_common intel_rapl iosf_mbi btusb btrtl x86_pkg_temp_thermal btbcm coretemp snd_hda_codec_hdmi btintel snd_hda_codec_idt kvm_intel videodev bluetooth cdc_ether iTCO_wdt iTCO_vendor_support usbnet dell_wmi mii ppdev sparse_keymap cdc_acm cdc_wdm arc4 iwldvm snd_hda_codec_generic
 kvm snd_hda_intel snd_hda_codec mac80211 dell_laptop media snd_hda_core crct10dif_pclmul crc32_pclmul snd_hwdep iwlwifi snd_seq snd_seq_device dcdbas snd_pcm cfg80211 crc32c_intel ghash_clmulni_intel dell_smm_hwmon snd_timer snd dell_rbtn rfkill soundcore joydev i2c_i801 lpc_ich wmi parport_pc parport dell_smo8800 shpchp mei_me mei nfsd auth_rpcgss nfs_acl lockd grace sunrpc i915 i2c_algo_bit serio_raw sdhci_pci e1000e drm_kms_helper sdhci mmc_core drm ptp pps_core video
CPU: 1 PID: 5318 Comm: (agetty) Not tainted 4.2.3-300.fc23.x86_64 #1
Hardware name: Dell Inc. Latitude E6330/0P1XMK, BIOS A13 06/20/2014
 0000000000000000 0000000031245e75 ffff8803f90f3708 ffffffff81771fca
 0000000000000000 ffff8803f90f3760 ffff8803f90f3748 ffffffff8109e4a6
 ffff880408140cc0 0000000000000010 ffff88040747c000 ffff8803b4d8a640
Call Trace:
 [<ffffffff81771fca>] dump_stack+0x45/0x57
 [<ffffffff8109e4a6>] warn_slowpath_common+0x86/0xc0
 [<ffffffff8109e535>] warn_slowpath_fmt+0x55/0x70
 [<ffffffffa0160739>] i915_gem_track_fb+0x129/0x140 [i915]
 [<ffffffffa01a7537>] intel_prepare_plane_fb+0xe7/0x1a0 [i915]
 [<ffffffffa00cde89>] drm_atomic_helper_prepare_planes+0x59/0xe0 [drm_kms_helper]
 [<ffffffffa019f88e>] __intel_set_mode+0x1ae/0xb60 [i915]
 [<ffffffffa01a154f>] ? intel_modeset_compute_config+0x3af/0xb60 [i915]
 [<ffffffffa01a6ee6>] intel_crtc_set_config+0x2b6/0x580 [i915]
 [<ffffffffa002f326>] drm_mode_set_config_internal+0x66/0x100 [drm]
 [<ffffffffa00d1512>] restore_fbdev_mode+0xc2/0xf0 [drm_kms_helper]
 [<ffffffffa00d3399>] drm_fb_helper_restore_fbdev_mode_unlocked+0x29/0x70 [drm_kms_helper]
 [<ffffffffa00d3402>] drm_fb_helper_set_par+0x22/0x40 [drm_kms_helper]
 [<ffffffffa01b584a>] intel_fbdev_set_par+0x1a/0x60 [i915]
 [<ffffffff814136b6>] fb_set_var+0x236/0x460
 [<ffffffff811ac33a>] ? __alloc_pages_nodemask+0x19a/0x980
 [<ffffffff814097d2>] fbcon_blank+0x312/0x360
 [<ffffffff8132922b>] ? cred_has_capability+0x6b/0x100
 [<ffffffff8148e453>] do_unblank_screen+0xd3/0x1a0
 [<ffffffff81483a1a>] vt_ioctl+0x50a/0x12e0
 [<ffffffff8147dfad>] ? n_tty_ioctl_helper+0x2d/0x140
 [<ffffffff81477023>] tty_ioctl+0x3c3/0xb80
 [<ffffffff812312b5>] do_vfs_ioctl+0x295/0x470
 [<ffffffff8132930d>] ? selinux_file_ioctl+0x4d/0xc0
 [<ffffffff81231509>] SyS_ioctl+0x79/0x90
 [<ffffffff817789ae>] entry_SYSCALL_64_fastpath+0x12/0x71
Comment 3 Julian Stecklina 2015-10-21 04:29:09 EDT
Happens to me as well with Haswell IGP and dual monitor setup.

00:02.0 VGA compatible controller [0300]: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller [8086:0412] (rev 06)
Comment 4 Jiri Konecny 2015-10-21 04:49:37 EDT
Same problem here. 2 monitors setup.
When I was working on my notebook it froze with no know reason to me.
Comment 5 Steve Harms 2015-10-22 13:22:44 EDT
3 monitor setup on a W541:

[   33.235243] ------------[ cut here ]------------
[   33.235264] WARNING: CPU: 1 PID: 1894 at drivers/gpu/drm/i915/i915_gem.c:5269 i915_gem_track_fb+0x129/0x140 [i915]()
[   33.235265] WARN_ON(!(old->frontbuffer_bits & frontbuffer_bits))
[   33.235267] Modules linked in:
[   33.235268]  cmac xt_CHECKSUM ipt_MASQUERADE nf_nat_masquerade_ipv4 tun nf_conntrack_netbios_ns nf_conntrack_broadcast ip6t_rpfilter ip6t_REJECT nf_reject_ipv6 xt_conntrack ebtable_nat ebtable_filter ebtable_broute bridge stp llc ebtables ip6table_raw ip6table_security ip6table_nat nf_conntrack_ipv6 nf_defrag_ipv6 nf_nat_ipv6 ip6table_mangle ip6table_filter ip6_tables iptable_raw iptable_security iptable_nat nf_conntrack_ipv4 nf_defrag_ipv4 nf_nat_ipv4 nf_nat nf_conntrack iptable_mangle bbswitch(OE) bnep btusb uvcvideo btrtl btbcm videobuf2_vmalloc btintel videobuf2_core bluetooth videobuf2_memops v4l2_common videodev media arc4 iwlmvm snd_hda_codec_realtek snd_hda_codec_hdmi snd_hda_codec_generic iTCO_wdt mac80211 iTCO_vendor_support snd_hda_intel intel_rapl iosf_mbi snd_hda_codec x86_pkg_temp_thermal
[   33.235300]  coretemp snd_hda_core iwlwifi snd_hwdep kvm_intel snd_seq snd_seq_device kvm cfg80211 snd_pcm ie31200_edac joydev mei_me i2c_i801 thinkpad_acpi lpc_ich snd_timer edac_core tpm_tis mei snd shpchp soundcore tpm rfkill nfsd auth_rpcgss nfs_acl lockd grace sunrpc dm_crypt nouveau i915 mxm_wmi ttm i2c_algo_bit drm_kms_helper crct10dif_pclmul crc32_pclmul crc32c_intel sdhci_pci drm ghash_clmulni_intel e1000e sdhci serio_raw mmc_core ptp pps_core wmi video
[   33.235328] CPU: 1 PID: 1894 Comm: gnome-shell Tainted: G        W  OE   4.2.3-300.fc23.x86_64 #1
[   33.235329] Hardware name: LENOVO 20EF000LUS/20EF000LUS, BIOS GNET76WW (2.24 ) 09/03/2015
[   33.235330]  0000000000000000 00000000c66f3007 ffff8808447d7a28 ffffffff81771fca
[   33.235333]  0000000000000000 ffff8808447d7a80 ffff8808447d7a68 ffffffff8109e4a6
[   33.235335]  ffff880036860000 0000000000000001 ffff880854bf7cc0 ffff880854bfc240
[   33.235337] Call Trace:
[   33.235341]  [<ffffffff81771fca>] dump_stack+0x45/0x57
[   33.235345]  [<ffffffff8109e4a6>] warn_slowpath_common+0x86/0xc0
[   33.235347]  [<ffffffff8109e535>] warn_slowpath_fmt+0x55/0x70
[   33.235358]  [<ffffffffa01db739>] i915_gem_track_fb+0x129/0x140 [i915]
[   33.235371]  [<ffffffffa0222537>] intel_prepare_plane_fb+0xe7/0x1a0 [i915]
[   33.235377]  [<ffffffffa0197e89>] drm_atomic_helper_prepare_planes+0x59/0xe0 [drm_kms_helper]
[   33.235389]  [<ffffffffa021a88e>] __intel_set_mode+0x1ae/0xb60 [i915]
[   33.235401]  [<ffffffffa021c54f>] ? intel_modeset_compute_config+0x3af/0xb60 [i915]
[   33.235412]  [<ffffffffa0221ee6>] intel_crtc_set_config+0x2b6/0x580 [i915]
[   33.235421]  [<ffffffffa00d9326>] drm_mode_set_config_internal+0x66/0x100 [drm]
[   33.235429]  [<ffffffffa00dd809>] drm_mode_setcrtc+0x3e9/0x500 [drm]
[   33.235435]  [<ffffffffa00ce365>] drm_ioctl+0x125/0x610 [drm]
[   33.235437]  [<ffffffff813232df>] ? avc_compute_av+0x11f/0x190
[   33.235444]  [<ffffffffa00dd420>] ? drm_mode_setplane+0x1b0/0x1b0 [drm]
[   33.235447]  [<ffffffff812312b5>] do_vfs_ioctl+0x295/0x470
[   33.235450]  [<ffffffff8132930d>] ? selinux_file_ioctl+0x4d/0xc0
[   33.235451]  [<ffffffff81231509>] SyS_ioctl+0x79/0x90
[   33.235455]  [<ffffffff817789ae>] entry_SYSCALL_64_fastpath+0x12/0x71
[   33.235457] ---[ end trace dde5d33a4dc79280 ]---
Comment 6 David Strauss 2015-10-22 14:13:37 EDT
These are usually related to DisplayPort MST.
Comment 7 fred 2015-10-26 10:27:50 EDT
I think it happenend when I unplugged my secondary screen running wayland and some xwayland apps.
Comment 8 Robert Hancock 2015-10-27 19:03:15 EDT
(In reply to David Strauss from comment #6)
> These are usually related to DisplayPort MST.

No MST involved in my case. This should be tagged as a regression. Kernel warnings and/or oopses can be reproducibly triggered by connecting/disconnecting displays which wasn't the case in previous kernels.
Comment 9 Môshe van der Sterre 2015-10-28 09:30:02 EDT
I got this WARN_ON immediately after a cold boot on my XPS 13, while having a DP->HDMI cable and display connected.

I am  trying different ways of connecting, including using an MST hub. However, I disconnected all that before cold booting this time.
Comment 10 Robert Hancock 2015-11-02 09:19:56 EST
Still occurring with kernel-4.2.5-201.fc22.x86_64
Comment 11 AGS 2015-11-02 12:53:53 EST
Seems like a duplicate of #1241197
https://bugzilla.redhat.com/show_bug.cgi?id=1241197

Also happening on Fedora Workstation 23. Everything including the GNOME Wayland session was working fine until I disconnected a DP connected monitor in a hurry to go to a meeting.  Now only the X11 session starts and GNOME Wayland crashes back to the login screen. What's strange is that I can start GNOME Wayland running only on the laptop monitor alone but once connecting the DP adapter everything goes crazy. This seems to persist across reboots and even power disconnections, nothing seems to be able to reset it.

Linux version 4.2.3-300.fc23.x86_64:
Nov 02 11:34:29 user-t440p kernel: ------------[ cut here ]------------
Nov 02 11:34:29 user-t440p kernel: WARNING: CPU: 0 PID: 893 at drivers/gpu/drm/i915/i915_gem.c:5269 i915_gem_track_fb+0x129/0x140 [i915]()
Nov 02 11:34:29 user-t440p kernel: WARN_ON(!(old->frontbuffer_bits & frontbuffer_bits))
Nov 02 11:34:29 user-t440p kernel: Modules linked in: rfcomm fuse cmac xt_CHECKSUM ipt_MASQUERADE nf_nat_masquerade_ipv4 tun ip6t_rpfilter ip6t_REJECT nf_reject_ipv6 xt_conntrack ebtable_broute bridge stp llc ebtable_nat ebtable_filte
Nov 02 11:34:29 user-t440p kernel:  snd_hda_intel videobuf2_memops v4l2_common videodev iwlwifi joydev snd_hda_codec snd_usbmidi_lib snd_rawmidi media snd_hda_core snd_hwdep cfg80211 i2c_i801 snd_seq snd_seq_device snd_pcm mei_me thin
Nov 02 11:34:29 user-t440p kernel: CPU: 0 PID: 893 Comm: systemd-logind Tainted: G        W       4.2.3-300.fc23.x86_64 #1
Nov 02 11:34:29 user-t440p kernel: Hardware name: LENOVO 20AN0069US/20AN0069US, BIOS GLET74WW (2.28 ) 10/21/2014
Nov 02 11:34:29 user-t440p kernel:  0000000000000000 0000000011edb941 ffff8800368bf708 ffffffff81771fca
Nov 02 11:34:29 user-t440p kernel:  0000000000000000 ffff8800368bf760 ffff8800368bf748 ffffffff8109e4a6
Nov 02 11:34:29 user-t440p kernel:  ffff880428098180 0000000000000010 ffff8800a93d8000 ffff8804077d1f80
Nov 02 11:34:29 user-t440p kernel: Call Trace:
Nov 02 11:34:29 user-t440p kernel:  [<ffffffff81771fca>] dump_stack+0x45/0x57
Nov 02 11:34:29 user-t440p kernel:  [<ffffffff8109e4a6>] warn_slowpath_common+0x86/0xc0
Nov 02 11:34:29 user-t440p kernel:  [<ffffffff8109e535>] warn_slowpath_fmt+0x55/0x70
Nov 02 11:34:29 user-t440p kernel:  [<ffffffffa016b739>] i915_gem_track_fb+0x129/0x140 [i915]
Nov 02 11:34:29 user-t440p kernel:  [<ffffffffa01b2537>] intel_prepare_plane_fb+0xe7/0x1a0 [i915]
Nov 02 11:34:29 user-t440p kernel:  [<ffffffffa00fee89>] drm_atomic_helper_prepare_planes+0x59/0xe0 [drm_kms_helper]
Nov 02 11:34:29 user-t440p kernel:  [<ffffffffa01aa88e>] __intel_set_mode+0x1ae/0xb60 [i915]
Nov 02 11:34:29 user-t440p kernel:  [<ffffffffa01ac54f>] ? intel_modeset_compute_config+0x3af/0xb60 [i915]
Nov 02 11:34:29 user-t440p kernel:  [<ffffffffa01b1ee6>] intel_crtc_set_config+0x2b6/0x580 [i915]
Nov 02 11:34:29 user-t440p kernel:  [<ffffffffa0046326>] drm_mode_set_config_internal+0x66/0x100 [drm]
Nov 02 11:34:29 user-t440p kernel:  [<ffffffffa0102512>] restore_fbdev_mode+0xc2/0xf0 [drm_kms_helper]
Nov 02 11:34:29 user-t440p kernel:  [<ffffffffa0104399>] drm_fb_helper_restore_fbdev_mode_unlocked+0x29/0x70 [drm_kms_helper]
Nov 02 11:34:29 user-t440p kernel:  [<ffffffffa0104402>] drm_fb_helper_set_par+0x22/0x40 [drm_kms_helper]
Nov 02 11:34:29 user-t440p kernel:  [<ffffffffa01c084a>] intel_fbdev_set_par+0x1a/0x60 [i915]
Nov 02 11:34:29 user-t440p kernel:  [<ffffffff814136b6>] fb_set_var+0x236/0x460
Nov 02 11:34:29 user-t440p kernel:  [<ffffffff813390eb>] ? context_struct_compute_av+0x30b/0x3f0
Nov 02 11:34:29 user-t440p kernel:  [<ffffffff812000c6>] ? kmem_cache_alloc+0x1d6/0x210
Nov 02 11:34:29 user-t440p kernel:  [<ffffffff813230c7>] ? avc_alloc_node+0x27/0x120
Nov 02 11:34:29 user-t440p kernel:  [<ffffffff814097d2>] fbcon_blank+0x312/0x360
Nov 02 11:34:29 user-t440p kernel:  [<ffffffff8132922b>] ? cred_has_capability+0x6b/0x100
Nov 02 11:34:29 user-t440p kernel:  [<ffffffff8148e453>] do_unblank_screen+0xd3/0x1a0
Nov 02 11:34:29 user-t440p kernel:  [<ffffffff81483a1a>] vt_ioctl+0x50a/0x12e0
Nov 02 11:34:29 user-t440p kernel:  [<ffffffff81477023>] tty_ioctl+0x3c3/0xb80
Nov 02 11:34:29 user-t440p kernel:  [<ffffffff811ffa60>] ? kfree+0x130/0x140
Nov 02 11:34:29 user-t440p kernel:  [<ffffffff812312b5>] do_vfs_ioctl+0x295/0x470
Nov 02 11:34:29 user-t440p kernel:  [<ffffffff8132930d>] ? selinux_file_ioctl+0x4d/0xc0
Nov 02 11:34:29 user-t440p kernel:  [<ffffffff81231509>] SyS_ioctl+0x79/0x90
Nov 02 11:34:29 user-t440p kernel:  [<ffffffff817789ae>] entry_SYSCALL_64_fastpath+0x12/0x71
Nov 02 11:34:29 user-t440p kernel: ---[ end trace 608775decd3e5053 ]---
Comment 12 AGS 2015-11-02 14:13:03 EST
Also confirming happening on 4.2.5-300.fc23.x86_64, update didn't fix this issue.
Comment 13 Andrey Motoshkov 2015-11-05 07:57:07 EST
Description of problem:
Getting to gdm login screen with 3 displays

Version-Release number of selected component:
kernel

Additional info:
reporter:       libreport-2.6.3
cmdline:        BOOT_IMAGE=/vmlinuz-4.2.5-300.fc23.x86_64 root=/dev/mapper/fedora_dragonfly-root ro rd.lvm.lv=fedora_dragonfly/swap rd.lvm.lv=fedora_dragonfly/root rhgb quiet LANG=en_US.utf8
kernel:         4.2.5-300.fc23.x86_64
runlevel:       5 3
type:           Kerneloops

Truncated backtrace:
WARNING: CPU: 1 PID: 901 at drivers/gpu/drm/i915/i915_gem.c:5269 i915_gem_track_fb+0x129/0x140 [i915]()
WARN_ON(!(old->frontbuffer_bits & frontbuffer_bits))
Modules linked in: rfcomm fuse cmac nf_conntrack_netbios_ns nf_conntrack_broadcast ip6t_rpfilter ip6t_REJECT nf_reject_ipv6 xt_conntrack ebtable_broute bridge stp llc ebtable_filter ebtable_nat ebtables ip6table_security ip6table_nat nf_conntrack_ipv6 nf_defrag_ipv6 nf_nat_ipv6 ip6table_raw ip6table_mangle ip6table_filter ip6_tables iptable_security iptable_nat nf_conntrack_ipv4 nf_defrag_ipv4 nf_nat_ipv4 nf_nat nf_conntrack iptable_raw iptable_mangle bnep btusb btrtl btbcm btintel uvcvideo videobuf2_vmalloc videobuf2_core videobuf2_memops bluetooth v4l2_common videodev dell_wmi ppdev media sparse_keymap iTCO_wdt iTCO_vendor_support cdc_ether intel_rapl usbnet iosf_mbi mii cdc_wdm x86_pkg_temp_thermal cdc_acm arc4 coretemp kvm_intel snd_hda_codec_hdmi iwldvm kvm mac80211 snd_hda_codec_idt
 snd_hda_codec_generic snd_hda_intel snd_hda_codec snd_hda_core snd_hwdep iwlwifi dell_laptop dcdbas crct10dif_pclmul snd_seq snd_seq_device snd_pcm dell_smm_hwmon crc32_pclmul crc32c_intel snd_timer snd cfg80211 joydev i2c_i801 soundcore shpchp parport_pc wmi mei_me dell_rbtn rfkill mei lpc_ich parport dell_smo8800 nfsd auth_rpcgss nfs_acl lockd grace sunrpc i915 serio_raw sdhci_pci sdhci i2c_algo_bit e1000e mmc_core drm_kms_helper drm ptp pps_core video
CPU: 1 PID: 901 Comm: systemd-logind Not tainted 4.2.5-300.fc23.x86_64 #1
Hardware name: Dell Inc. Latitude E6330/0P1XMK, BIOS A13 06/20/2014
 0000000000000000 0000000069bc2440 ffff8804016776d8 ffffffff8177280a
 0000000000000000 ffff880401677730 ffff880401677718 ffffffff8109e4b6
 ffff880408a8c840 0000000000000010 ffff8804070ec000 ffff8803fa130d80
Call Trace:
 [<ffffffff8177280a>] dump_stack+0x45/0x57
 [<ffffffff8109e4b6>] warn_slowpath_common+0x86/0xc0
 [<ffffffff8109e545>] warn_slowpath_fmt+0x55/0x70
 [<ffffffffa016b739>] i915_gem_track_fb+0x129/0x140 [i915]
 [<ffffffffa01b2287>] intel_prepare_plane_fb+0xe7/0x1a0 [i915]
 [<ffffffffa0093ec9>] drm_atomic_helper_prepare_planes+0x59/0xe0 [drm_kms_helper]
 [<ffffffffa01aa5de>] __intel_set_mode+0x1ae/0xb60 [i915]
 [<ffffffffa01ac29f>] ? intel_modeset_compute_config+0x3af/0xb60 [i915]
 [<ffffffffa01b1c36>] intel_crtc_set_config+0x2b6/0x580 [i915]
 [<ffffffffa002f306>] drm_mode_set_config_internal+0x66/0x100 [drm]
 [<ffffffffa0097552>] restore_fbdev_mode+0xc2/0xf0 [drm_kms_helper]
 [<ffffffffa00993d9>] drm_fb_helper_restore_fbdev_mode_unlocked+0x29/0x70 [drm_kms_helper]
 [<ffffffffa0099442>] drm_fb_helper_set_par+0x22/0x40 [drm_kms_helper]
 [<ffffffffa01c059a>] intel_fbdev_set_par+0x1a/0x60 [i915]
 [<ffffffff814138ff>] ? fb_set_var+0x2ef/0x460
 [<ffffffff81413846>] fb_set_var+0x236/0x460
 [<ffffffff810d16fa>] ? check_preempt_wakeup+0xfa/0x210
 [<ffffffff810d11d9>] ? update_curr+0x79/0x150
 [<ffffffff81409962>] fbcon_blank+0x312/0x360
 [<ffffffff8148e623>] do_unblank_screen+0xd3/0x1a0
 [<ffffffff8148365d>] complete_change_console+0x5d/0xe0
 [<ffffffff814849a2>] vt_ioctl+0x12c2/0x12e0
 [<ffffffff81778c5e>] ? _raw_spin_unlock_irqrestore+0xe/0x10
 [<ffffffff814771f3>] tty_ioctl+0x3c3/0xba0
 [<ffffffff813239b2>] ? avc_has_perm+0x122/0x190
 [<ffffffff8177910d>] ? tty_unlock+0x2d/0x60
 [<ffffffff812313b5>] do_vfs_ioctl+0x295/0x470
 [<ffffffff8132944d>] ? selinux_file_ioctl+0x4d/0xc0
 [<ffffffff81231609>] SyS_ioctl+0x79/0x90
 [<ffffffff817791ee>] entry_SYSCALL_64_fastpath+0x12/0x71
Comment 14 Michael Catanzaro 2015-11-08 00:46:13 EST
*** Bug 1241197 has been marked as a duplicate of this bug. ***
Comment 15 Stuart Auchterlonie 2015-11-09 06:22:49 EST
I hit this on my system just by booting it up (within 15s of bootup)

In my case, there is a DRM error immediately preceeding each of these
stack traces

[drm:check_crtc_state [i915]] *ERROR* mismatch in ips_enabled (expected 1, found 0)
Comment 16 Martin Kolman 2015-11-10 04:46:46 EST
Description of problem:
Upgraded to F23 and ABRT reported this crash after I logged in for the first time after the upgrade.

Version-Release number of selected component:
kernel

Additional info:
reporter:       libreport-2.6.3
cmdline:        BOOT_IMAGE=/vmlinuz-4.2.5-300.fc23.x86_64 root=/dev/mapper/fedora_dhcp--29--242-root ro rd.lvm.lv=fedora_dhcp-29-242/swap rd.md=0 rd.dm=0 vconsole.keymap=cz-lat2 rd.lvm.lv=fedora_dhcp-29-242/root rd.luks.uuid=luks-03eeaf47-f9e1-4172-9bdf-f96a6ed68e59 rhgb quiet zswap.enabled=1 zswap.max_pool_percent=25 zswap.compressor=lz4 LANG=cs_CZ.UTF-8
kernel:         4.2.5-300.fc23.x86_64
runlevel:       N 5
type:           Kerneloops

Truncated backtrace:
WARNING: CPU: 2 PID: 1672 at drivers/gpu/drm/i915/i915_gem.c:5269 i915_gem_track_fb+0x129/0x140 [i915]()
WARN_ON(!(old->frontbuffer_bits & frontbuffer_bits))
Modules linked in:
 xt_CHECKSUM fuse ipt_MASQUERADE nf_nat_masquerade_ipv4 tun rpcsec_gss_krb5 nfsv4 dns_resolver nfs fscache ip6t_rpfilter ip6t_REJECT nf_reject_ipv6 xt_conntrack ebtable_filter ebtable_broute bridge stp llc ebtable_nat ebtables ip6table_security ip6table_nat nf_conntrack_ipv6 nf_defrag_ipv6 nf_nat_ipv6 ip6table_raw ip6table_mangle ip6table_filter ip6_tables iptable_security iptable_nat nf_conntrack_ipv4 nf_defrag_ipv4 nf_nat_ipv4 nf_nat nf_conntrack iptable_raw iptable_mangle uvcvideo videobuf2_vmalloc videobuf2_core videobuf2_memops v4l2_common videodev media intel_rapl iosf_mbi x86_pkg_temp_thermal coretemp kvm_intel arc4 kvm iwldvm snd_hda_codec_hdmi snd_hda_codec_realtek mac80211 iTCO_wdt iTCO_vendor_support snd_hda_codec_generic snd_hda_intel iwlwifi cfg80211 snd_hda_codec snd_hda_core
 snd_hwdep mei_me snd_seq snd_seq_device snd_pcm mei i2c_i801 joydev shpchp lpc_ich snd_timer thinkpad_acpi snd soundcore wmi tpm_tis rfkill tpm nfsd auth_rpcgss nfs_acl lockd grace sunrpc binfmt_misc dm_crypt hid_microsoft i915 crct10dif_pclmul crc32_pclmul crc32c_intel e1000e i2c_algo_bit drm_kms_helper sdhci_pci sdhci drm serio_raw mmc_core ptp pps_core video lz4 lz4_compress
CPU: 2 PID: 1672 Comm: gnome-shell Not tainted 4.2.5-300.fc23.x86_64 #1
Hardware name: LENOVO 2325F51/2325F51, BIOS G2ET86WW (2.06 ) 11/13/2012
 0000000000000000 00000000f4d2178a ffff88020f493a28 ffffffff8177280a
 0000000000000000 ffff88020f493a80 ffff88020f493a68 ffffffff8109e4b6
 ffff880211a60000 0000000000000010 ffff8800b009cfc0 ffff880211bf5440
Call Trace:
 [<ffffffff8177280a>] dump_stack+0x45/0x57
 [<ffffffff8109e4b6>] warn_slowpath_common+0x86/0xc0
 [<ffffffff8109e545>] warn_slowpath_fmt+0x55/0x70
 [<ffffffffa0185739>] i915_gem_track_fb+0x129/0x140 [i915]
 [<ffffffffa01cc287>] intel_prepare_plane_fb+0xe7/0x1a0 [i915]
 [<ffffffffa00ebec9>] drm_atomic_helper_prepare_planes+0x59/0xe0 [drm_kms_helper]
 [<ffffffffa01c45de>] __intel_set_mode+0x1ae/0xb60 [i915]
 [<ffffffffa01c629f>] ? intel_modeset_compute_config+0x3af/0xb60 [i915]
 [<ffffffffa01cbc36>] intel_crtc_set_config+0x2b6/0x580 [i915]
 [<ffffffffa0072306>] drm_mode_set_config_internal+0x66/0x100 [drm]
 [<ffffffffa00767e9>] drm_mode_setcrtc+0x3e9/0x500 [drm]
 [<ffffffffa0067365>] drm_ioctl+0x125/0x610 [drm]
 [<ffffffffa0076400>] ? drm_mode_setplane+0x1b0/0x1b0 [drm]
 [<ffffffff812313b5>] do_vfs_ioctl+0x295/0x470
 [<ffffffff81140ffb>] ? __audit_syscall_entry+0xab/0xf0
 [<ffffffff810223ab>] ? do_audit_syscall_entry+0x4b/0x70
 [<ffffffff81231609>] SyS_ioctl+0x79/0x90
 [<ffffffff810238e5>] ? syscall_trace_leave+0xb5/0x110
 [<ffffffff817791ee>] entry_SYSCALL_64_fastpath+0x12/0x71
Comment 17 David Strauss 2015-11-10 10:13:23 EST
Still seeing this on a 100% updated F23 installation. T440p with two chained (DisplayPort MST) Dell U2715H displays.
Comment 18 Stefan Assmann 2015-11-13 11:58:35 EST
Same backtrace on W541 after I logged in via wayland.

# uname -a
Linux w541 4.2.5-300.fc23.x86_64 #1 SMP Tue Oct 27 04:29:56 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
Comment 19 Peter H. Jones 2015-11-15 17:45:30 EST
Description of problem:
Trying to connect a second display to my laptop.

Version-Release number of selected component:
kernel

Additional info:
reporter:       libreport-2.6.3
cmdline:        BOOT_IMAGE=/vmlinuz-4.2.6-200.fc22.x86_64 root=/dev/mapper/fedora-root ro rd.lvm.lv=fedora/swap rd.lvm.lv=fedora/root rhgb quiet LANG=en_US.UTF-8
kernel:         4.2.6-200.fc22.x86_64
runlevel:       unknown
type:           Kerneloops

Truncated backtrace:
WARNING: CPU: 1 PID: 782 at drivers/gpu/drm/i915/i915_gem.c:5269 i915_gem_track_fb+0x129/0x140 [i915]()
WARN_ON(!(old->frontbuffer_bits & frontbuffer_bits))
Modules linked in:
 vfat fat rfcomm fuse xt_CHECKSUM ipt_MASQUERADE nf_nat_masquerade_ipv4 tun uas usb_storage nf_conntrack_netbios_ns nf_conntrack_broadcast ip6t_rpfilter ip6t_REJECT nf_reject_ipv6 xt_conntrack ebtable_nat ebtable_broute bridge ebtable_filter ebtables ip6table_nat nf_conntrack_ipv6 nf_defrag_ipv6 nf_nat_ipv6 ip6table_mangle ip6table_security ip6table_raw ip6table_filter ip6_tables iptable_nat nf_conntrack_ipv4 nf_defrag_ipv4 nf_nat_ipv4 nf_nat nf_conntrack iptable_mangle iptable_security iptable_raw bnep uvcvideo videobuf2_vmalloc videobuf2_core videobuf2_memops snd_hda_codec_hdmi v4l2_common snd_hda_codec_realtek videodev media snd_hda_codec_generic btusb btrtl btbcm iTCO_wdt btintel iTCO_vendor_support bluetooth coretemp snd_hda_intel kvm snd_hda_codec snd_hda_core snd_hwdep snd_seq
 snd_seq_device snd_pcm arc4 iwldvm input_polldev lpc_ich mac80211 snd_timer i2c_i801 iwlwifi cfg80211 snd tpm_infineon tpm_tis tpm rfkill soundcore fujitsu_laptop shpchp acpi_cpufreq nfsd auth_rpcgss nfs_acl lockd grace sunrpc binfmt_misc i915 sdhci_pci sdhci firewire_ohci mmc_core 8021q i2c_algo_bit garp drm_kms_helper stp llc mrp serio_raw drm sky2 firewire_core yenta_socket crc_itu_t video
CPU: 1 PID: 782 Comm: systemd-logind Not tainted 4.2.6-200.fc22.x86_64 #1
Hardware name: FUJITSU LifeBook P8020/FJNB1F4, BIOS Version 1.12  03/16/2009
 0000000000000000 000000000d19b4f8 ffff88013a6f37d8 ffffffff817729ea
 0000000000000000 ffff88013a6f3830 ffff88013a6f3818 ffffffff8109e4b6
 ffff880139b89b40 0000000000000010 ffff880036392900 ffff880036392900
Call Trace:
 [<ffffffff817729ea>] dump_stack+0x45/0x57
 [<ffffffff8109e4b6>] warn_slowpath_common+0x86/0xc0
 [<ffffffff8109e545>] warn_slowpath_fmt+0x55/0x70
 [<ffffffffa016a739>] i915_gem_track_fb+0x129/0x140 [i915]
 [<ffffffffa01b12d7>] intel_prepare_plane_fb+0xe7/0x1a0 [i915]
 [<ffffffffa00c7eb9>] drm_atomic_helper_prepare_planes+0x59/0xe0 [drm_kms_helper]
 [<ffffffffa01a961e>] __intel_set_mode+0x1ae/0xb60 [i915]
 [<ffffffffa01ab2df>] ? intel_modeset_compute_config+0x3af/0xb60 [i915]
 [<ffffffffa01b0c86>] intel_crtc_set_config+0x2b6/0x580 [i915]
 [<ffffffffa0064306>] drm_mode_set_config_internal+0x66/0x100 [drm]
 [<ffffffffa00cb542>] restore_fbdev_mode+0xc2/0xf0 [drm_kms_helper]
 [<ffffffffa00cd3c9>] drm_fb_helper_restore_fbdev_mode_unlocked+0x29/0x70 [drm_kms_helper]
 [<ffffffffa00cd432>] drm_fb_helper_set_par+0x22/0x40 [drm_kms_helper]
 [<ffffffffa00cd35a>] drm_fb_helper_hotplug_event+0xca/0x110 [drm_kms_helper]
 [<ffffffffa00cd3ec>] drm_fb_helper_restore_fbdev_mode_unlocked+0x4c/0x70 [drm_kms_helper]
 [<ffffffffa01c02ae>] intel_fbdev_restore_mode+0x1e/0x50 [i915]
 [<ffffffffa01e970e>] i915_driver_lastclose+0xe/0x20 [i915]
 [<ffffffffa00578ee>] drm_lastclose+0x2e/0x140 [drm]
 [<ffffffffa0057caf>] drm_release+0x2af/0x490 [drm]
 [<ffffffff8121fd6c>] __fput+0xdc/0x1e0
 [<ffffffff8121febe>] ____fput+0xe/0x10
 [<ffffffff810bab8b>] task_work_run+0x9b/0xb0
 [<ffffffff810a0bc1>] do_exit+0x391/0xae0
 [<ffffffff810a13a7>] do_group_exit+0x47/0xb0
 [<ffffffff810ac7b4>] get_signal+0x274/0x600
 [<ffffffff811d608a>] ? handle_mm_fault+0xc8a/0x17d0
 [<ffffffff81014347>] do_signal+0x37/0x6b0
 [<ffffffff8110dca5>] ? ktime_get_ts64+0x45/0xf0
 [<ffffffff812320ea>] ? poll_select_copy_remaining+0x11a/0x140
 [<ffffffff812339f5>] ? SyS_ppoll+0xf5/0x1b0
 [<ffffffff81014a3c>] do_notify_resume+0x7c/0x90
 [<ffffffff817795bc>] int_signal+0x12/0x17
Comment 20 Marcos Paulo 2015-11-16 11:08:24 EST
Happened with me right now while using my laptop and and a second monitor.

Please let me know if I can do anything to help in testing...

[ 8040.015371] WARNING: CPU: 3 PID: 1886 at drivers/gpu/drm/i915/intel_display.c:1362 assert_plane.constprop.98+0x6f/0x90 [i915]()
[ 8040.015372] plane A assertion failure (expected on, current off)
[ 8040.015424] Modules linked in: bnep bluetooth fuse xt_CHECKSUM ipt_MASQUERADE nf_nat_masquerade_ipv4 tun nf_conntrack_netbios_ns nf_conntrack_broadcast ip6t_rpfilter ip6t_REJECT nf_reject_ipv6 xt_conntrack ebtable_broute bridge ebtable_nat ebtable_filter ebtables ip6table_mangle ip6table_security ip6table_nat nf_conntrack_ipv6 nf_defrag_ipv6 nf_nat_ipv6 ip6table_raw ip6table_filter ip6_tables iptable_mangle iptable_security iptable_nat nf_conntrack_ipv4 nf_defrag_ipv4 nf_nat_ipv4 nf_nat nf_conntrack iptable_raw vfat fat intel_rapl iosf_mbi x86_pkg_temp_thermal coretemp uvcvideo videobuf2_vmalloc kvm_intel videobuf2_core videobuf2_memops v4l2_common snd_hda_codec_hdmi snd_hda_codec_conexant snd_hda_codec_generic arc4 kvm snd_soc_rt5640 snd_hda_intel videodev iTCO_wdt iTCO_vendor_support media rt2800pci
[ 8040.015452]  rt2800mmio rt2800lib snd_hda_codec rt2x00pci asus_nb_wmi snd_soc_rl6231 snd_soc_core snd_hda_core rt2x00mmio asus_wmi sparse_keymap rt2x00lib mac80211 cfg80211 eeprom_93cx6 crc_ccitt rfkill snd_hwdep snd_compress snd_pcm_dmaengine ac97_bus snd_seq crct10dif_pclmul crc32_pclmul snd_seq_device snd_pcm crc32c_intel joydev snd_soc_sst_acpi snd_timer mei_me mei dw_dmac dw_dmac_core shpchp snd i2c_designware_platform i2c_designware_core soundcore lpc_ich i2c_i801 nfsd auth_rpcgss nfs_acl lockd grace sunrpc nouveau i915 mxm_wmi ttm i2c_algo_bit drm_kms_helper 8021q garp stp llc mrp drm serio_raw alx mdio sdhci_acpi sdhci mmc_core wmi i2c_hid video
[ 8040.015455] CPU: 3 PID: 1886 Comm: Xorg Tainted: G        W       4.2.5-300.fc23.x86_64 #1
[ 8040.015455] Hardware name: ASUSTeK COMPUTER INC. X450LCP/X450LCP, BIOS X450LCP.207 04/11/2014
[ 8040.015458]  0000000000000000 00000000ace6be71 ffff8800c8593718 ffffffff8177280a
[ 8040.015460]  0000000000000000 ffff8800c8593770 ffff8800c8593758 ffffffff8109e4b6
[ 8040.015461]  0000000000000000 0000000000000000 ffff880222fb0000 ffff8802257ea000
[ 8040.015461] Call Trace:
[ 8040.015467]  [<ffffffff8177280a>] dump_stack+0x45/0x57
[ 8040.015471]  [<ffffffff8109e4b6>] warn_slowpath_common+0x86/0xc0
[ 8040.015474]  [<ffffffff8109e545>] warn_slowpath_fmt+0x55/0x70
[ 8040.015495]  [<ffffffffa01aeaff>] assert_plane.constprop.98+0x6f/0x90 [i915]
[ 8040.015513]  [<ffffffffa01b7ae9>] hsw_disable_ips+0x39/0x180 [i915]
[ 8040.015528]  [<ffffffffa01b7c84>] intel_pre_disable_primary+0x54/0x90 [i915]
[ 8040.015542]  [<ffffffffa01b7cfa>] intel_crtc_disable_planes+0x3a/0x100 [i915]
[ 8040.015555]  [<ffffffffa01b8656>] __intel_set_mode+0x226/0xb60 [i915]
[ 8040.015568]  [<ffffffffa01ba29f>] ? intel_modeset_compute_config+0x3af/0xb60 [i915]
[ 8040.015583]  [<ffffffffa01bfc36>] intel_crtc_set_config+0x2b6/0x580 [i915]
[ 8040.015595]  [<ffffffffa007e306>] drm_mode_set_config_internal+0x66/0x100 [drm]
[ 8040.015600]  [<ffffffffa0102552>] restore_fbdev_mode+0xc2/0xf0 [drm_kms_helper]
[ 8040.015605]  [<ffffffffa01043d9>] drm_fb_helper_restore_fbdev_mode_unlocked+0x29/0x70 [drm_kms_helper]
[ 8040.015609]  [<ffffffffa0104442>] drm_fb_helper_set_par+0x22/0x40 [drm_kms_helper]
[ 8040.015623]  [<ffffffffa01ce59a>] intel_fbdev_set_par+0x1a/0x60 [i915]
[ 8040.015627]  [<ffffffff81413846>] fb_set_var+0x236/0x460
[ 8040.015630]  [<ffffffff810c6d8d>] ? ttwu_do_wakeup+0x1d/0xd0
[ 8040.015633]  [<ffffffff81233249>] ? do_sys_poll+0x149/0x5c0
[ 8040.015635]  [<ffffffff81409962>] fbcon_blank+0x312/0x360
[ 8040.015639]  [<ffffffff81647a9e>] ? sock_def_readable+0x3e/0x70
[ 8040.015642]  [<ffffffff8148e623>] do_unblank_screen+0xd3/0x1a0
[ 8040.015644]  [<ffffffff81483bea>] vt_ioctl+0x50a/0x12e0
[ 8040.015646]  [<ffffffff814771f3>] tty_ioctl+0x3c3/0xba0
[ 8040.015650]  [<ffffffff811d6030>] ? handle_mm_fault+0xcc0/0x17d0
[ 8040.015653]  [<ffffffff8121e57b>] ? do_readv_writev+0x14b/0x250
[ 8040.015655]  [<ffffffff812313b5>] do_vfs_ioctl+0x295/0x470
[ 8040.015658]  [<ffffffff81065454>] ? __do_page_fault+0x1b4/0x400
[ 8040.015660]  [<ffffffff81231609>] SyS_ioctl+0x79/0x90
[ 8040.015662]  [<ffffffff810656cf>] ? do_page_fault+0x2f/0x80
[ 8040.015665]  [<ffffffff817791ee>] entry_SYSCALL_64_fastpath+0x12/0x71
[ 8040.015666] ---[ end trace 98d7e0ccb26af0d8 ]---
[ 8047.935915] ACPI Warning: \_SB_.PCI0.RP05.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20150619/nsarguments-95)
[ 8047.936608] ACPI: \_SB_.PCI0.RP05.PEGP: failed to evaluate _DSM
[ 8047.936624] ACPI Warning: \_SB_.PCI0.RP05.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20150619/nsarguments-95)
[ 8055.822025] [drm:drm_edid_block_valid [drm]] *ERROR* EDID checksum is invalid, remainder is 104
[ 8055.822033] Raw EDID:
[ 8055.822037]  	00 ff ff ff ff ff ff 00 1e 6d ee 57 01 01 01 01
[ 8055.822039]  	01 14 01 03 80 33 1c 78 ea c6 65 a0 59 58 9d 27
[ 8055.822042]  	0e 50 54 a1 08 00 b3 00 81 80 71 40 81 40 01 01
[ 8055.822044]  	01 01 01 01 01 01 1a 36 80 a0 70 38 1f 40 30 20
[ 8055.822047]  	35 00 fd 1e 11 00 00 1a 02 3a 80 18 71 38 2d 40
[ 8055.822049]  	53 2c 45 00 fd 1e 11 00 00 1e 00 00 00 fd 00 30
[ 8055.822052]  	3d 1c 53 0f 00 0a 20 20 20 20 20 20 00 00 00 fc
[ 8055.822054]  	00 4d 32 33 38 30 41 0a 20 20 ff ff ff ff ff ff
[ 8055.834246] [drm:drm_edid_block_valid [drm]] *ERROR* EDID checksum is invalid, remainder is 187
[ 8055.834253] Raw EDID:
[ 8055.834257]  	00 ff ff ff ff ff ff 00 1e 6d ee 57 01 01 01 01
[ 8055.834259]  	01 14 01 03 80 33 1c 78 ea c6 65 a0 59 58 9d 27
[ 8055.834261]  	0e 50 54 a1 08 00 b3 00 81 80 71 40 81 40 01 01
[ 8055.834263]  	01 01 01 01 01 01 1a 36 80 a0 70 38 00 00 00 00
[ 8055.834266]  	01 ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[ 8055.834268]  	ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[ 8055.834270]  	ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[ 8055.834272]  	ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[ 8076.951420] ACPI Warning: \_SB_.PCI0.RP05.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20150619/nsarguments-95)
[ 8076.952125] ACPI: \_SB_.PCI0.RP05.PEGP: failed to evaluate _DSM
[ 8076.952138] ACPI Warning: \_SB_.PCI0.RP05.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20150619/nsarguments-95)
[ 8138.008759] ACPI Warning: \_SB_.PCI0.RP05.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20150619/nsarguments-95)
[ 8138.009155] ACPI: \_SB_.PCI0.RP05.PEGP: failed to evaluate _DSM
[ 8138.009161] ACPI Warning: \_SB_.PCI0.RP05.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20150619/nsarguments-95)
Comment 21 Marcos Paulo 2015-11-16 11:16:07 EST
After some minutes that I plug an HDMI cable and share my screen with a second monitor, the crash happens.
Comment 22 Robert Hancock 2015-11-16 11:16:14 EST
This happens on every single bootup on a machine I use with two DisplayPort-connected monitors. I have to wonder how this bug got into a released kernel since it's so easily reproducible - this is hardly some exotic hardware platform.

Also not sure why this is tagged as HardwareEnablement instead of Regression, since it affects setups that were working perfectly fine previously. Also have to wonder if anyone pays any attention to these ABRT reports at all, given the number of people that have reported this without any real response. I guess we can hope that this is fixed in the 4.3 kernel.
Comment 23 Gustavo Maciel Dias Vieira 2015-11-17 08:44:17 EST
Description of problem:
Alternating users

Version-Release number of selected component:
kernel

Additional info:
reporter:       libreport-2.6.3
cmdline:        BOOT_IMAGE=/boot/vmlinuz-4.2.5-300.fc23.x86_64 root=UUID=63d1e316-f80c-4bb6-af52-2a1b4509197f ro rhgb quiet
kernel:         4.2.5-300.fc23.x86_64
runlevel:       N 5
type:           Kerneloops

Truncated backtrace:
WARNING: CPU: 0 PID: 1926 at drivers/gpu/drm/i915/i915_gem.c:5269 i915_gem_track_fb+0x129/0x140 [i915]()
WARN_ON(!(old->frontbuffer_bits & frontbuffer_bits))
Modules linked in:
 vhost_net vhost macvtap macvlan ccm bnep bluetooth fuse xt_CHECKSUM ipt_MASQUERADE nf_nat_masquerade_ipv4 tun ip6t_rpfilter ip6t_REJECT nf_reject_ipv6 xt_conntrack ebtable_broute bridge stp llc ebtable_nat ebtable_filter ebtables ip6table_raw ip6table_nat nf_conntrack_ipv6 nf_defrag_ipv6 nf_nat_ipv6 ip6table_mangle ip6table_security ip6table_filter ip6_tables iptable_raw iptable_nat nf_conntrack_ipv4 nf_defrag_ipv4 nf_nat_ipv4 nf_nat nf_conntrack iptable_mangle iptable_security uvcvideo intel_rapl iosf_mbi x86_pkg_temp_thermal videobuf2_vmalloc videobuf2_core coretemp videobuf2_memops v4l2_common kvm_intel videodev kvm media snd_hda_codec_hdmi iTCO_wdt crct10dif_pclmul snd_hda_codec_idt iTCO_vendor_support crc32_pclmul crc32c_intel snd_hda_codec_generic hp_wmi sparse_keymap arc4 iwldvm
 mac80211 snd_hda_intel snd_hda_codec snd_hda_core rtsx_pci_ms memstick iwlwifi cfg80211 snd_hwdep joydev mei_me snd_seq snd_seq_device snd_pcm rfkill lpc_ich snd_timer wmi shpchp snd soundcore mei i2c_i801 hp_accel lis3lv02d input_polldev nfsd auth_rpcgss nfs_acl lockd grace sunrpc i915 rtsx_pci_sdmmc mmc_core i2c_algo_bit drm_kms_helper drm atl1c serio_raw rtsx_pci video
CPU: 0 PID: 1926 Comm: Xorg Not tainted 4.2.5-300.fc23.x86_64 #1
Hardware name: Hewlett-Packard HP Pavilion dm4 Notebook PC/1650, BIOS F.14 11/16/2011
 0000000000000000 00000000d87fb3d0 ffff88022b8d3ac8 ffffffff8177280a
 0000000000000000 ffff88022b8d3b20 ffff88022b8d3b08 ffffffff8109e4b6
 ffff880242870000 0000000000000010 ffff88002acd4d80 ffff88002acd4d80
Call Trace:
 [<ffffffff8177280a>] dump_stack+0x45/0x57
 [<ffffffff8109e4b6>] warn_slowpath_common+0x86/0xc0
 [<ffffffff8109e545>] warn_slowpath_fmt+0x55/0x70
 [<ffffffffa011d739>] i915_gem_track_fb+0x129/0x140 [i915]
 [<ffffffffa0164287>] intel_prepare_plane_fb+0xe7/0x1a0 [i915]
 [<ffffffffa00afec9>] drm_atomic_helper_prepare_planes+0x59/0xe0 [drm_kms_helper]
 [<ffffffffa00744e5>] ? drm_atomic_check_only+0x215/0x540 [drm]
 [<ffffffffa0176202>] intel_atomic_commit+0x42/0x100 [i915]
 [<ffffffffa0074847>] drm_atomic_commit+0x37/0x60 [drm]
 [<ffffffffa00b1537>] drm_atomic_helper_plane_set_property+0x87/0xc0 [drm_kms_helper]
 [<ffffffffa00624b9>] ? _object_find+0x69/0xa0 [drm]
 [<ffffffffa0062e2d>] drm_mode_plane_set_obj_prop+0x2d/0x90 [drm]
 [<ffffffffa00696e6>] drm_mode_obj_set_property_ioctl+0x1c6/0x270 [drm]
 [<ffffffffa0059365>] drm_ioctl+0x125/0x610 [drm]
 [<ffffffff8125e1b6>] ? fsnotify+0x316/0x4a0
 [<ffffffffa0069520>] ? drm_mode_obj_get_properties_ioctl+0xa0/0xa0 [drm]
 [<ffffffff812313b5>] do_vfs_ioctl+0x295/0x470
 [<ffffffff8132944d>] ? selinux_file_ioctl+0x4d/0xc0
 [<ffffffff81231609>] SyS_ioctl+0x79/0x90
 [<ffffffff817791ee>] entry_SYSCALL_64_fastpath+0x12/0x71
Comment 24 Adam Williamson 2015-11-17 14:32:54 EST
Robert: I already associated this bug with an upstream report, https://bugs.freedesktop.org/show_bug.cgi?id=91866 , where one of the developers is active on it.
Comment 25 Francesco Frassinelli (frafra) 2015-11-18 19:00:28 EST
Description of problem:
VT switching.

Version-Release number of selected component:
kernel

Additional info:
reporter:       libreport-2.6.3
cmdline:        BOOT_IMAGE=/vmlinuz-4.2.5-300.fc23.x86_64 root=UUID=6d95a3dd-0830-4bf9-94c1-a37232327df9 ro rootflags=subvol=root rd.luks.uuid=luks-81064417-7468-43b9-8e39-2e5e9e332d40 rd.luks.uuid=luks-87e2654d-afaa-402c-a4a7-1d6aa1e2403b rhgb quiet i915.enable_ips=0 LANG=it_IT.UTF-8
kernel:         4.2.5-300.fc23.x86_64
runlevel:       N 5
type:           Kerneloops

Truncated backtrace:
WARNING: CPU: 1 PID: 1500 at drivers/gpu/drm/i915/i915_gem.c:5269 i915_gem_track_fb+0x129/0x140 [i915]()
WARN_ON(!(old->frontbuffer_bits & frontbuffer_bits))
Modules linked in:
 ccm rfcomm fuse ipt_MASQUERADE nf_nat_masquerade_ipv4 tun nf_conntrack_netbios_ns nf_conntrack_broadcast ip6t_rpfilter ip6t_REJECT nf_reject_ipv6 xt_conntrack ebtable_nat ebtable_filter ebtable_broute bridge ebtables ip6table_security ip6table_nat nf_conntrack_ipv6 nf_defrag_ipv6 nf_nat_ipv6 ip6table_raw ip6table_mangle ip6table_filter ip6_tables iptable_security iptable_nat nf_conntrack_ipv4 nf_defrag_ipv4 nf_nat_ipv4 nf_nat nf_conntrack iptable_raw iptable_mangle bnep arc4 intel_rapl iosf_mbi iTCO_wdt iwlmvm iTCO_vendor_support x86_pkg_temp_thermal coretemp kvm_intel mac80211 uvcvideo vfat fat videobuf2_vmalloc videobuf2_core kvm videobuf2_memops snd_hda_codec_realtek iwlwifi snd_hda_codec_generic v4l2_common snd_hda_codec_hdmi videodev btusb btrtl btbcm snd_hda_intel btintel bluetooth
 cfg80211 snd_hda_codec snd_hda_core snd_hwdep snd_seq i2c_i801 media snd_seq_device lpc_ich rfkill snd_pcm snd_timer snd acpi_als kfifo_buf soundcore mei_me acpi_pad industrialio mei shpchp nfsd auth_rpcgss nfs_acl lockd grace sunrpc btrfs xor raid6_pq dm_crypt i915 crct10dif_pclmul crc32_pclmul crc32c_intel i2c_algo_bit drm_kms_helper 8021q garp stp llc drm mrp serio_raw r8169 mii video
CPU: 1 PID: 1500 Comm: Xorg Not tainted 4.2.5-300.fc23.x86_64 #1
Hardware name: Intel Corporation SharkBay Platform/WhiteTip Mountain1 Fab2, BIOS 5.6.5 03/17/2015
 0000000000000000 000000008a28f00f ffff88022ff1fac8 ffffffff8177280a
 0000000000000000 ffff88022ff1fb20 ffff88022ff1fb08 ffffffff8109e4b6
 ffff8802424810c0 0000000000000010 ffff880241f30000 ffff880241f30000
Call Trace:
 [<ffffffff8177280a>] dump_stack+0x45/0x57
 [<ffffffff8109e4b6>] warn_slowpath_common+0x86/0xc0
 [<ffffffff8109e545>] warn_slowpath_fmt+0x55/0x70
 [<ffffffffa0133739>] i915_gem_track_fb+0x129/0x140 [i915]
 [<ffffffffa017a287>] intel_prepare_plane_fb+0xe7/0x1a0 [i915]
 [<ffffffffa00d6ec9>] drm_atomic_helper_prepare_planes+0x59/0xe0 [drm_kms_helper]
 [<ffffffffa005e4e5>] ? drm_atomic_check_only+0x215/0x540 [drm]
 [<ffffffffa018c202>] intel_atomic_commit+0x42/0x100 [i915]
 [<ffffffffa005e847>] drm_atomic_commit+0x37/0x60 [drm]
 [<ffffffffa00d8537>] drm_atomic_helper_plane_set_property+0x87/0xc0 [drm_kms_helper]
 [<ffffffffa004c4b9>] ? _object_find+0x69/0xa0 [drm]
 [<ffffffffa004ce2d>] drm_mode_plane_set_obj_prop+0x2d/0x90 [drm]
 [<ffffffffa00536e6>] drm_mode_obj_set_property_ioctl+0x1c6/0x270 [drm]
 [<ffffffffa0043365>] drm_ioctl+0x125/0x610 [drm]
 [<ffffffffa0053520>] ? drm_mode_obj_get_properties_ioctl+0xa0/0xa0 [drm]
 [<ffffffff812313b5>] do_vfs_ioctl+0x295/0x470
 [<ffffffff8132944d>] ? selinux_file_ioctl+0x4d/0xc0
 [<ffffffff81231609>] SyS_ioctl+0x79/0x90
 [<ffffffff81775147>] ? schedule+0x37/0x80
 [<ffffffff817791ee>] entry_SYSCALL_64_fastpath+0x12/0x71
Comment 26 lennart_reuther 2015-11-24 15:27:52 EST
Description of problem:
possibly while started new gnome session using wayland

Version-Release number of selected component:
kernel

Additional info:
reporter:       libreport-2.6.3
cmdline:        BOOT_IMAGE=/vmlinuz-4.2.6-300.fc23.x86_64 root=/dev/mapper/fedora-root ro rd.lvm.lv=fedora/swap rd.md=0 rd.dm=0 rd.luks=0 vconsole.font=latarcyrheb-sun16 rd.lvm.lv=fedora/root vconsole.keymap=de rhgb quiet LANG=de_DE.UTF-8
kernel:         4.2.6-300.fc23.x86_64
runlevel:       unknown
type:           Kerneloops

Truncated backtrace:
WARNING: CPU: 1 PID: 864 at drivers/gpu/drm/i915/i915_gem.c:5269 i915_gem_track_fb+0x129/0x140 [i915]()
WARN_ON(!(old->frontbuffer_bits & frontbuffer_bits))
Modules linked in: ipheth rfcomm bnep btusb btrtl btbcm btintel bluetooth uas usblp usb_storage ccm fuse xt_CHECKSUM ipt_MASQUERADE nf_nat_masquerade_ipv4 tun nf_conntrack_netbios_ns nf_conntrack_broadcast ip6t_rpfilter ip6t_REJECT nf_reject_ipv6 xt_conntrack ebtable_broute bridge stp llc ebtable_nat ebtable_filter ebtables ip6table_mangle ip6table_nat nf_conntrack_ipv6 nf_defrag_ipv6 nf_nat_ipv6 ip6table_raw ip6table_security ip6table_filter ip6_tables iptable_mangle iptable_nat nf_conntrack_ipv4 nf_defrag_ipv4 nf_nat_ipv4 nf_nat nf_conntrack iptable_raw iptable_security dm_crypt iTCO_wdt iTCO_vendor_support coretemp kvm_intel kvm arc4 snd_hda_codec_conexant snd_hda_codec_generic iwldvm snd_hda_intel mac80211 snd_hda_codec iwlwifi snd_hda_core snd_hwdep snd_seq snd_seq_device cfg80211
 snd_pcm i2c_i801 lpc_ich snd_timer shpchp thinkpad_acpi snd wmi tpm_tis soundcore rfkill tpm mei_me mei acpi_cpufreq nfsd auth_rpcgss nfs_acl lockd grace sunrpc i915 i2c_algo_bit drm_kms_helper drm e1000e serio_raw ptp pps_core video
CPU: 1 PID: 864 Comm: systemd-logind Not tainted 4.2.6-300.fc23.x86_64 #1
Hardware name: LENOVO 7458WCC/7458WCC, BIOS 6DET71WW (3.21 ) 12/13/2011
 0000000000000000 00000000c4a8c930 ffff880228473688 ffffffff817729ea
 0000000000000000 ffff8802284736e0 ffff8802284736c8 ffffffff8109e4b6
 ffff88022fedfb40 0000000000000010 ffff88022fa18900 ffff88022fa18900
Call Trace:
 [<ffffffff817729ea>] dump_stack+0x45/0x57
 [<ffffffff8109e4b6>] warn_slowpath_common+0x86/0xc0
 [<ffffffff8109e545>] warn_slowpath_fmt+0x55/0x70
 [<ffffffffa0130739>] i915_gem_track_fb+0x129/0x140 [i915]
 [<ffffffffa01772d7>] intel_prepare_plane_fb+0xe7/0x1a0 [i915]
 [<ffffffffa00e2eb9>] drm_atomic_helper_prepare_planes+0x59/0xe0 [drm_kms_helper]
 [<ffffffffa016f61e>] __intel_set_mode+0x1ae/0xb60 [i915]
 [<ffffffffa01712df>] ? intel_modeset_compute_config+0x3af/0xb60 [i915]
 [<ffffffffa0176c86>] intel_crtc_set_config+0x2b6/0x580 [i915]
 [<ffffffffa007e306>] drm_mode_set_config_internal+0x66/0x100 [drm]
 [<ffffffffa00e6542>] restore_fbdev_mode+0xc2/0xf0 [drm_kms_helper]
 [<ffffffffa00e83c9>] drm_fb_helper_restore_fbdev_mode_unlocked+0x29/0x70 [drm_kms_helper]
 [<ffffffffa00e8432>] drm_fb_helper_set_par+0x22/0x40 [drm_kms_helper]
 [<ffffffffa00e835a>] drm_fb_helper_hotplug_event+0xca/0x110 [drm_kms_helper]
 [<ffffffffa00e83ec>] drm_fb_helper_restore_fbdev_mode_unlocked+0x4c/0x70 [drm_kms_helper]
 [<ffffffffa00e8432>] drm_fb_helper_set_par+0x22/0x40 [drm_kms_helper]
 [<ffffffffa01855ea>] intel_fbdev_set_par+0x1a/0x60 [i915]
 [<ffffffff813392bb>] ? context_struct_compute_av+0x30b/0x3f0
 [<ffffffff81413986>] fb_set_var+0x236/0x460
 [<ffffffff813392bb>] ? context_struct_compute_av+0x30b/0x3f0
 [<ffffffff81200206>] ? kmem_cache_alloc+0x1d6/0x210
 [<ffffffff81323297>] ? avc_alloc_node+0x27/0x120
 [<ffffffff81409a72>] fbcon_blank+0x312/0x360
 [<ffffffff813293fb>] ? cred_has_capability+0x6b/0x100
 [<ffffffff8148e763>] do_unblank_screen+0xd3/0x1a0
 [<ffffffff81483d2a>] vt_ioctl+0x50a/0x12e0
 [<ffffffff81477333>] tty_ioctl+0x3c3/0xba0
 [<ffffffff811ffba0>] ? kfree+0x130/0x140
 [<ffffffff81231445>] do_vfs_ioctl+0x295/0x470
 [<ffffffff813294dd>] ? selinux_file_ioctl+0x4d/0xc0
 [<ffffffff81231699>] SyS_ioctl+0x79/0x90
 [<ffffffff817793ee>] entry_SYSCALL_64_fastpath+0x12/0x71
Comment 27 David Strauss 2015-12-02 01:45:18 EST
To be clear (and contrast my issue with other comments), I was not using a Wayland session when this occurred for me.
Comment 28 David Strauss 2016-01-04 19:25:32 EST
Just happened again on kernel 4.2.8.300.fc23.x86_64.
Comment 29 homann.philipp 2016-01-13 11:05:46 EST
Had this problem before last update to 4.3.3-300.fc23.x86_64.

Symptoms I had:
I have a Thinkpad X240 with 2 external screens attached (one using VGA and one using DP).
After waking monitors up (after standby eg after locking the screen) one of the monitors (normally the one connected using VGA) was not waking up automatically.
Workaround for me was to open gnome-settings => Display and changing disabling the defective montitor. Then pressing ESC to revert back to old settings and the the monitor was waking up.

Also the mentioned kernel message occured.

This is fixed now (didn't occur during the whole workday)
Comment 30 Mark 2016-03-12 10:20:17 EST
*** Bug 1317158 has been marked as a duplicate of this bug. ***
Comment 31 Adam Jackson 2016-03-17 12:11:39 EDT
Fixed in kernel 4.3 and later, according to the upstream report.
Comment 32 marc skinner 2016-03-29 10:46:49 EDT
eta on new F23 kernel with fix being released?
Comment 33 Josh Boyer 2016-03-29 12:31:31 EDT
(In reply to marc skinner from comment #32)
> eta on new F23 kernel with fix being released?

Um, the current F23 kernel should already contain any fixes if Adam's comment #31 is correct.  F23 is on 4.4.6.
Comment 34 marc skinner 2016-03-29 12:37:33 EDT
hmmm, well it just crashed on my this morning with the same error.

WARNING: CPU: 0 PID: 1939 at drivers/gpu/drm/i915/i915_gem.c:5269 i915_gem_track_fb+0x129/0x140 [i915]() [i915]

running kernel:4.4.6-300.fc23.x86_64

hardware: w541 with bios 2.26

i have abrt output if that is needed.
Comment 35 marc skinner 2016-03-29 16:30:22 EDT
never mind - i just looked at the date of my abrt log - the time of crash was Tue 22 Mar 2016 10:53:59 AM CDT

At that time I didn't have the kernel-4.4.6-300.fc23 installed.  I will repost if it happens again with the "fixed" kernel.

thanks.

Note You need to log in before you can comment on or make changes to this bug.