Bug 1254252 - Fields 'Customer Portal Username/Password' under Access Insights > Manage(Sat 6.1.1) should not be mandatory to use Insights service
Fields 'Customer Portal Username/Password' under Access Insights > Manage(Sat...
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: rubygem-foreman-redhat_access (Show other bugs)
Unspecified
x86_64 Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Lindani Phiri
Anisha Narang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-17 09:55 EDT by Anisha Narang
Modified: 2017-02-23 14:47 EST (History)
2 users (show)

See Also:
Fixed In Version: ruby193-rubygem-foreman-redhat_access-0.2.3-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-26 15:47:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
UI authentication error (46.17 KB, image/png)
2015-08-17 09:55 EDT, Anisha Narang
no flags Details
UI authentication error (62.54 KB, image/png)
2015-08-17 09:56 EDT, Anisha Narang
no flags Details

  None (edit)
Description Anisha Narang 2015-08-17 09:55:18 EDT
Created attachment 1063863 [details]
UI authentication error

Description of problem:
The Access insights Service is not available to the user in Satellite 6.1.1 until he mentions 'Customer Portal Username/passowrd under RHAI> Manage tab.

Version-Release number of selected component (if applicable):
ruby193-rubygem-foreman-redhat_access-0.2.2-1.el7sat.noarch

How reproducible:


Steps to Reproduce:
1. Setup a Satellite 6.1.1 instance.
2. Register a client machine to the Satelite instance using:
subscription-manager register --activationkey <ak> --org <org name>
3.redhat-access-insights --register


Actual results:
[root@abc ~]# redhat-access-insights --register
ERROR: Upload failed!
Debug Information:
HTTP Status Code: 502
HTTP Status Text: Bad Gateway

[root@abc ~]# redhat-access-insights --test-connection
Connection test config:
Proxy config: None
Certificate Verification: /etc/rhsm/ca/katello-server-ca.pem

Testing upload_url connection:
Testing: https://hp-dl320g6-01.rhts.eng.bos.redhat.com:443/redhat_access/r/insights/uploads/
HTTP Status Code: 502
HTTP Status Text: Bad Gateway
Connection failed
Testing: https://hp-dl320g6-01.rhts.eng.bos.redhat.com:443
HTTP Status Code: 500
HTTP Status Text: Internal Server Error
Connection failed
Testing: https://hp-dl320g6-01.rhts.eng.bos.redhat.com:443/r
HTTP Status Code: 404
HTTP Status Text: Not Found
Connection failed
Testing: https://hp-dl320g6-01.rhts.eng.bos.redhat.com:443/r/insights
HTTP Status Code: 404
HTTP Status Text: Not Found
Connection failed
upload_url test success

Testing api_url connection:
Testing: https://hp-dl320g6-01.rhts.eng.bos.redhat.com:443/redhat_access/r/insights/
HTTP Status Code: 401
HTTP Status Text: Unauthorized
Connection failed
Testing: https://hp-dl320g6-01.rhts.eng.bos.redhat.com:443
HTTP Status Code: 401
HTTP Status Text: Unauthorized
Connection failed
Testing: https://hp-dl320g6-01.rhts.eng.bos.redhat.com:443/r
HTTP Status Code: 404
HTTP Status Text: Not Found
Connection failed
Testing: https://hp-dl320g6-01.rhts.eng.bos.redhat.com:443/r/insights
HTTP Status Code: 404
HTTP Status Text: Not Found
Connection failed
api_url test success

Connectivity tests completed successfully

refer screenshots for the UI.

Expected results:
Registration should have been successful, no mandatory Portal username/password should be there.

Additional info:
Comment 1 Anisha Narang 2015-08-17 09:56:45 EDT
Created attachment 1063864 [details]
UI authentication error
Comment 3 Lindani Phiri 2015-08-17 10:06:04 EDT
A test config file was inadvertently included in the build.
To workaround this issue for these steps on satellite server:


(1) rm  /opt/rh/ruby193/root/usr/share/gems/gems/redhat_access-0.2.2/config/config.yml

(2) service httpd restart
Comment 6 Anisha Narang 2015-08-19 12:00:08 EDT
Verified on SNAP 17.
rpm version: ruby193-rubygem-foreman-redhat_access-0.2.3-1

The client system can register to the RHAI service without adding a Customer Portal Username/Password in the RHAI > Manage tab.
Comment 8 errata-xmlrpc 2015-08-26 15:47:09 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:1688

Note You need to log in before you can comment on or make changes to this bug.