Bug 1254262 - ipa-dnskeysync-replica crash cannot contact kdc
ipa-dnskeysync-replica crash cannot contact kdc
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa (Show other bugs)
7.2
Unspecified Unspecified
medium Severity unspecified
: rc
: ---
Assigned To: IPA Maintainers
Namita Soman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-17 10:06 EDT by Scott Poore
Modified: 2015-11-19 07:05 EST (History)
4 users (show)

See Also:
Fixed In Version: ipa-4.2.0-5.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 07:05:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Poore 2015-08-17 10:06:07 EDT
Description of problem:

time:           Sun 16 Aug 2015 10:36:09 PM EDT
cmdline:        /usr/bin/python2 /usr/libexec/ipa/ipa-dnskeysync-replica
uid:            992 (ods)
abrt_version:   2.1.11
dso_list:       ipa-python-4.2.0-4.el7.x86_64
event_log:      
executable:     /usr/libexec/ipa/ipa-dnskeysync-replica
hostname:       dell-pe800-01.spoore3.test
kernel:         3.10.0-304.el7.x86_64
last_occurrence: 1439778969
pid:            18724
pkg_arch:       x86_64
pkg_epoch:      0
pkg_name:       ipa-server
pkg_release:    4.el7
pkg_version:    4.2.0
runlevel:       N 3
username:       ods

backtrace:
:ipautil.py:1231:kinit_keytab:Krb5Error: (-1765328228, 'Cannot contact any KDC for requested realm')
:
:Traceback (most recent call last):
:  File "/usr/libexec/ipa/ipa-dnskeysync-replica", line 144, in <module>
:    ipautil.kinit_keytab(PRINCIPAL, paths.IPA_DNSKEYSYNCD_KEYTAB, ccache_filename)
:  File "/usr/lib/python2.7/site-packages/ipapython/ipautil.py", line 1231, in kinit_keytab
:    ccache.init_creds_keytab(keytab=ktab, principal=princ)
:Krb5Error: (-1765328228, 'Cannot contact any KDC for requested realm')
:
:Local variables in innermost frame:
:attempts: 1
:e: Krb5Error(-1765328228, 'Cannot contact any KDC for requested realm')
:config: None
:old_config: None
rinc: <krb5.Principal instance at 0x428c290: ipa-dnskeysyncd/dell-pe800-01.spoore3.test@SPOORE3.TEST>
:krbcontext: <krbV.Context instance at 0x5da6098>
:keytab: '/etc/ipa/dnssec/ipa-dnskeysyncd.keytab'
:ccache: <krbV.CCache instance at 0x428c3f8>
:ccache_name: '/tmp/ipa-dnskeysync-replica.ccache'
:attempt: 1
:errors_to_retry: set([-1765328228, -1765328355])
:ktab: <krbV.Keytab instance at 0x428cb00>
rincipal: 'ipa-dnskeysyncd/dell-pe800-01.spoore3.test'

environ:
:LANG=en_US.UTF-8
:SHELL=/sbin/nologin
:KRB5CCNAME=/tmp/ipa-dnskeysyncd.ccache
:LOGNAME=ods
:USER=ods
:SOFTHSM2_CONF=/etc/ipa/dnssec/softhsm2.conf
:HOME=//var/lib/softhsm
ATH=/bin:/sbin:/usr/kerberos/bin:/usr/kerberos/sbin:/usr/bin:/usr/sbin

machineid:
:systemd=5aa1af4015c6414b8e24c340c714face
:sosreport_uploader-dmidecode=7a582b64bcf1d6ce98c628748d4d7d7c720fb9731a08045d3b786aed9672d3ea

os_info:
:NAME="Red Hat Enterprise Linux Server"
:VERSION="7.2 (Maipo)"
:ID="rhel"
:ID_LIKE="fedora"
:VERSION_ID="7.2"
RETTY_NAME="Red Hat Enterprise Linux Server 7.2 Beta (Maipo)"
:ANSI_COLOR="0;31"
:CPE_NAME="cpe:/o:redhat:enterprise_linux:7.2:beta:server"
:HOME_URL="https://www.redhat.com/"
:BUG_REPORT_URL="https://bugzilla.redhat.com/"
:
:REDHAT_BUGZILLA_PRODUCT="Red Hat Enterprise Linux 7"
:REDHAT_BUGZILLA_PRODUCT_VERSION=7.2
:REDHAT_SUPPORT_PRODUCT="Red Hat Enterprise Linux"
:REDHAT_SUPPORT_PRODUCT_VERSION="7.2 Beta"


Version-Release number of selected component (if applicable):
ipa-server-4.2.0-4.el7.x86_64

How reproducible:
unknown

Steps to Reproduce:
1.  ipa-server-install
2.
3.

Actual results:
server install seems to work but, afterwards I see this crash


Expected results:
no crash

Additional info:
Comment 4 Petr Vobornik 2015-08-17 11:25:43 EDT
in the message log we can see that the service get restarted and works ok - not a severe issue. 

In any case, it should not traceback.
Comment 5 Petr Vobornik 2015-08-17 11:26:45 EDT
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/5229
Comment 8 Scott Poore 2015-09-02 15:37:07 EDT
Verified.

Version ::

4.2.0-5 thru 4.2.0-7

Results ::

We haven't seen this crash since the update.  Verifying Sanity only.
Comment 9 errata-xmlrpc 2015-11-19 07:05:34 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2362.html

Note You need to log in before you can comment on or make changes to this bug.