This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1254270 - Fatal error using dud for 7.2Alpha installation
Fatal error using dud for 7.2Alpha installation
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda (Show other bugs)
7.2
x86_64 Linux
urgent Severity urgent
: rc
: ---
Assigned To: Will Woods
Release Test Team
Petr Bokoc
: Regression
Depends On: 1260610 1260624
Blocks: 1104057 1133060 1186677 1246125 1252514
  Show dependency treegraph
 
Reported: 2015-08-17 10:38 EDT by Peter Pols
Modified: 2016-05-31 16:18 EDT (History)
9 users (show)

See Also:
Fixed In Version: anaconda-21.48.22.40-1
Doc Type: Known Issue
Doc Text:
Please update Doc Text for RHEL7.2 Beta release notes Cause: Consequence: Fix: Result:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 05:03:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fatal error screenshot (142.03 KB, image/png)
2015-08-17 10:41 EDT, Peter Pols
no flags Details
kmod-driver select screen (66.34 KB, image/png)
2015-08-17 10:42 EDT, Peter Pols
no flags Details
megasr 7.1 image (932.00 KB, application/octet-stream)
2015-08-18 03:30 EDT, Peter Pols
no flags Details
megasr 7.2 image (934.00 KB, application/octet-stream)
2015-08-18 03:30 EDT, Peter Pols
no flags Details

  None (edit)
Description Peter Pols 2015-08-17 10:38:08 EDT
Using a driver disk for a 7.2 alpha installation fails. The problem is seen with
different installation methods (pxe/net or remote storage).

How reproducible: always

Steps to Reproduce:
1. install 7.2 alpha
2. select a driver disk

Actual results:
A fatal error screen (see screenshot1) about a missing kmod-driver package appears.
The installation will be aborted, but the driver package is still present and usable (see screenshot2).

Expected results:
Driver disk should be loaded and installed

Additional info:
No additional information is available is collectable because no shell (F2) or F3 screen is working.
 
The driver package can be installed on an existing 7.2 system without problems.
Comment 1 Peter Pols 2015-08-17 10:41:28 EDT
Created attachment 1063908 [details]
Fatal error screenshot
Comment 2 Peter Pols 2015-08-17 10:42:36 EDT
Created attachment 1063909 [details]
kmod-driver select screen
Comment 4 Christian Horn 2015-08-17 11:19:48 EDT
Thanks for reporting this.
From the kmod package it seems like you have rebuild the driver for rhel7.2, I understand it can be loaded/used on an existing rhel7.2 installation.

- Can you upload the driver package?
- Also the one for 7.1 might be useful, so I can compare with a 7.1 deployment.
- When using pxeboot, you use format "dd=http://<ip>/driverdisk.img", right?
Comment 5 Peter Pols 2015-08-18 03:29:04 EDT
The pxeboot notation is inst.dd=http://<ip>/driverdisk.img.
Comment 6 Peter Pols 2015-08-18 03:30:09 EDT
Created attachment 1064182 [details]
megasr 7.1 image
Comment 7 Peter Pols 2015-08-18 03:30:45 EDT
Created attachment 1064183 [details]
megasr 7.2 image
Comment 8 Christian Horn 2015-08-18 04:48:56 EDT
Danke Peter.

I got the issue reproduced, and this looks indeed like an issue here preventing the DUD to work.

- For reproducing, I used KVM guests, deployed with virt-install
- I use kickstart, and the additionally inst.dd=http://<ip>/driverdisk.img
- After 7.1 deployment, kmod-megasr is installed, after 7.2 deployment not
- both DUD images follow the same directory structure
- the 7.2 RPM installs fine on an installed rhel7.2 alpha

I see this difference while installation, RHEL7.1, but not 7.2:
DD: Processing Network Drivers from /tmp/DD-net/
DD: Processing DD repo /media/DD//rpms/x86_64 on /tmp/DD-net/megasr-16.01.2014.0318.4fts-6.el7.1-000.x86_64.iso
DD: Extracting files from /media/DD//rpms/x86_64/kmod-megasr-16.01.2014.0318.4fts-6.el7.1.x86_64.rpm

This issue should be considered as blocker.
Comment 9 Christian Horn 2015-08-18 04:54:53 EDT
The issue is reported for RHEL-7.2-Alpha-1.1 with kernel-3.10.0-302.el7.x86_64, which was distributed to partners.  I have no access to later builds.
Comment 11 Martin Wilck 2015-08-31 08:37:55 EDT
"Doc Type: Bug Fix → Known Issue"

Does that mean there is not intention to fix this?? Please explain.
Comment 13 Will Woods 2015-08-31 14:26:09 EDT
We're trying to reproduce the problem(s) now.

Note that the original problem in comment #0 and the problem in comment #8 are two different failures in two different code paths, so we may need to split this bug in two in order to track those separately.
Comment 14 Brian Lane 2015-08-31 15:37:35 EDT
I can reproduce this in KVM when booting with the provided 7.2 DUD iso. There are multiple problems, here are fixes for 2 of them:

https://github.com/rhinstaller/anaconda/pull/337

In addition to those it extracts the drivers 3 times, into DD-1, DD-2 and DD-3.
Comment 16 Martin Wilck 2015-09-02 02:12:46 EDT
In which beta snap shot can we expect this to be fixed?
Comment 17 John Jarvis 2015-09-03 10:00:59 EDT
anaconda-21.48.22.41-1.el7 is included in Snapshot 1 so this fix is included in snap 1.
Comment 19 Peter Pols 2015-09-25 09:33:19 EDT
Retest with Snapshot2 (anaconda-21.48.22.47-1.el7) done.
Using a driver disk is working fine with this snapshot.
Comment 21 errata-xmlrpc 2015-11-19 05:03:20 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2284.html

Note You need to log in before you can comment on or make changes to this bug.