Bug 1254301 - Upgrading torque will clobber the files in /etc/rc.d/init.d
Summary: Upgrading torque will clobber the files in /etc/rc.d/init.d
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: torque
Version: el5
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: David Brown
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-08-17 16:27 UTC by Kevin L. Esteb
Modified: 2016-03-16 13:30 UTC (History)
4 users (show)

Fixed In Version: torque-4.2.10-9.fc22 torque-4.2.10-9.fc23 torque-4.2.10-9.el5 torque-4.2.10-9.el7 torque-4.2.10-9.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-02-22 20:49:19 UTC


Attachments (Terms of Use)

Description Kevin L. Esteb 2015-08-17 16:27:41 UTC
Description of problem:

Release 4.2.10-5 will clobber any changes made to the init scripts in /etc/rc.d/init.d. This is undesirable when changes are made to them so that you can actually override startup parameters from corresponding files in /etc/sysconfig.

Version-Release number of selected component (if applicable):

4.2.10-5

How reproducible:

Just upgrade from 4.2.10-3

Steps to Reproduce:

1. yum update torque

Actual results:

The files in /etc/rc.d/init.d/ are over written.

Expected results:

Any changes to the files in /etc/rc.d/init.d would be preserved.

Additional info:

Comment 1 David Brown 2015-12-07 00:18:10 UTC
Its been my opinion (and I believe the rest of Fedora/EPEL) that /etc/rc.d/init.d files should not be changed by system administrators. If the init scripts do not allow for some feature to be passed through to the torque daemons that should be added as options to be overridden by /etc/sysconfig files.

So, what changes did you make to the init.d files that you would like to see preserved in future releases?

Thanks,
- David Brown

Comment 2 Kevin L. Esteb 2015-12-07 16:33:01 UTC
Personally I believe that if the local administrator makes changes to the init scripts they should be honored. I believe that is the Debian policy, but then this is Redhat.

With that being said I added a PBS_ARGS to pbs_sched and pbs_mom so that I can define additional arguments on the command line. I also added a PBS_PORT to pbs_mom so I can define the port for momctl to communicate on.

With those additions, I can then use the /etc/sysconfig files to set those variables. 

I don't use the default ports for torque. In 2.4, I could change /etc/service and it would be picked up. With 4.2, this doesn't seem to happen any more. 

Here is the sed script that I use in my configuration rpm for torque.

#
# fix some init.d files
#
if ! grep PBS_ARGS /etc/init.d/pbs_mom > /dev/nul ; then
    sed -i '/^PBS_HOME/a PBS_ARGS=""' /etc/init.d/pbs_mom
    sed -i '/^PBS_ARGS/a PBS_PORT=""' /etc/init.d/pbs_mom
    sed -i 's/momctl -s/momctl -s $PBS_PORT/g' /etc/init.d/pbs_mom
    sed -i 's/\$PBS_DAEMON \$args/$PBS_DAEMON $PBS_ARGS $args/g' /etc/init.d/pbs_mom
fi
#
if ! grep PBS_ARGS /etc/init.d/pbs_sched > /dev/null ; then
    sed -i '/^PBS_HOME/a PBS_ARGS=""' /etc/init.d/pbs_sched
    sed -i 's/daemon \$PBS_DAEMON/daemon $PBS_DAEMON $PBS_ARGS/g' /etc/init.d/pbs_sched
fi
#
#

Comment 3 David Brown 2015-12-08 01:04:14 UTC
https://fedoraproject.org/wiki/EPEL:SysVInitScript

For future reference. There looks like there's ways of setting args in the pbs_mom and pbs_sched files.

args="-L /tmp/mylog.log"

would go into into /etc/sysconfig/pbs_mom and it should get passed to the mom.

However, if you specify a port as part of those arguments it wouldn't get passed to the momctl and the init script would fail...

Let me take a look and do some testing.

Comment 4 Fedora Update System 2016-02-21 08:08:44 UTC
torque-4.2.10-9.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-4465cb2604

Comment 5 Fedora Update System 2016-02-21 08:09:08 UTC
torque-4.2.10-9.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-a99d29fa05

Comment 6 Fedora Update System 2016-02-21 08:09:34 UTC
torque-4.2.10-9.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-80daa121a4

Comment 7 Fedora Update System 2016-02-21 08:10:01 UTC
torque-4.2.10-9.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-652d4f3054

Comment 8 Fedora Update System 2016-02-21 08:10:28 UTC
torque-4.2.10-9.el5 has been submitted as an update to Fedora EPEL 5. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-f2f3898eca

Comment 9 Fedora Update System 2016-02-22 03:48:25 UTC
torque-4.2.10-9.el5 has been pushed to the Fedora EPEL 5 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-f2f3898eca

Comment 10 Fedora Update System 2016-02-22 03:48:35 UTC
torque-4.2.10-9.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-652d4f3054

Comment 11 Fedora Update System 2016-02-22 04:20:19 UTC
torque-4.2.10-9.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-a99d29fa05

Comment 12 Fedora Update System 2016-02-22 04:21:45 UTC
torque-4.2.10-9.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-4465cb2604

Comment 13 Fedora Update System 2016-02-22 04:51:00 UTC
torque-4.2.10-9.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-80daa121a4

Comment 14 Fedora Update System 2016-02-22 20:49:12 UTC
torque-4.2.10-9.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2016-02-23 01:22:49 UTC
torque-4.2.10-9.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2016-03-15 22:01:37 UTC
torque-4.2.10-9.el5 has been pushed to the Fedora EPEL 5 stable repository. If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2016-03-15 22:47:46 UTC
torque-4.2.10-9.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2016-03-16 13:30:39 UTC
torque-4.2.10-9.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.