Bug 1254303 - linux_admin dependency is too wide open causing failure in internal database configuration
linux_admin dependency is too wide open causing failure in internal database ...
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Appliance (Show other bugs)
5.4.0
Unspecified Unspecified
unspecified Severity unspecified
: GA
: 5.4.2
Assigned To: Nick Carboni
Dave Johnson
: ZStream
Depends On: 1254302
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-17 12:31 EDT by Chris Pelland
Modified: 2015-09-09 09:09 EDT (History)
10 users (show)

See Also:
Fixed In Version: 5.4.2.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1254302
Environment:
Last Closed: 2015-09-09 08:26:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Pelland 2015-08-17 12:31:21 EDT
+++ This bug was initially created as a clone of Bug #1254302 +++

Description of problem:

linux_admin dependency is too wide open causing failure in specs.  In particular, when setting the internal database configuration in the appliance, it blows up with

  1) ApplianceConsole::InternalDatabaseConfiguration postgresql service #start_postgres (private)
     Failure/Error: Unable to find matching line from backtrace
       Exactly one instance should have received the following message(s) but didn't: start

because LinuxAdmin::Service was slightly changed.  This may only affect tests, but we cannot release with failing specs.
Comment 1 CFME Bot 2015-08-17 22:26:27 EDT
New commit detected on cfme/5.4.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=a9325b67ded5a2201a07565e1a9626570d6cbc07

commit a9325b67ded5a2201a07565e1a9626570d6cbc07
Author:     Nick Carboni <ncarboni@redhat.com>
AuthorDate: Mon Aug 17 13:39:45 2015 -0400
Commit:     Nick Carboni <ncarboni@redhat.com>
CommitDate: Mon Aug 17 13:39:45 2015 -0400

    Fixed the version restriction for linux_admin
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1254302
    https://bugzilla.redhat.com/show_bug.cgi?id=1254303

 lib/Gemfile | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Comment 2 CFME Bot 2015-08-17 22:26:33 EDT
New commit detected on cfme/5.4.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=5ae8c86d077414cdada99b7536abe986d1a9c9f3

commit 5ae8c86d077414cdada99b7536abe986d1a9c9f3
Merge: 755e381 a9325b6
Author:     Jason Frey <jfrey@redhat.com>
AuthorDate: Mon Aug 17 18:08:43 2015 -0400
Commit:     Jason Frey <jfrey@redhat.com>
CommitDate: Mon Aug 17 18:08:43 2015 -0400

    Merge branch 'fix_linux_admin_version' into '5.4.z'
    
    Fixed the version restriction for linux_admin
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1254302
    https://bugzilla.redhat.com/show_bug.cgi?id=1254303
    
    See merge request !227

 lib/Gemfile | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Comment 5 errata-xmlrpc 2015-09-09 08:26:48 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1744.html

Note You need to log in before you can comment on or make changes to this bug.