Bug 1254309 - Mock dependency install all mirrors failed
Mock dependency install all mirrors failed
Status: CLOSED WONTFIX
Product: Copr
Classification: Community
Component: backend (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Suchý
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-17 12:38 EDT by Viktor Jancik
Modified: 2016-04-11 10:39 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-11 10:39:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Viktor Jancik 2015-08-17 12:38:22 EDT
Description of problem:
Tried to build a package and the process failed on rawhide.i386 because it couldn't download the packages.

My guess is this wasn't caused by a temporary blackout of the service, because other builds passed at the same time.

Here is the log:
https://copr-be.cloud.fedoraproject.org/results/vjancik/opencv3-deps/fedora-rawhide-i386/00109464-libkface/root.log

Here are all of the builds:
https://copr.fedoraproject.org/coprs/vjancik/opencv3-deps/build/109464/
Comment 1 Viktor Jancik 2015-08-17 12:52:34 EDT
I guess I should add that the subsequent build with the same SRPM passed without problems:
https://copr.fedoraproject.org/coprs/vjancik/opencv3-deps/build/109467/

Although the build on the aforementioned chroot took almost twice as long.

Maybe you could implement an automated retry? If the build failed because of "no mirrors left". If it's something that "just happens" sometimes.
Comment 2 Miroslav Suchý 2015-08-18 04:43:22 EDT
If build fails, we already are trying once again.
Comment 3 Jakub Kadlčík 2015-09-10 08:17:19 EDT
It also happens to me sometimes. Every time for different chroot. The current workaround for me is just hitting the "resubmit" button.

Anyway, there is an interesting (I think) traceback in mockchain.log


ERROR: Command failed. See logs for output.
 # /usr/bin/yum --installroot /var/lib/mock/fedora-rawhide-i386-mockbuilder-7005/root/ --releasever 23 install @buildsys-build --setopt=tsflags=nocontexts
Traceback (most recent call last):
  File "/usr/share/copr/backend/mockremote/__init__.py", line 303, in build_pkg_and_process_results
    build_stdout = self.builder.build()
  File "/usr/share/copr/backend/mockremote/builder.py", line 324, in build
    check_for_ans_error(ansible_build_results, self.hostname)  # on error raises AnsibleResponseError
  File "/usr/share/copr/backend/mockremote/builder.py", line 449, in check_for_ans_error
    raise AnsibleResponseError(**err_results)
AnsibleResponseError: BuildError: rc 2 not in success_codes; return code: 2; stdout: starting logfile: None
Comment 5 Miroslav Suchý 2016-04-11 10:39:48 EDT
Likely just network issue.

Note You need to log in before you can comment on or make changes to this bug.