Bug 1254332 - Unreliable cpu detection through glibtop
Unreliable cpu detection through glibtop
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-system-monitor (Show other bugs)
7.2
All Linux
unspecified Severity low
: rc
: ---
Assigned To: David King
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-17 14:09 EDT by Helio Chissini de Castro
Modified: 2015-11-19 02:34 EST (History)
4 users (show)

See Also:
Fixed In Version: gnome-system-monitor-3.14.1-3.el7
Doc Type: Bug Fix
Doc Text:
Cause: a CPU core is completely idle, which is considerably more likely to occur with many CPUs. Consequence: gnome-system-monitor reports an incorrect number of CPUs; it stops counting when it encounters one with zero load Fix: a patch was added to query the number of CPUs from the system directly Result: the correct number of CPUs are detected, regardless of CPU load on a particular CPU
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 02:34:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 753731 None None None Never

  None (edit)
Description Helio Chissini de Castro 2015-08-17 14:09:13 EDT
glibtop not provides the number of cpus on the machine directly, relying on a list with the current load of each core.

Original code assume that a 0 load core is the end of cpu list, which is invalid in cases of machines with high number of cores, that happens to some cores stay idle with 0 load.

Since this can happens in any core number, if a machine has 192 cores, but the core number 5 has 0 load, then 4 cores will be wrongly reported.

Using standard sysconf api solves the issue in a simple way.

Reference:
https://bugzilla.gnome.org/show_bug.cgi?id=753731
Comment 8 errata-xmlrpc 2015-11-19 02:34:13 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2215.html

Note You need to log in before you can comment on or make changes to this bug.