Bug 1254436 - logging: Revert usage of global xlator for log buffer
logging: Revert usage of global xlator for log buffer
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: logging (Show other bugs)
3.7.3
All All
unspecified Severity high
: ---
: ---
Assigned To: Soumya Koduri
: Triaged
Depends On: 1243806
Blocks: 1241761
  Show dependency treegraph
 
Reported: 2015-08-18 03:13 EDT by Soumya Koduri
Modified: 2015-09-09 05:39 EDT (History)
6 users (show)

See Also:
Fixed In Version: glusterfs-3.7.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1243806
Environment:
Last Closed: 2015-09-09 05:39:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Soumya Koduri 2015-08-18 03:13:54 EDT
+++ This bug was initially created as a clone of Bug #1243806 +++

Description of problem:
With http://review.gluster.org/#/c/10319/, global_xlator is used for allocations needed for logging so that we don't try to free objects belonging to an already-deleted translator (which will crash). The same global xlator needs to be referred while trying to free those allocations as well.

--- Additional comment from Anand Avati on 2015-07-16 07:48:56 EDT ---

REVIEW: http://review.gluster.org/11696 (logging: Use global xlator to free log buffer) posted (#1) for review on master by soumya k (skoduri@redhat.com)

--- Additional comment from Anand Avati on 2015-08-05 23:31:21 EDT ---

REVIEW: http://review.gluster.org/11811 (Revert "core: avoid crashes in gf_msg dup-detection code") posted (#3) for review on master by soumya k (skoduri@redhat.com)

--- Additional comment from Soumya Koduri on 2015-08-05 23:37:17 EDT ---

Instead, since with http://review.gluster.org/#/c/10417/, struct mem_accnt is no longer embedded in a xlator_t object, but allocated separately, we have decided to revert the workaround provided to avoid crashes in logging infrastructure.

--- Additional comment from Anand Avati on 2015-08-06 04:50:36 EDT ---

REVIEW: http://review.gluster.org/11811 (logging: Stop using global xlator for log_buf allocations) posted (#4) for review on master by soumya k (skoduri@redhat.com)

--- Additional comment from Anand Avati on 2015-08-08 06:51:28 EDT ---

COMMIT: http://review.gluster.org/11811 committed in master by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit 3e05e2c69979119ca63b1ae5b775019d8bd27d31
Author: Soumya Koduri <skoduri@redhat.com>
Date:   Thu Jul 30 17:03:50 2015 +0530

    logging: Stop using global xlator for log_buf allocations
    
    This reverts commit 765849ee00f6661c9059122ff2346b03b224745f.
    
    With http://review.gluster.org/#/c/10417/, struct mem_accnt
    is no longer embedded in a xlator_t object, but instead is
    allocated separately. Hence this workaround provided to avoid
    crashes in logging infrastructure is no longer needed
    
    BUG: 1243806
    Change-Id: I1bc006172ebe5e417a5923f8be2f37a6277c5e5d
    Signed-off-by: Soumya Koduri <skoduri@redhat.com>
    Reviewed-on: http://review.gluster.org/11811
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: N Balachandran <nbalacha@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
Comment 1 Anand Avati 2015-08-18 03:18:50 EDT
REVIEW: http://review.gluster.org/11946 (logging: Stop using global xlator for log_buf allocations) posted (#1) for review on release-3.7 by soumya k (skoduri@redhat.com)
Comment 2 Anand Avati 2015-08-18 13:07:23 EDT
COMMIT: http://review.gluster.org/11946 committed in release-3.7 by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit eeb05e207dc6a0354ca2489f4b8e07f1800c8eb8
Author: Soumya Koduri <skoduri@redhat.com>
Date:   Thu Jul 30 17:03:50 2015 +0530

    logging: Stop using global xlator for log_buf allocations
    
    This reverts commit 765849ee00f6661c9059122ff2346b03b224745f.
    
    With http://review.gluster.org/#/c/10417/, struct mem_accnt
    is no longer embedded in a xlator_t object, but instead is
    allocated separately. Hence this workaround provided to avoid
    crashes in logging infrastructure is no longer needed
    
    This is a backport of the below fix -
    http://review.gluster.org/11811
    
    BUG: 1254436
    Change-Id: I4bbf7649bdc29424ff1bb878f79e99328efa0b3e
    Signed-off-by: Soumya Koduri <skoduri@redhat.com>
    Reviewed-on: http://review.gluster.org/11811
    Reviewed-by: N Balachandran <nbalacha@redhat.com>
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    Reviewed-on: http://review.gluster.org/11946
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
Comment 3 Kaushal 2015-09-09 05:39:52 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.4, please open a new bug report.

glusterfs-3.7.4 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/12496
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.