Bug 1254442 - tiering/snapshot: Tier daemon failed to start during volume start after restoring into a tiered volume from a non-tiered volume.
tiering/snapshot: Tier daemon failed to start during volume start after resto...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
3.7.3
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: bugs@gluster.org
bugs@gluster.org
: Triaged
Depends On: 1238593
Blocks: 1260923
  Show dependency treegraph
 
Reported: 2015-08-18 03:21 EDT by Mohammed Rafi KC
Modified: 2015-10-30 13:32 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.7.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1238593
Environment:
Last Closed: 2015-09-09 05:39:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mohammed Rafi KC 2015-08-18 03:21:55 EDT
+++ This bug was initially created as a clone of Bug #1238593 +++

Description of problem:

 Tier daemon failed to start during volume start after restoring into a tiered volume from a non-tiered volume.

Version-Release number of selected component (if applicable):


How reproducible:

100%.

Steps to Reproduce:
1.create a tiered volume
2.take snapshot of the tiered volume
3.detach-tier
4.stop the volume
5.restore the snapshot
6.start the volume
7.chek #gluster v rebalance volname tier status

Actual results:

tier daemon is not running

Expected results:

tier daemon should along with volume start

Additional info:

--- Additional comment from Anand Avati on 2015-07-03 08:01:57 EDT ---

REVIEW: http://review.gluster.org/11525 (tiering/glusterd: start tier daemon during volume start) posted (#1) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

--- Additional comment from Anand Avati on 2015-07-06 03:03:07 EDT ---

REVIEW: http://review.gluster.org/11525 (tiering/glusterd: start tier daemon during volume start) posted (#2) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

--- Additional comment from Anand Avati on 2015-07-07 03:06:44 EDT ---

REVIEW: http://review.gluster.org/11525 (tiering/glusterd: start tier daemon during volume start) posted (#3) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

--- Additional comment from Anand Avati on 2015-07-20 12:27:35 EDT ---

REVIEW: http://review.gluster.org/11525 (tiering/glusterd: start tier daemon during volume start) posted (#4) for review on master by Dan Lambright (dlambrig@redhat.com)

--- Additional comment from Anand Avati on 2015-08-04 10:47:22 EDT ---

REVIEW: http://review.gluster.org/11525 (tiering/glusterd: start tier daemon during volume start) posted (#5) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

--- Additional comment from Anand Avati on 2015-08-06 02:39:54 EDT ---

REVIEW: http://review.gluster.org/11525 (tiering/glusterd: start tier daemon during volume start) posted (#6) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

--- Additional comment from Anand Avati on 2015-08-06 17:38:15 EDT ---

REVIEW: http://review.gluster.org/11525 (tiering/glusterd: start tier daemon during volume start) posted (#7) for review on master by Dan Lambright (dlambrig@redhat.com)
Comment 1 Anand Avati 2015-08-18 06:52:41 EDT
REVIEW: http://review.gluster.org/11952 (tiering/glusterd: start tier daemon during volume start) posted (#1) for review on release-3.7 by mohammed rafi  kc (rkavunga@redhat.com)
Comment 2 Anand Avati 2015-08-19 04:47:38 EDT
COMMIT: http://review.gluster.org/11952 committed in release-3.7 by Dan Lambright (dlambrig@redhat.com) 
------
commit 4fa5f8ccdcfeac20dbee8a0bc4753e5ca607a4d1
Author: Mohammed Rafi KC <rkavunga@redhat.com>
Date:   Fri Jul 3 15:27:15 2015 +0530

    tiering/glusterd: start tier daemon during volume start
    
    Tier daemon should always run with tier volume. If volume
    is stopped and started again, we manually need to start
    the tier-daemon, instead this patch will automatically trigger
    tier process along with volume start.
    
    A snapshot restored volume will not have node_state_info,
    so we need to create and store it dynamically
    
    Back port of:
    >Change-Id: I659387c914bec7a1b6929ee5cb61f7b406402075
    >BUG: 1238593
    >Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    >Signed-off-by: Dan Lambright <dlambrig@redhat.com>
    >Reviewed-on: http://review.gluster.org/11525
    >Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    >Tested-by: Gluster Build System <jenkins@build.gluster.com>
    >Reviewed-by: Krishnan Parthasarathi <kparthas@redhat.com>
    
    Change-Id: I5766a0712a5695423b42a28a0f2e7435f4dd2628
    BUG: 1254442
    Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    Reviewed-on: http://review.gluster.org/11952
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    Tested-by: Dan Lambright <dlambrig@redhat.com>
Comment 3 Kaushal 2015-09-09 05:39:53 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.4, please open a new bug report.

glusterfs-3.7.4 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/12496
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.