Bug 1254452 - guvnor-mgmt-projects first time startup error in BPMSuite
guvnor-mgmt-projects first time startup error in BPMSuite
Status: CLOSED DUPLICATE of bug 1263738
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.2.0
Unspecified Unspecified
high Severity high
: ER5
: 6.2.0
Assigned To: Mauricio Salatino
Jiri Locker
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-18 03:51 EDT by Ryan Zhang
Modified: 2015-11-10 08:34 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-10 08:34:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
server.log (965.55 KB, text/plain)
2015-08-18 03:52 EDT, Ryan Zhang
no flags Details

  None (edit)
Description Ryan Zhang 2015-08-18 03:51:46 EDT
Description of problem:
I spot this error will occure when you start up the bpms server if you have a clean local repository .
It seems to me that the deployment of guvnor-mgmt-projects are depending on the cache in local repository (eg, ~/.m2/repository/org/guvnor/guvnor-mgmt-project in my case)
After I clean the local cache and restart the server, this error will appear.

15:47:36,470 WARN  [org.kie.scanner.embedder.MavenSettings] (MSC service thread 1-2) Environment variable M2_HOME is not set
15:47:36,470 INFO  [org.uberfire.ext.metadata.io.BatchIndex] (Thread-90) Completed indexing of default://master@datasets/
15:47:36,575 ERROR [org.guvnor.m2repo.backend.server.GuvnorM2Repository] (MSC service thread 1-2) Could not find artifact org.guvnor:guvnor-asset-mgmt-project:jar:6.3.0.CR1-redhat-1 in guvnor-m2-repo (file:/home/rzhang/lab/1brms6/6.2.0/bpmsuite-6.2.0.ER1/smoketest/jboss-eap-6.4/bin/repositories/kie/): org.eclipse.aether.resolution.ArtifactResolutionException: Could not find artifact org.guvnor:guvnor-asset-mgmt-project:jar:6.3.0.CR1-redhat-1 in guvnor-m2-repo (file:/home/rzhang/lab/1brms6/6.2.0/bpmsuite-6.2.0.ER1/smoketest/jboss-eap-6.4/bin/repositories/kie/)
	at org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:444) [aether-impl-1.0.0.v20140518.jar:]
	at org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolveArtifacts(DefaultArtifactResolver.java:246) [aether-impl-1.0.0.v20140518.jar:]
	at org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolveArtifact(DefaultArtifactResolver.java:223) [aether-impl-1.0.0.v20140518.jar:]
	at org.eclipse.aether.internal.impl.DefaultRepositorySystem.resolveArtifact(DefaultRepositorySystem.java:294) [aether-impl-1.0.0.v20140518.jar:]
	at org.guvnor.m2repo.backend.server.GuvnorM2Repository.getArtifactFileFromRepository(GuvnorM2Repository.java:976) [guvnor-m2repo-editor-backend-6.3.0.CR1-redhat-1.jar:6.3.0.CR1-redhat-1]
	at org.guvnor.m2repo.backend.server.GuvnorM2Repository$Proxy$_$$_WeldClientProxy.getArtifactFileFromRepository(GuvnorM2Repository$Proxy$_$$_WeldClientProxy.java) [guvnor-m2repo-editor-backend-6.3.0.CR1-redhat-1.jar:6.3.0.CR1-redhat-1]
	at org.jbpm.console.ng.asset.backend.server.AssetMgmtDeploymentUnitProvider.deployToLocalMavenIfNeeded(AssetMgmtDeploymentUnitProvider.java:119) [jbpm-console-ng-asset-mgmt-backend-6.3.0.CR1-redhat-1.jar:6.3.0.CR1-redhat-1]
	at org.jbpm.console.ng.asset.backend.server.AssetMgmtDeploymentUnitProvider.getDeploymentUnits(AssetMgmtDeploymentUnitProvider.java:68) [jbpm-console-ng-asset-mgmt-backend-6.3.0.CR1-redhat-1.jar:6.3.0.CR1-redhat-1]
	at org.jbpm.console.ng.asset.backend.server.AssetMgmtDeploymentUnitProvider$Proxy$_$$_WeldClientProxy.getDeploymentUnits(AssetMgmtDeploymentUnitProvider$Proxy$_$$_WeldClientProxy.java) [jbpm-console-ng-asset-mgmt-backend-6.3.0.CR1-redhat-1.jar:6.3.0.CR1-redhat-1]
	at org.jbpm.console.ng.bd.backend.server.AdministrationServiceImpl.produceDeploymentUnits(AdministrationServiceImpl.java:223) [jbpm-console-ng-business-domain-backend-6.3.0.CR1-redhat-1.jar:6.3.0.CR1-redhat-1]
	at org.jbpm.console.ng.bd.backend.server.AdministrationServiceImpl.bootstrapDeployments(AdministrationServiceImpl.java:199) [jbpm-console-ng-business-domain-backend-6.3.0.CR1-redhat-1.jar:6.3.0.CR1-redhat-1]
	at org.jbpm.console.ng.bd.backend.server.AdministrationServiceImpl$Proxy$_$$_WeldClientProxy.bootstrapDeployments(AdministrationServiceImpl$Proxy$_$$_WeldClientProxy.java) [jbpm-console-ng-business-domain-backend-6.3.0.CR1-redhat-1.jar:6.3.0.CR1-redhat-1]
	at org.kie.workbench.backend.AppSetup.assertPlayground(AppSetup.java:179) [classes:]
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) [rt.jar:1.8.0_45]
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) [rt.jar:1.8.0_45]
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) [rt.jar:1.8.0_45]
	at java.lang.reflect.Method.invoke(Method.java:497) [rt.jar:1.8.0_45]
	at org.jboss.weld.util.reflection.SecureReflections$13.work(SecureReflections.java:267) [weld-core-1.1.28.Final-redhat-1.jar:1.1.28.Final-redhat-1]
	at org.jboss.weld.util.reflection.SecureReflectionAccess.run(SecureReflectionAccess.java:52) [weld-core-1.1.28.Final-redhat-1.jar:1.1.28.Final-redhat-1]
	at org.jboss.weld.util.reflection.SecureReflectionAccess.runAsInvocation(SecureReflectionAccess.java:137) [weld-core-1.1.28.Final-redhat-1.jar:1.1.28.Final-redhat-1]
	at org.jboss.weld.util.reflection.SecureReflections.invoke(SecureReflections.java:263) [weld-core-1.1.28.Final-redhat-1.jar:1.1.28.Final-redhat-1]
	at org.jboss.weld.introspector.jlr.WeldMethodImpl.invoke(WeldMethodImpl.java:168) [weld-core-1.1.28.Final-redhat-1.jar:1.1.28.Final-redhat-1]
	at org.jboss.weld.bean.AbstractClassBean.defaultPostConstruct(AbstractClassBean.java:403) [weld-core-1.1.28.Final-redhat-1.jar:1.1.28.Final-redhat-1]
	at org.jboss.weld.bean.ManagedBean$ManagedBeanInjectionTarget.postConstruct(ManagedBean.java:178) [weld-core-1.1.28.Final-redhat-1.jar:1.1.28.Final-redhat-1]
	at org.jboss.weld.bean.ManagedBean.create(ManagedBean.java:298) [weld-core-1.1.28.Final-redhat-1.jar:1.1.28.Final-redhat-1]
	at org.jboss.weld.context.AbstractContext.get(AbstractContext.java:103) [weld-core-1.1.28.Final-redhat-1.jar:1.1.28.Final-redhat-1]
	at org.jboss.weld.bean.proxy.ContextBeanInstance.getInstance(ContextBeanInstance.java:90) [weld-core-1.1.28.Final-redhat-1.jar:1.1.28.Final-redhat-1]
	at org.jboss.weld.bean.proxy.ProxyMethodHandler.invoke(ProxyMethodHandler.java:79) [weld-core-1.1.28.Final-redhat-1.jar:1.1.28.Final-redhat-1]
	at org.kie.workbench.backend.AppSetup$Proxy$_$$_WeldClientProxy.toString(AppSetup$Proxy$_$$_WeldClientProxy.java) [classes:]
	at org.uberfire.backend.server.cdi.SystemConfigProducer.runPostConstruct(SystemConfigProducer.java:143) [uberfire-backend-cdi-0.7.0.CR2-redhat-1.jar:0.7.0.CR2-redhat-1]
	at org.uberfire.backend.server.cdi.SystemConfigProducer.afterDeploymentValidation(SystemConfigProducer.java:126) [uberfire-backend-cdi-0.7.0.CR2-redhat-1.jar:0.7.0.CR2-redhat-1]
	at org.uberfire.backend.server.cdi.SystemConfigProducer$Proxy$_$$_WeldClientProxy.afterDeploymentValidation(SystemConfigProducer$Proxy$_$$_WeldClientProxy.java) [uberfire-backend-cdi-0.7.0.CR2-redhat-1.jar:0.7.0.CR2-redhat-1]
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) [rt.jar:1.8.0_45]
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) [rt.jar:1.8.0_45]
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) [rt.jar:1.8.0_45]
	at java.lang.reflect.Method.invoke(Method.java:497) [rt.jar:1.8.0_45]
	at org.jboss.weld.util.reflection.SecureReflections$13.work(SecureReflections.java:267) [weld-core-1.1.28.Final-redhat-1.jar:1.1.28.Final-redhat-1]
	at org.jboss.weld.util.reflection.SecureReflectionAccess.run(SecureReflectionAccess.java:52) [weld-core-1.1.28.Final-redhat-1.jar:1.1.28.Final-redhat-1]
	at org.jboss.weld.util.reflection.SecureReflectionAccess.runAsInvocation(SecureReflectionAccess.java:137) [weld-core-1.1.28.Final-redhat-1.jar:1.1.28.Final-redhat-1]
	at org.jboss.weld.util.reflection.SecureReflections.invoke(SecureReflections.java:263) [weld-core-1.1.28.Final-redhat-1.jar:1.1.28.Final-redhat-1]
	at org.jboss.weld.introspector.jlr.WeldMethodImpl.invokeOnInstance(WeldMethodImpl.java:164) [weld-core-1.1.28.Final-redhat-1.jar:1.1.28.Final-redhat-1]
	at org.jboss.weld.introspector.ForwardingWeldMethod.invokeOnInstance(ForwardingWeldMethod.java:51) [weld-core-1.1.28.Final-redhat-1.jar:1.1.28.Final-redhat-1]
	at org.jboss.weld.injection.MethodInjectionPoint.invokeOnInstanceWithSpecialValue(MethodInjectionPoint.java:154) [weld-core-1.1.28.Final-redhat-1.jar:1.1.28.Final-redhat-1]
	at org.jboss.weld.event.ObserverMethodImpl.sendEvent(ObserverMethodImpl.java:245) [weld-core-1.1.28.Final-redhat-1.jar:1.1.28.Final-redhat-1]
	at org.jboss.weld.event.ObserverMethodImpl.sendEvent(ObserverMethodImpl.java:233) [weld-core-1.1.28.Final-redhat-1.jar:1.1.28.Final-redhat-1]
	at org.jboss.weld.event.ObserverMethodImpl.notify(ObserverMethodImpl.java:213) [weld-core-1.1.28.Final-redhat-1.jar:1.1.28.Final-redhat-1]
	at org.jboss.weld.bootstrap.events.AbstractContainerEvent.fire(AbstractContainerEvent.java:75) [weld-core-1.1.28.Final-redhat-1.jar:1.1.28.Final-redhat-1]
	at org.jboss.weld.bootstrap.events.AbstractDeploymentContainerEvent.fire(AbstractDeploymentContainerEvent.java:46) [weld-core-1.1.28.Final-redhat-1.jar:1.1.28.Final-redhat-1]
	at org.jboss.weld.bootstrap.events.AfterDeploymentValidationImpl.fire(AfterDeploymentValidationImpl.java:31) [weld-core-1.1.28.Final-redhat-1.jar:1.1.28.Final-redhat-1]
	at org.jboss.weld.bootstrap.WeldBootstrap.validateBeans(WeldBootstrap.java:382) [weld-core-1.1.28.Final-redhat-1.jar:1.1.28.Final-redhat-1]
	at org.jboss.as.weld.WeldStartService.start(WeldStartService.java:64) [jboss-as-weld-7.5.0.Final-redhat-21.jar:7.5.0.Final-redhat-21]
	at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1980)
	at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1913)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142) [rt.jar:1.8.0_45]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617) [rt.jar:1.8.0_45]
	at java.lang.Thread.run(Thread.java:745) [rt.jar:1.8.0_45]
Caused by: org.eclipse.aether.transfer.ArtifactNotFoundException: Could not find artifact org.guvnor:guvnor-asset-mgmt-project:jar:6.3.0.CR1-redhat-1 in guvnor-m2-repo (file:/home/rzhang/lab/1brms6/6.2.0/bpmsuite-6.2.0.ER1/smoketest/jboss-eap-6.4/bin/repositories/kie/)
	at org.eclipse.aether.connector.basic.ArtifactTransportListener.transferFailed(ArtifactTransportListener.java:39) [aether-connector-basic-1.0.0.v20140518.jar:]
	at org.eclipse.aether.connector.basic.BasicRepositoryConnector$TaskRunner.run(BasicRepositoryConnector.java:355) [aether-connector-basic-1.0.0.v20140518.jar:]
	at org.eclipse.aether.util.concurrency.RunnableErrorForwarder$1.run(RunnableErrorForwarder.java:67) [aether-util-1.0.0.v20140518.jar:]
	at org.eclipse.aether.connector.basic.BasicRepositoryConnector$DirectExecutor.execute(BasicRepositoryConnector.java:581) [aether-connector-basic-1.0.0.v20140518.jar:]
	at org.eclipse.aether.connector.basic.BasicRepositoryConnector.get(BasicRepositoryConnector.java:249) [aether-connector-basic-1.0.0.v20140518.jar:]
	at org.eclipse.aether.internal.impl.DefaultArtifactResolver.performDownloads(DefaultArtifactResolver.java:520) [aether-impl-1.0.0.v20140518.jar:]
	at org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:421) [aether-impl-1.0.0.v20140518.jar:]
	... 55 more

15:47:36,603 INFO  [org.jbpm.console.ng.asset.backend.server.AssetMgmtDeploymentUnitProvider] (MSC service thread 1-2) Found guvnor asset management deployment unit org.guvnor:guvnor-asset-mgmt-project:6.3.0.CR1-redhat-1 [strategy=SINGLETON] attempting to deploy it
15:47:36,647 ERROR [stderr] (MSC service thread 1-2) ScriptEngineManager providers.next(): javax.script.ScriptEngineFactory: Provider com.sun.script.javascript.RhinoScriptEngineFactory not found


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Ryan Zhang 2015-08-18 03:52:57 EDT
Created attachment 1064196 [details]
server.log
Comment 2 Ryan Zhang 2015-08-18 03:54:22 EDT
This can be reproduced in 6.2.0 DR1, ER1.
Comment 5 manstis 2015-10-23 07:54:16 EDT
See referenced BZ. We've changed this to be a warning. The message itself is benign. See the referenced BZ for an explanation.
Comment 6 Jiri Locker 2015-11-10 08:34:36 EST

*** This bug has been marked as a duplicate of bug 1263738 ***

Note You need to log in before you can comment on or make changes to this bug.