Bug 1254460 - GUI: In the about window ,License window doesnot close when you click on credit button
GUI: In the about window ,License window doesnot close when you click on cred...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: John Sefler
John Sefler
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-18 04:10 EDT by Shwetha Kallesh
Modified: 2015-11-19 06:50 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 06:50:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Credit button doesnot close the license window when you click on it (127.14 KB, image/png)
2015-10-13 03:27 EDT, Shwetha Kallesh
no flags Details
About window without a credits button (251.41 KB, image/png)
2015-10-13 08:19 EDT, John Sefler
no flags Details
About window with a working Credits button (237.21 KB, image/png)
2015-10-15 16:39 EDT, John Sefler
no flags Details

  None (edit)
Description Shwetha Kallesh 2015-08-18 04:10:38 EDT
Description of problem:
GUI: In the about window ,License window doesnot close when you click on credit button

Version-Release number of selected component (if applicable):
[root@dhcp35-236 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 2.0.6-1
subscription management rules: 5.16
subscription-manager: 1.15.9-6.el7
python-rhsm: 1.15.4-3.el7

How reproducible:


Steps to Reproduce:
1.subscription-manager-gui    --------> help -----> about 
2.Window pops up, click on license button and then click on credits button
3.

Actual results:
License window doesnot close, closes when you click on credits button for the second time

Expected results:
License window should close when you click on credits button 

Additional info:
Comment 4 vritant 2015-09-09 11:39:01 EDT
Latest RHEL 7.2 nightly does not show the Credits button
Comment 5 Shwetha Kallesh 2015-10-13 03:27 EDT
Created attachment 1082289 [details]
Credit button doesnot close the license window when you click on it

Re-opening the bug as I see the credit button now.

[root@dhcp35-36 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.9.51.5-1
subscription management rules: 5.15
subscription-manager: 1.15.9-14.el7
python-rhsm: 1.15.4-5.el7
Comment 6 John Sefler 2015-10-13 08:19 EDT
Created attachment 1082404 [details]
About window without a credits button

It appears that we have a small mystery to solve...

On my RHEL7 system with the same version subscription-manager-gui-1.15.9-14.el7 installed, I do not see a Credits button.
Comment 7 Adrian Likins 2015-10-13 09:23:48 EDT
what versions of gtk3?

rpm -q gtk3

Could this be related to https://bugzilla.gnome.org/show_bug.cgi?id=724411 ?
That was a changed between gtk-3-12 and gtk-3-14.
Comment 8 vritant 2015-10-13 09:50:04 EDT
Shwetha, what versions of gtk3?
Comment 9 Shwetha Kallesh 2015-10-13 09:51:14 EDT
[root@dhcp35-36 ~]# rpm -qa | grep gtk3
avahi-ui-gtk3-0.6.31-15.el7.x86_64
gtk3-immodule-xim-3.14.13-16.el7.x86_64
ibus-gtk3-1.5.3-13.el7.x86_64
spice-gtk3-0.26-5.el7.x86_64
caribou-gtk3-module-0.4.16-1.el7.x86_64
libcanberra-gtk3-0.30-5.el7.x86_64
webkitgtk3-2.4.9-5.el7.x86_64
PackageKit-gtk3-module-1.0.7-5.el7.x86_64
gtk3-3.14.13-16.el7.x86_64
 
On Snapshot4.1 system
Comment 10 Chris Snyder 2015-10-13 10:30:34 EDT
commit 3f9ccc6d5a003edaa4d78f40197323f529242f00
Author: Chris Rog <crog@redhat.com>
Date:   Tue Oct 13 09:46:42 2015 -0400

    1254460: Fixed the credits button in the about dialog in subman GUI
    
    - Clicking the "Credits" button in the about dialog in subman GUI
      now displays generic credits

A fix for this is now in master as of the above commit. The credits button is displayed and the window can still be closed.
Comment 12 John Sefler 2015-10-15 16:39 EDT
Created attachment 1083404 [details]
About window with a working Credits button

Verifying Version...

[root@jsefler-7 ~]# rpm -q subscription-manager-gui
subscription-manager-gui-1.15.9-15.el7.x86_64

[root@jsefler-7 ~]# rpm -qa | grep gtk3
libcanberra-gtk3-0.30-5.el7.x86_64
ibus-gtk3-1.5.3-13.el7.x86_64
caribou-gtk3-module-0.4.16-1.el7.x86_64
avahi-ui-gtk3-0.6.31-15.el7.x86_64
PackageKit-gtk3-module-1.0.7-5.el7.x86_64
gtk3-3.14.13-16.el7.x86_64
spice-gtk3-0.26-5.el7.x86_64
webkitgtk3-2.4.9-5.el7.x86_64
gtk3-immodule-xim-3.14.13-16.el7.x86_64
Comment 13 errata-xmlrpc 2015-11-19 06:50:46 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2122.html

Note You need to log in before you can comment on or make changes to this bug.