Bug 1254471 - fail to delete a snapshot after creating a volume it with RBD driver
fail to delete a snapshot after creating a volume it with RBD driver
Status: CLOSED DUPLICATE of bug 1254470
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder (Show other bugs)
7.0 (Kilo)
x86_64 Linux
high Severity high
: ---
: 8.0 (Liberty)
Assigned To: Eric Harney
nlevinki
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-18 04:22 EDT by Yogev Rabl
Modified: 2016-04-26 09:41 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-21 08:58:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1485897 None None None Never

  None (edit)
Description Yogev Rabl 2015-08-18 04:22:41 EDT
Description of problem:
The deletion of a snapshot fails with the error 

2015-08-18 11:11:39.198 4418 ERROR cinder.volume.manager [req-e721e329-ba76-4088-bce6-dbfb0757fe05 b7bc6cb74f5d4935b8a994d4c4582de2 e577bce6013b4fde98e5e44bc82e7ca1 - - -] Cannot delete snapshot 0b33c534-7f52-4aa5-9fbb-725eb929b771: snapshot is busy

while exists a volume that was created from it. 

Version-Release number of selected component (if applicable):
python-cinder-2015.1.0-3.el7ost.noarch
ceph-common-0.80.8-7.el7cp.x86_64
openstack-cinder-2015.1.0-3.el7ost.noarch
python-cinderclient-1.2.1-1.el7ost.noarch


How reproducible:
100% 

Steps to Reproduce:
1. Create a volume 
2. Take a snapshot of the volume
3. Create a new volume from the snapshot
4. Delete the snapshot 
5. Check the snapshot list

Actual results:
The snapshot stays in a available state

Expected results:
The Cinder client will provide an output that explains why the action failed or set the snapshot with a deleted tag in the Ceph pool and delete the snapshot record in Cinder
Comment 3 Sergey Gotliv 2015-09-21 08:58:00 EDT

*** This bug has been marked as a duplicate of bug 1254470 ***

Note You need to log in before you can comment on or make changes to this bug.