Bug 1254538 - network-throughput: sysctl tuning are not applied
network-throughput: sysctl tuning are not applied
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: tuned (Show other bugs)
7.2
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Jaroslav Škarvada
Tereza Cerna
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-18 06:54 EDT by Jaroslav Škarvada
Modified: 2015-11-19 07:21 EST (History)
5 users (show)

See Also:
Fixed In Version: tuned-2.5.1-3.el7
Doc Type: Bug Fix
Doc Text:
Cause: Previously, sysctl settings were not unquoted before they were applied. Consequence: Tuned could silently fail to apply the quoted sysctl settings. This was especially problem for the network-throughput profile. In this profile the sysctl settings were specified quoted which resulted in this tuning not being applied. Fix: The Tuned code was improved to unquote sysctl settings before there are applied. Result: Now the sysctl settings are correctly applied.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 07:21:59 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaroslav Škarvada 2015-08-18 06:54:00 EDT
Description of problem:
network-throughput: sysctl tunings are not correctly applied because sysctl commands aren't unquoted.

Version-Release number of selected component (if applicable):
tuned-2.5.1-1.el7.noarch

How reproducible:
Always

Steps to Reproduce:
1. tuned-adm profile network-throughput
2. sysctl net.ipv4.tcp_rmem
sysctl net.ipv4.tcp_wmem
sysctl net.ipv4.udp_mem

Actual results:
Settings differ from the profile.

Expected results:
Settings matching the profile.

Additional info:
Comment 1 Jaroslav Škarvada 2015-08-19 08:17:23 EDT
Fixed in upstream commit:
https://git.fedorahosted.org/cgit/tuned.git/commit/?id=efac9c470b2a74da94c92703e87da603bf87296f
Comment 6 errata-xmlrpc 2015-11-19 07:21:59 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2375.html

Note You need to log in before you can comment on or make changes to this bug.