Bug 1254545 - Unable to Redo file to Trash in nautilus
Unable to Redo file to Trash in nautilus
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: nautilus (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Carlos Soriano
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-18 07:20 EDT by Martin Simon
Modified: 2017-02-17 04:28 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-02-17 04:28:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Simon 2015-08-18 07:20:10 EDT
Description of problem:
Undo and Redo works well in case of e.g. renaming files/folders, but the Redo does not work in moving to trash again scenario.

Version-Release number of selected component (if applicable):
nautilus-3.14.3-3.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Press Delete to move any file to the trash
2. Press Control+z to Undo (Restore file from the trash)
3. Try to Redo move file back to the trash) (Control+Shift+z or menu->Redo)

Actual results:
The action is not invoked and the menu does not have the action enabled

Expected results:
The file should end in trash again, the redo should move the file to trash again

Additional info:
If you perform the Undo action and unfold the general menu, you can see that the "Redo Trash" action blinks there for a moment.
Comment 1 Matthias Clasen 2015-08-18 14:08:12 EDT
Hmm, I just tried this here, with nautilus 3.14.3-3.el7, and it worked flawlessly here. Any special circumstances that might make this fail for you ?
Comment 2 Martin Simon 2015-08-19 03:26:58 EDT
I don't think so. This fail was originally observed in beaker environment among our nautilus' automation, and I expect the beaker environment shouldn't be "special". Then, I've successfully reproduced this on my bare metal RHEL7.

The original beaker job is here https://beaker.engineering.redhat.com/jobs/1041067 (test  cases nautilus_Test13_actionRedoMenu and nautilus_Test14_actionRedoShortcut)
Comment 3 David King 2015-08-21 07:59:49 EDT
I can reproduce the bug.

Note You need to log in before you can comment on or make changes to this bug.