Bug 1254552 - X.org: segmentation fault when X -configure called - NULL pointer dereference
X.org: segmentation fault when X -configure called - NULL pointer dereference
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: xorg-x11-server (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Adam Jackson
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-18 07:39 EDT by Robin Hack
Modified: 2016-11-03 22:49 EDT (History)
4 users (show)

See Also:
Fixed In Version: xorg-x11-server-1.17.2-18.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-03 22:49:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robin Hack 2015-08-18 07:39:17 EDT
Description of problem:
I tried to run X -configure with my configuration and result is segmentation fault.

Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.15.0-33.el7_1.x86_64

How reproducible:
always

Steps to Reproduce:
1. run X -configure


Actual results:
[root@sheep-2 ~]# X -configure

X.Org X Server 1.15.0
Release Date: 2013-12-27
X Protocol Version 11, Revision 0
Build Operating System:  2.6.32-504.12.2.el6.x86_64 
Current Operating System: Linux sheep-2.lab.eng.brq.redhat.com 3.10.0-229.el7.x86_64 #1 SMP Thu Jan 29 18:37:38 EST 2015 x86_64
Kernel command line: BOOT_IMAGE=/vmlinuz-3.10.0-229.el7.x86_64 root=/dev/mapper/rhel_sheep--2-root ro console=ttyS0 crashkernel=auto rd.lvm.lv=rhel_sheep-2/root elevator=noop console=tty0 rd.lvm.lv=rhel_sheep-2/swap LANG=en_US.UTF-8
Build Date: 26 March 2015  09:51:53AM
Build ID: xorg-x11-server 1.15.0-33.el7_1 
Current version of pixman: 0.32.4
	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Tue Aug 18 13:36:45 2015
List of video drivers:
	vesa
(++) Using config file: "/root/xorg.conf.new"
(==) Using config directory: "/etc/X11/xorg.conf.d"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
vesa: Ignoring device with a bound kernel driver
(EE) 
(EE) Backtrace:
(EE) 0: X (xorg_backtrace+0x55) [0x7f1db3afb795]
(EE) 1: X (0x7f1db394c000+0x1b3539) [0x7f1db3aff539]
(EE) 2: /lib64/libc.so.6 (0x7f1db1307000+0x35650) [0x7f1db133c650]
(EE) 
(EE) Segmentation fault at address 0x0
(EE) 
Fatal server error:
(EE) Caught signal 11 (Segmentation fault). Server aborting
(EE) 
(EE) 
Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help. 
(EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
(EE) 
(EE) Server terminated with error (1). Closing log file.
Aborted


Expected results:
No segfault.

Additional info:
It's beaker virtual machine with hw configuration:
sheep-2.lab.eng.brq.redhat.com
    description: Computer
    product: KVM
    vendor: Red Hat
    version: RHEL 7.0.0 PC (i440FX + PIIX, 1996)
    width: 64 bits
    capabilities: smbios-2.4 dmi-2.4 vsyscall32
    configuration: boot=normal family=Red Hat Enterprise Linux uuid=ABCB9EE2-A56C-487E-8A31-8378CE3CD5A1
  *-core
       description: Motherboard
       physical id: 0
     *-firmware
          description: BIOS
          vendor: Seabios
          physical id: 0
          version: 0.5.1
          date: 01/01/2011
          size: 96KiB
     *-cpu
          description: CPU
          product: Intel(R) Xeon(R) CPU E5-2620 v2 @ 2.10GHz
          vendor: Intel Corp.
          physical id: 401
          bus info: cpu@0
          slot: CPU 1
          size: 2GHz
          capacity: 2GHz
          width: 64 bits
          capabilities: fpu fpu_exception wp vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ss syscall nx pdpe1gb rdtscp x86-64 constant_tsc arch_perfmon rep_good nopl eagerfpu pni pclmulqdq ssse3 cx16 pcid sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer aes xsave avx f16c rdrand hypervisor lahf_lm xsaveopt fsgsbase smep erms
     *-memory
          description: System Memory
          physical id: 1000
          size: 3GiB
          capacity: 3GiB
        *-bank
             description: DIMM RAM
             physical id: 0
             slot: DIMM 0
             size: 3GiB
             width: 64 bits
     *-pci
          description: Host bridge
          product: 440FX - 82441FX PMC [Natoma]
          vendor: Intel Corporation
          physical id: 100
          bus info: pci@0000:00:00.0
          version: 02
          width: 32 bits
          clock: 33MHz
        *-isa
             description: ISA bridge
             product: 82371SB PIIX3 ISA [Natoma/Triton II]
             vendor: Intel Corporation
             physical id: 1
             bus info: pci@0000:00:01.0
             version: 00
             width: 32 bits
             clock: 33MHz
             capabilities: isa
             configuration: latency=0
        *-ide
             description: IDE interface
             product: 82371SB PIIX3 IDE [Natoma/Triton II]
             vendor: Intel Corporation
             physical id: 1.1
             bus info: pci@0000:00:01.1
             version: 00
             width: 32 bits
             clock: 33MHz
             capabilities: ide bus_master
             configuration: driver=ata_piix latency=0
             resources: irq:0 ioport:1f0(size=8) ioport:3f6 ioport:170(size=8) ioport:376 ioport:c0e0(size=16)
        *-usb
             description: USB controller
             product: 82371SB PIIX3 USB [Natoma/Triton II]
             vendor: Intel Corporation
             physical id: 1.2
             bus info: pci@0000:00:01.2
             version: 01
             width: 32 bits
             clock: 33MHz
             capabilities: uhci bus_master
             configuration: driver=uhci_hcd latency=0
             resources: irq:11 ioport:c040(size=32)
           *-usbhost
                product: UHCI Host Controller
                vendor: Linux 3.10.0-229.el7.x86_64 uhci_hcd
                physical id: 1
                bus info: usb@1
                logical name: usb1
                version: 3.10
                capabilities: usb-1.10
                configuration: driver=hub slots=2 speed=12Mbit/s
              *-usb
                   description: Mouse
                   product: QEMU USB Tablet
                   vendor: QEMU
                   physical id: 1
                   bus info: usb@1:1
                   version: 0.00
                   serial: 42
                   capabilities: usb-2.00
                   configuration: driver=usbhid maxpower=100mA speed=12Mbit/s
        *-bridge
             description: Bridge
             product: 82371AB/EB/MB PIIX4 ACPI
             vendor: Intel Corporation
             physical id: 1.3
             bus info: pci@0000:00:01.3
             version: 03
             width: 32 bits
             clock: 33MHz
             capabilities: bridge
             configuration: driver=piix4_smbus latency=0
             resources: irq:9
        *-display
             description: VGA compatible controller
             product: QXL paravirtual graphic card
             vendor: Red Hat, Inc.
             physical id: 2
             bus info: pci@0000:00:02.0
             version: 04
             width: 32 bits
             clock: 33MHz
             capabilities: vga_controller rom
             configuration: driver=qxl latency=0
             resources: irq:10 memory:f4000000-f7ffffff memory:f8000000-fbffffff memory:fc054000-fc055fff ioport:c060(size=32) memory:fc040000-fc04ffff
        *-network
             description: Ethernet interface
             product: Virtio network device
             vendor: Red Hat, Inc
             physical id: 3
             bus info: pci@0000:00:03.0
             logical name: eth0
             version: 00
             serial: da:36:d0:6e:50:02
             width: 32 bits
             clock: 33MHz
             capabilities: msix bus_master cap_list rom ethernet physical
             configuration: broadcast=yes driver=virtio_net driverversion=1.0.0 ip=10.34.88.2 latency=0 link=yes multicast=yes
             resources: irq:10 ioport:c080(size=32) memory:fc056000-fc056fff memory:fc000000-fc03ffff
        *-multimedia
             description: Audio device
             product: 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller
             vendor: Intel Corporation
             physical id: 4
             bus info: pci@0000:00:04.0
             version: 01
             width: 32 bits
             clock: 33MHz
             capabilities: msi bus_master cap_list
             configuration: driver=snd_hda_intel latency=0
             resources: irq:47 memory:fc050000-fc053fff
        *-communication
             description: Communication controller
             product: Virtio console
             vendor: Red Hat, Inc
             physical id: 5
             bus info: pci@0000:00:05.0
             version: 00
             width: 32 bits
             clock: 33MHz
             capabilities: msix bus_master cap_list
             configuration: driver=virtio-pci latency=0
             resources: irq:11 ioport:c0a0(size=32) memory:fc057000-fc057fff
        *-scsi
             description: SCSI storage controller
             product: Virtio block device
             vendor: Red Hat, Inc
             physical id: 6
             bus info: pci@0000:00:06.0
             version: 00
             width: 32 bits
             clock: 33MHz
             capabilities: scsi msix bus_master cap_list
             configuration: driver=virtio-pci latency=0
             resources: irq:10 ioport:c000(size=64) memory:fc058000-fc058fff
        *-generic
             description: Unclassified device
             product: Virtio memory balloon
             vendor: Red Hat, Inc
             physical id: 7
             bus info: pci@0000:00:07.0
             version: 00
             width: 32 bits
             clock: 33MHz
             capabilities: bus_master
             configuration: driver=virtio-pci latency=0
             resources: irq:10 ioport:c0c0(size=32)


Installed xorg packages:
xorg-x11-xkb-utils-7.7-9.1.el7.x86_64
xorg-x11-server-Xvfb-1.15.0-33.el7_1.x86_64
xorg-x11-xauth-1.0.7-6.1.el7.x86_64
xorg-x11-server-utils-7.7-4.el7.x86_64
xorg-x11-server-common-1.15.0-33.el7_1.x86_64
xorg-x11-drv-vesa-2.3.2-14.el7.x86_64
xorg-x11-xinit-1.3.2-14.el7.x86_64
xorg-x11-font-utils-7.5-18.1.el7.x86_64
xorg-x11-server-Xorg-1.15.0-33.el7_1.x86_64
xorg-x11-server-Xnest-1.15.0-33.el7_1.x86_64
Comment 1 Robin Hack 2015-08-18 07:41:00 EDT
UPDATE: I didn't change anything. So please ignore: with my configuration part of first sentence :).
Comment 3 Olivier Fourdan 2015-08-28 07:36:28 EDT
I just tried running "X -configure" from a kvm virtual machine running el7.2 and all went fine.

el7.2 has a rebased version of Xorg and its drivers, would it be possible for you to try with a current compose of Red Hat Enterprise Linux 7.2 to see if the issue still occurs?
Comment 10 errata-xmlrpc 2016-11-03 22:49:53 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2293.html

Note You need to log in before you can comment on or make changes to this bug.