Bug 1254585 - traceback with pyOpenSSL.noarch 0.15.1-1.fc22
traceback with pyOpenSSL.noarch 0.15.1-1.fc22
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pyOpenSSL (Show other bugs)
22
Unspecified Unspecified
urgent Severity urgent
: ---
: ---
Assigned To: Tomas Mraz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-18 09:05 EDT by Tomáš Hozza
Modified: 2015-12-03 16:52 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-18 10:05:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomáš Hozza 2015-08-18 09:05:37 EDT
Description of problem:
After running 'dnf update' fedpkg ends always with traceback:

$ fedpkg 
Traceback (most recent call last):
  File "/usr/bin/fedpkg", line 13, in <module>
    from fedpkg.__main__ import main
  File "/usr/lib/python2.7/site-packages/fedpkg/__init__.py", line 12, in <module>
    import pyrpkg
  File "/usr/lib/python2.7/site-packages/pyrpkg/__init__.py", line 23, in <module>
    import koji
  File "/usr/lib/python2.7/site-packages/koji/__init__.py", line 47, in <module>
    import ssl.SSLCommon
  File "/usr/lib/python2.7/site-packages/koji/ssl/SSLCommon.py", line 18, in <module>
    from OpenSSL import SSL
  File "/usr/lib/python2.7/site-packages/OpenSSL/__init__.py", line 8, in <module>
    from OpenSSL import rand, crypto, SSL
  File "/usr/lib/python2.7/site-packages/OpenSSL/SSL.py", line 10, in <module>
    from six import int2byte, indexbytes
ImportError: cannot import name indexbytes


The issue seems to be in rpkg.

Version-Release number of selected component (if applicable):
fedpkg-1.20-1.fc22.noarch
pyOpenSSL-0.15.1-1.fc22.noarch
pyrpkg-1.36-1.fc22.noarch

How reproducible:
always

Steps to Reproduce:
1. update F22
2. run any fedpkg command

Actual results:
traceback

Expected results:
no traceback

Additional info:
Comment 1 Tomáš Hozza 2015-08-18 09:18:29 EDT
Seems to be rather pyOpenSSL issue:

$ python2 -c 'from OpenSSL import rand, crypto, SSL'
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/usr/lib/python2.7/site-packages/OpenSSL/__init__.py", line 8, in <module>
    from OpenSSL import rand, crypto, SSL
  File "/usr/lib/python2.7/site-packages/OpenSSL/SSL.py", line 10, in <module>
    from six import int2byte, indexbytes
ImportError: cannot import name indexbytes
Comment 2 Tomáš Hozza 2015-08-18 10:05:08 EDT
It seems that the reinstall of python-six solved the issue for me... Not sure what was the cause.
Comment 3 Luis Pabón 2015-12-03 16:52:15 EST
I found the same issue and reinstalling python-six also solved it.  I wonder what is going on?

Note You need to log in before you can comment on or make changes to this bug.