Bug 1254588 - AMQP 1.0 jms client hangs when another reconnect should happen on the same MRGM broker
AMQP 1.0 jms client hangs when another reconnect should happen on the same MR...
Status: CLOSED ERRATA
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-java (Show other bugs)
3.2
Unspecified Unspecified
unspecified Severity high
: 3.2
: ---
Assigned To: Robbie Gemmell
Michal Toth
:
Depends On:
Blocks: 1215806
  Show dependency treegraph
 
Reported: 2015-08-18 09:18 EDT by Michal Toth
Modified: 2016-10-10 12:24 EDT (History)
4 users (show)

See Also:
Fixed In Version: qpid-jms-0.5.0-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-08 09:11:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker ENTMQCL-12 Major Closed AMQP 1.0 jms client hangs when another reconnect should happen on the same MRGM broker 2016-10-10 12:24 EDT

  None (edit)
Description Michal Toth 2015-08-18 09:18:40 EDT
Note: Using qpid-java as component (but referring to the latest pacakged qpid-jms-client 0.3.0)
Comment 1 Michal Toth 2015-08-18 09:23:31 EDT
Qpid-jms-client hangs in a second and subsequent failover reconnect attempt on the same MRG-M broker, with "Transport connection remotely closed". No error is reported and client keeps running.
Comment 2 JBoss JIRA Server 2015-08-24 10:48:52 EDT
Robbie Gemmell <rgemmell@redhat.com> updated the status of jira ENTMQCL-12 to Coding In Progress
Comment 3 Robbie Gemmell 2015-08-25 11:03:15 EDT
Changes made upstream look to resolve this. See JIRA ENTMQCL-12 for more comments.

Moving to POST until decided on a backport or rebase etc.
Comment 4 Michal Toth 2015-09-01 07:25:55 EDT
Manually verified using qpid-jms-client-0.5.0-1.el6/7 against MRG-M broker.
Apart from incorrect number of received messages in destination by broker, the reconnect feature is working correctly. 

Marking original issue as verified. For incorrect number of messages, see
Bug 1087828
Comment 5 JBoss JIRA Server 2015-09-02 05:12:55 EDT
Robbie Gemmell <rgemmell@redhat.com> updated the status of jira ENTMQCL-12 to Resolved
Comment 7 errata-xmlrpc 2015-10-08 09:11:06 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-1879.html
Comment 8 JBoss JIRA Server 2016-08-12 06:25:40 EDT
Michal Toth <mtoth@redhat.com> updated the status of jira ENTMQCL-12 to Closed
Comment 9 JBoss JIRA Server 2016-10-10 12:24:13 EDT
Justin Ross <jross@redhat.com> updated the status of jira ENTMQCL-12 to Reopened
Comment 10 JBoss JIRA Server 2016-10-10 12:24:48 EDT
Justin Ross <jross@redhat.com> updated the status of jira ENTMQCL-12 to Closed

Note You need to log in before you can comment on or make changes to this bug.