Bug 1254590 - AMQP 1.0 jms client ignores failover.useReconnectBackOff value
AMQP 1.0 jms client ignores failover.useReconnectBackOff value
Status: CLOSED NOTABUG
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-java (Show other bugs)
3.2
Unspecified Unspecified
unspecified Severity medium
: 3.2
: ---
Assigned To: Robbie Gemmell
Messaging QE
:
Depends On:
Blocks: 1215806
  Show dependency treegraph
 
Reported: 2015-08-18 09:21 EDT by Michal Toth
Modified: 2015-09-28 09:26 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-20 11:40:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker ENTMQCL-13 Minor Closed AMQP 1.0 jms client ignores failover.useReconnectBackOff value 2015-10-05 17:14 EDT

  None (edit)
Description Michal Toth 2015-08-18 09:21:34 EDT
Note: Using qpid-java as component (but referring to the latest pacakged qpid-jms-client 0.3.0).
See more information in a linked JIRA
"When client (re)connects using ReconnectBackOff set to false/0/off - this value is always ignored and default value of 2 of reconnectBackOffMultiplier is used.
Also failover.reconnectBackOffMultiplier is ignored when reconnectBackOff is set to true."
Comment 1 Robbie Gemmell 2015-08-19 10:22:12 EDT
( Copy of comment from: https://issues.jboss.org/browse/ENTMQCL-13?focusedCommentId=13099846&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-13099846 )


I believe this is because the URI being used isnt in the documented format (e.g detailed at: http://qpid.apache.org/releases/qpid-jms-0.4.0/docs/index.html#failover-configuration-options).

The documented format looks like:
{noformat}
failover:(brokerURI1[,brokerURI2])?<failover.options>&<failover.nested.options>
{noformat}

whereas the format being used here is:
{noformat}
failover:amqp://localhost:5672?<jms.options>&<failover.options>.
{noformat}

In the above case it isnt distinguishable [without the documented use of parethesis] that the stuff after the ? isn't part of the broker URI, and so it had no effect on the failover layer but was instead treated as part of the broker uri. The 'failover.' options were presumably then not collected for use by the JMS/transport layers when given the URI because they dont match the relevant prefix those layers use.

Adding the parethesis as documented should get things going.
Comment 2 JBoss JIRA Server 2015-08-20 07:07:15 EDT
Michal Toth <mtoth@redhat.com> updated the status of jira ENTMQCL-13 to Closed
Comment 3 Robbie Gemmell 2015-08-20 11:40:06 EDT
Closing BZ to match the JIRA, Michal confirmed things work with the URI update.

Note You need to log in before you can comment on or make changes to this bug.