Bug 1254610 - [RFE] add man page for ceph-installer
Summary: [RFE] add man page for ceph-installer
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Storage Console
Classification: Red Hat
Component: ceph-installer
Version: 2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 2
Assignee: Andrew Schoen
QA Contact: ceph-qe-bugs
URL:
Whiteboard:
Depends On: 1165308
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-08-18 13:50 UTC by Ken Dreyer (Red Hat)
Modified: 2017-01-06 20:11 UTC (History)
11 users (show)

Fixed In Version: RHEL: ceph-installer-1.0.10-2.el7cp
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 19:47:36 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1754 normal SHIPPED_LIVE New packages: Red Hat Storage Console 2.0 2017-04-18 19:09:06 UTC

Description Ken Dreyer (Red Hat) 2015-08-18 13:50:26 UTC
Description of problem:
rpmdiff warns that there is no man page for /usr/sbin/rhcs-installer

Version-Release number of selected component (if applicable):
rhcs-installer-0.1.0-1.el7cp

Steps to Reproduce:
1. yum install rhcs-installer
2. man rhcs-installer

Actual results:
man exits with an error: "No manual entry for rhcs-installer"

Expected results:
man page displays

Comment 7 Ken Dreyer (Red Hat) 2016-02-29 17:14:53 UTC
In RHCS 2, the rhcs-installer has been replaced with /usr/bin/ceph-installer. We need a man page for this utility.

Comment 10 Andrew Schoen 2016-05-10 14:53:29 UTC
I've opened a PR for this: https://github.com/ceph/ceph-installer/pull/148

Comment 11 Ken Dreyer (Red Hat) 2016-05-10 16:34:48 UTC
I've tested a local RPM build here with this patch and it works: https://github.com/ceph/ceph-installer/pull/150

Comment 12 monti lawrence 2016-05-10 20:13:25 UTC
Comment 11: Needs to get merged.

Comment 13 Ken Dreyer (Red Hat) 2016-05-11 17:00:51 UTC
This will be in the next ceph-installer upstream release (v1.0.10)

Comment 14 Ken Dreyer (Red Hat) 2016-05-11 19:00:52 UTC
Ali would you please build v1.0.10 in Brew?

You can also make this change in the downstream ceph-installer.spec: https://github.com/ceph/ceph-installer/commit/c0746a25b06b008ce671eed14e5fb08e2c46ce0d

Comment 15 Ken Dreyer (Red Hat) 2016-05-12 22:22:26 UTC
Removing FutureFeature. This is technically an RFE, but it doesn't really fit the definition of a full product feature needing PM input IMO.

Comment 16 Ken Dreyer (Red Hat) 2016-05-13 02:53:41 UTC
Ali, would you please set the "Fixed In Version:" field to the NVR where this bug was fixed? For example "ceph-installer-1.0.10-2.el7cp"

Comment 19 Martin Kudlej 2016-06-21 11:48:03 UTC
I've filed bug 1348528 for differences between man page and help message. But man page does exist so -> VERIFIED

Comment 21 errata-xmlrpc 2016-08-23 19:47:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1754


Note You need to log in before you can comment on or make changes to this bug.