Bug 1254615 - Dell PowerEdge c6220 hangs on localboot after being provisioned by Satellite 6.1
Dell PowerEdge c6220 hangs on localboot after being provisioned by Satellite 6.1
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: syslinux (Show other bugs)
7.1
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Peter Jones
Release Test Team
:
Depends On:
Blocks: 1254623 1236373
  Show dependency treegraph
 
Reported: 2015-08-18 09:52 EDT by Jason Montleon
Modified: 2016-11-04 00:41 EDT (History)
6 users (show)

See Also:
Fixed In Version: 4.05-13
Doc Type: Bug Fix
Doc Text:
Cause: The firmware on the machine in question stores some of its data in an incorrect location. Consequence: When we use that location, it keeps the firmware from working right later. Fix: We move the firmware's data out of the way and put it back when we're done. Result: No crashy crashy.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 00:41:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Montleon 2015-08-18 09:52:19 EDT
Description of problem:
Satellite 6.1 expects that hosts boot to network so they can be povisioned. After they are provisioned the PXE config for the host is replaced with one that simply does '.localboot 0'. This is done so that if the user wants to rebuild the host they can just click a button, reboot, and reprovision.

However, (probably admittedly due to a bad firmware) these servers simply hang after the PXE timeout when they should boot to local disk.

Version-Release number of selected component (if applicable):
syslinux-4.05-12.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Set up Satellite or RHCI
2. Provsion a Dell PE c6220
3. Let it reboot

Actual results:
System hangs

Expected results:
System boots normally

Additional info:
This is the issue:
http://www.syslinux.org/wiki/index.php/Hardware_Compatibility#LOCALBOOT_on_Dell_PowerEdge_c6220

This workaround does admittedly work, however it would be nice if the system would work as expected without manual intervention and save users frustration:
http://www.syslinux.org/wiki/index.php/Hardware_Compatibility#LOCALBOOT

Either backporting the patch or updating syslinux to > 4.10-pre22 would probably resolve the issue.
Comment 2 Tzach Shefi 2015-08-25 02:02:38 EDT
Adding debugging info, flashing BIOS from 1.1.19 to -> 2.5.3 doesn't resolve.
Comment 6 Peter Jones 2016-05-10 09:31:34 EDT
This should be fixed in syslinux-4.05-13 .
Comment 9 Jason Montleon 2016-09-19 08:23:29 EDT
Our QE team no longer has the hardware to test with. It has been replaced with newer HP servers, so unfortunately we can't test.
Comment 10 Michal Kovarik 2016-09-19 08:56:04 EDT
We do not have access to machine, verifying as SanityOnly. Patch '[PATCH] Save Dell BIOS chunk in PXELINUX' is included in source rpm of syslinux-4.05-13.el7.
Comment 12 errata-xmlrpc 2016-11-04 00:41:35 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2366.html

Note You need to log in before you can comment on or make changes to this bug.