Bug 1254619 - BEDTools installation error
BEDTools installation error
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: BEDTools (Show other bugs)
22
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Adam Huffman
Fedora Extras Quality Assurance
:
: 1262838 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-18 10:02 EDT by Tony Schreiner
Modified: 2015-09-15 15:50 EDT (History)
2 users (show)

See Also:
Fixed In Version: 2.25.0-1.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-15 15:50:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tony Schreiner 2015-08-18 10:02:33 EDT
Description of problem:
With update to 2.24.0-5.fc22, the installation/update fails with
Error: Transaction check error:
  file /usr/bin from install of BEDTools-2.24.0-5.fc22.x86_64 conflicts with file from package filesystem-3.2-32.fc22.x86_64


Version-Release number of selected component (if applicable):
2.24.0-5.fc22

How reproducible:
Every time

Steps to Reproduce:
1. install or update BEDTools with dnf
2.
3.

Actual results:
Error: Transaction check error:
  file /usr/bin from install of BEDTools-2.24.0-5.fc22.x86_64 conflicts with file from package filesystem-3.2-32.fc22.x86_64


Expected results:
Successful installation

Additional info:
/usr/bin should not be claimed by this tool, suggest change to spec file
diff {a,b}/BEDTools.spec
99c99
< %{_bindir}*
---
> %{_bindir}/*
Comment 1 Fedora Update System 2015-08-23 08:15:18 EDT
BEDTools-2.24.0-6.fc22 has been submitted as an update to Fedora 22. https://bugzilla.redhat.com/show_bug.cgi?id=1254619
Comment 2 Fedora Update System 2015-08-23 13:19:37 EDT
BEDTools-2.24.0-6.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update BEDTools'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-14014
Comment 3 Fedora Update System 2015-09-06 17:48:50 EDT
BEDTools-2.25.0-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-15234
Comment 4 Fedora Update System 2015-09-07 14:19:38 EDT
BEDTools-2.25.0-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update BEDTools'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-15234
Comment 5 Adam Huffman 2015-09-15 01:46:41 EDT
*** Bug 1262838 has been marked as a duplicate of this bug. ***
Comment 6 Fedora Update System 2015-09-15 15:50:28 EDT
BEDTools-2.25.0-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.