Bug 1254662 - Regression: replace operation is not being replicated.
Regression: replace operation is not being replicated.
Status: CLOSED DUPLICATE of bug 1251288
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: 389-ds-base (Show other bugs)
6.8
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Noriko Hosoi
Viktor Ashirov
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-18 11:25 EDT by German Parente
Modified: 2015-08-18 11:41 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-18 11:41:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description German Parente 2015-08-18 11:25:11 EDT
Description of problem:

it seems a simple replace operation which is rather an attribute deletion is not replicated rightly.

the operation is replicated but the attribute is not deleted in the consumer.

I have tested it in release 50 where it's working fine. Then, updated to 60 release and it stops working.


Version-Release number of selected component (if applicable): 
rpm -qa | grep 389-ds-base
389-ds-base-1.2.11.15-60.el6.x86_64



I have tried to find any relevant bug but couldn't find but this one which is already fixed:

https://bugzilla.redhat.com/show_bug.cgi?id=1097002
https://fedorahosted.org/389/ticket/47764




How reproducible:

always (for me).

Steps to Reproduce:

1. two nodes in MMR.

2. do any operation of this sort:

ldapmodify 
dn: <some dn>
changetype: modify
replace: attr

Actual results:

the operation is taking place in master but it's not replicated.


Expected results:

the attribute should also be deleted in replica.


Additional info:

in audit logs we can see:

supplier:
=========

time: 20150818164156
dn: cn=user1,ou=people,o=redhat
changetype: modify
replace: mail
-
replace: modifiersname
modifiersname: cn=directory manager
-
replace: modifytimestamp
modifytimestamp: 20150818144156Z
-
replace: entryusn
entryusn: 5


consumer:
=========

time: 20150818164158
dn: cn=user1,ou=people,o=redhat
changetype: modify
replace: modifiersName
modifiersName: cn=directory manager
-
replace: modifyTimestamp
modifyTimestamp: 20150818144156Z
-
Comment 2 German Parente 2015-08-18 11:41:01 EDT

*** This bug has been marked as a duplicate of bug 1251288 ***

Note You need to log in before you can comment on or make changes to this bug.